Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

The Win16 Subsystem was unable to enter protected


  • Please log in to reply

#1
margaritabay

margaritabay

    New Member

  • Member
  • Pip
  • 2 posts
I had the same error as some others:" The Win16 Subsystem was unable to enter protected mode, DOSX.exe must be in your AUTOEXEC.NT and present in your path". when attempting to load a few programs.

I followed the fixes from post 4547 and 4389. The himem.sys now appears in my directory, but dosx.exe does not. Here is the entire directory list:
@echo off

REM AUTOEXEC.BAT is not used to initialize the MS-DOS environment.
REM AUTOEXEC.NT is used to initialize the MS-DOS environment unless a
REM different startup file is specified in an application's PIF.

REM Install CD ROM extensions
lh %SystemRoot%\system32\mscdexnt.exe

REM Install network redirector (load before dosx.exe)
lh %SystemRoot%\system32\redir

REM Install DPMI support
lh %SystemRoot%\system32\dosx

REM The following line enables Sound Blaster 2.0 support on NTVDM.
REM The command for setting the BLASTER environment is as follows:
REM SET BLASTER=A220 I5 D1 P330
REM where:
REM A specifies the sound blaster's base I/O port
REM I specifies the interrupt request line
REM D specifies the 8-bit DMA channel
REM P specifies the MPU-401 base I/O port
REM T specifies the type of sound blaster card
REM 1 - Sound Blaster 1.5
REM 2 - Sound Blaster Pro I
REM 3 - Sound Blaster 2.0
REM 4 - Sound Blaster Pro II
REM 6 - SOund Blaster 16/AWE 32/32/64
REM
REM The default value is A220 I5 D1 T3 and P330. If any of the switches is
REM left unspecified, the default value will be used. (NOTE, since all the
REM ports are virtualized, the information provided here does not have to
REM match the real hardware setting.) NTVDM supports Sound Blaster 2.0 only.
REM The T switch must be set to 3, if specified.
SET BLASTER=A220 I5 D1 P330 T3

REM To disable the sound blaster 2.0 support on NTVDM, specify an invalid
REM SB base I/O port address. For example:
REM SET BLASTER=A0
lh %SystemRoot%\system32\dosx.exe


Any ideas????

Mucho thanks!!!
  • 0

Advertisements


#2
-=jonnyrotten=-

-=jonnyrotten=-

    Member 2k

  • Retired Staff
  • 2,678 posts
So have you seen these instructions then?

Go to "My Computer" and double click your hard drive (usually c:\). Next double click "windows", double click "system32" and find the file named config.nt Right click the file and click "open". Pick "Choose the program from a list". Pick notepad Scroll down to the bottom of the text and enter the line shown below:

device=%systemroot%\system32\himem.sys

DO NOT ADD REM AT THE BEGINNING

Click 'File' at the top left of the window and click "Save" close the window.


Next find the file named autoexec.nt in the system32 folder also.
Right click the file and click "open". Pick "Choose the program from a list". Pick notepad Scroll down to the bottom of the text and enter the line shown below:

lh %systemroot%\system32\dosx.exe

DO NOT ADD REM AT THE BEGINNING

Click 'File' at the top left of the window and click "Save" close the window.

-=jonnyrotten=- :tazz:
  • 0

#3
margaritabay

margaritabay

    New Member

  • Topic Starter
  • Member
  • Pip
  • 2 posts
Yes, those are the proceedures I followed. I have some registry errors that are rather old that Norton registry scan cannot fix. i wonder if they have anything to do with why the fix will not work.
ty
Margaritabay
  • 0

#4
admin

admin

    Founder Geek

  • Administrator
  • 24,504 posts
%SystemRoot%\ is a variable. It's suposed to be replaced, depending on your system configuration.

If you have Windows 95/98 or ME installed on drice C: it's C:\Windows\System

If you have NT\2000\or XP it's C:\Windows\System32
  • 0

#5
vtori

vtori

    New Member

  • Member
  • Pip
  • 1 posts
Hello, i had the same problem. I went throught the instructions to add dosx.exe and himem.sys to system 32. Only when i checked system 32 file afterwards the files that were present are just dosx and himem not dosx.exe and himem.sys. i am still getting the same message. I followed the instructions to a T so not sure what went wrong.

can you help? thanks :)
  • 0






Similar Topics

1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP