Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

file type icons error


  • Please log in to reply

#1
camelgrass

camelgrass

    Member

  • Member
  • PipPip
  • 15 posts
I am having trouble with HTM/HTML file icons, they display as the plain old white icon - the type you get in Windows when there is no related program even though I have Firefox set as the default browser and default program for HTM/HTML files.

I have tried reinstalling Firefox but that makes no difference.

Re-registering the file type under Folder Options>File Types with either IE or Firefox doesn't change the icon even after computer restart.

Also strange that in IE under Internet Options>Programs there is nothing listed as HTML Editor and no programs available in the drop-down box.

Also just noticed that the folder ShellIconCache is missing from my %systemroot% folder even after computer restart.

Any ideas?

Thanking you,

Marty
  • 0

Advertisements


#2
simplejohn

simplejohn

    Member

  • Member
  • PipPip
  • 21 posts
Hey
Open your windows explorer, click on tools menu and select folder options.
Select the file type tab, and there you can select the file type, associate it with any
program you want and set it's icon.
Good Luck
_______________
The greatest mistake you can make in life is to be continually fearing you will make one
Don't let it be the reason of missing your opportunity to play online casino

  • 0

#3
camelgrass

camelgrass

    Member

  • Topic Starter
  • Member
  • PipPip
  • 15 posts
Thanks for your reply but I tried that already and it didn't work.

I think my problem has to do with the missing ShellIconCache folder in the %systemroot% folder.

Any help greatly appreciated.

Marty


Hey
Open your windows explorer, click on tools menu and select folder options.
Select the file type tab, and there you can select the file type, associate it with any
program you want and set it's icon.
Good Luck
_______________
The greatest mistake you can make in life is to be continually fearing you will make one
Don't let it be the reason of missing your opportunity to play online casino

View Post


  • 0

#4
Guest_Tony_*

Guest_Tony_*
  • Guest
Hey camelgrass,

Welcome to Geeks To Go, my name is Tony.

Have you checked your computer for Malware? If not Please Click here and follow the instructions carefully.
  • 0

#5
Michael

Michael

    Retired Staff

  • Retired Staff
  • 1,869 posts

Thanks for your reply but I tried that already and it didn't work.

I think my problem has to do with the missing ShellIconCache folder in the %systemroot% folder.

Any help greatly appreciated.

Marty

View Post



Can find C:\Windows\system32\SHELL32.dll if you can't find it, than what you said is true. I will send you a copy if you need it. I doubt that this is true, because it would affect a lot more that you internet shortcuts. Many some malware is doing affecting it. Read This and post Here to see if this it true. I know it sound over the top, but it is you internet short cuts and so it might be what it is.
  • 0

#6
camelgrass

camelgrass

    Member

  • Topic Starter
  • Member
  • PipPip
  • 15 posts

Can find C:\Windows\system32\SHELL32.dll if you can't find it, than what you said is true. I will send you a copy if you need it.  I doubt that this is true, because it would affect a lot more that you internet shortcuts.  Many some malware is doing affecting it.  Read This and post Here  to see if this it true.  I know it sound over the top, but it is you internet short cuts and so it might be what it is.

View Post

Hey Michael you live just down the road from me! Thanks for your reply.

By the way, the file C:\Windows\system32\SHELL32.dll was on my system. The file that was missing was C:\Documents and Settings\%userprofile%\Local Settings\Application Data\IconCache.db.

After nearly a whole day of non-stop problem solving in regards to a simple problem and what I thought had a simple solution I have finally fixed the .HTM and .HTML icon problem.

I tried everything including reinstalling Firefox, using the Rebuild Icons feature of Tweak UI Powertoy for Windows XP, running System File Checker, removing Internet Explorer component and then adding back to XP, changing settings in Folder Options > File Types.

I also tried some registry fixes that I found on a WinXP help site.

After exhausting all these avenues and with no result I decided to really get stuck into the registry and after backing up I deleted completely the following keys:

HKEY_CLASSES_ROOT\.htm
HKEY_CLASSES_ROOT\.html
HKEY_CLASSES_ROOT\FirefoxHTML
HKEY_CLASSES_ROOT\htmlfile
HKEY_CURRENT_USER\Software\Mozilla\Mozilla
HKEY_CURRENT_USER\Software\Mozilla\Mozilla Firefox
HKEY_CURRENT_USER\Software\Mozilla\Mozilla Firefox 1.0.7

I also deleted the values in these keys:

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.htm\OpenWithList
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.html\OpenWithList

There were some others that I can't recall as well.

(I'm definitely no Windows expert and so it was a bit of trial and error but most of the deleted keys seem to be replaced with fresh values on computer restart).

Restarted the computer, reinstalled Firefox and set it as default browser. Problem finally resolved.

Oh Mr Gates why do you create such feeble OS's!

Cheers,

Marty

Edited by camelgrass, 29 September 2005 - 09:00 AM.

  • 0

#7
MSG Archvist

MSG Archvist

    New Member

  • Member
  • Pip
  • 1 posts
Same HTM HTML issue on Windows 7 x64 using IE8. Affected only Explorer views.

My solution for the issue was to force IE8 to be the default browser even though it already was the default browser.

Exit your Explorer session(s). Go to IE8 tools, Internet Options, Programs, Check the "Tell Me ....." in the Default Browser box, apply the change and exit the browser session.

Start the browser session back up and you should be asked if you want to have IE as your default browser and chose yes and open up your IE browser session. Open up an Explorer session and check your HTML, HTM file icon which should now be the Blue E.

This solution worked for my laptop. My desktop was easier as I was able to click the Default Browser button and apply the change.

No sure about FireFox but may be sort of the same type of brute force fix.

Semper Fi.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP