Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Missing Operating System


  • Please log in to reply

#1
NullWolf

NullWolf

    Member

  • Member
  • PipPipPip
  • 225 posts
Best way to learn is to mess up... and have your wife yell at you because whe can't run her precious Windows...
This'll teach me...

OK, I recently installed Kanotix onto my second harddrive, setup Grub on the MBR.
No problems, everything worked fine.

Well, after about a week, started getting kdeinit errors. I knew it was something I'd TRIED to install, but since I'm not up too much on Linux root commands or how to uninstall etc... I foolishly decided that the problem could be resolved by reinstalling...

I'm guessing I shouldn't have let it try to reinstall grub...

I tried restarting, pops up "Invalid Partition Table"... cute... :tazz:
Luckily I had an UltimateBootCD handy, so I used the Grub available on the CD to boot my WinME install and did some searching. Everything I found referred to the MBR and claimed that running FDISK /mbr would fix the problem, then I could reinstall Grub... but NOOOOO, of course it didn't work...

So I booted the UBCD and used one (actual several) of the MBR utilities / FDISK utilities, and eventually got to the point to where it gave me "Missing Operating System" which is where I was stuck at until yesterday, when I setup / installed LILO to the MBR.

Well, LILO starts, gives me my options for WinME or Kanotix, but when I tried to choose WinME, up popped "Missing Operating System"... I didn't have time this morning to see if LILO will start Kanotix, so will have to wait till later to test that...
What confuses me is why I can boot from the UBCD to the appropriate OS / drive, but LILO won't let it boot...

Any ideas?
  • 0

Advertisements


#2
shard92

shard92

    Member 1K

  • Member
  • PipPipPipPip
  • 1,129 posts
well that's a tough one. you might try booting the ubcd again and see if you can still boot the winme. If not check to see if the partition is still there. if it is maybe the system files got messed. you also might want to get the drive utility for your brand hard drive and check the drive for errors.

As an afterthought you don't have a program called go-back or any kind of disk manager?
  • 0

#3
dsenette

dsenette

    Je suis Napoléon!

  • Administrator
  • 26,038 posts
  • MVP
the ubcd opperates irrespective of your mbr...it's booting from the cd....any of the info about your me partition that you're seeing is outside of that operating system.



edit: upon reading the post again...i see what you meant....

probably because it's using it's own boot loader instead of the boot loader that's on your mbr, the boot loader within the ubcd doesnt opperate off of the HD it runs from the ram drive

Edited by dsenette, 29 September 2005 - 03:04 PM.

  • 0

#4
NullWolf

NullWolf

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 225 posts
Yeah, I can boot fine to either OS, as long as I use a bootloader from the UBCD.
Its very interesting... I've got a WinME Boot CD, and I'm gonna see if I can Sys C: it...
Since I loaded LILO into HD0 MBR, it shows me my options, I choose WinME and get the Missing OS. I guess I should really try booting to Kanotix from LILO... woulda already, but the wife insisted on using the comp...
  • 0

#5
dsenette

dsenette

    Je suis Napoléon!

  • Administrator
  • 26,038 posts
  • MVP
i hate to say it but...you may want to use the ubcd to back up your stuff.....then start over from scratch...
  • 0

#6
NullWolf

NullWolf

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 225 posts
I might have to...
Going to have to talk the wife into going away from Windows in that case.
The comps 2nd hand from my older sister. Problem is, she didn't give me the WinME CDs, so if I wipe the drive, I'm gonna have to not use M$ (no extra $$ to get new OS CDs). Ah well, she'll have to learn to live without Windows...
In which case I'm just gonna backup the documents I wanna keep to the extra HD and wipe out the ME system... guess we'll be going completely Linux (aside from the little old iMac) sooner than expected.
  • 0

#7
dsenette

dsenette

    Je suis Napoléon!

  • Administrator
  • 26,038 posts
  • MVP
yeah....cuz you can get the openoffice sweet to access all your microsoft documents....and what not
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP