Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Optical drives have vanished


  • Please log in to reply

#1
manu08

manu08

    Member

  • Member
  • PipPipPip
  • 355 posts
I can no longer see any of my optical drives in my computer. They aren't even there in device manager. Out of my four drives 2 have their light on constantly, their not blinking just "on". Someone please help.
  • 0

Advertisements


#2
austin_o

austin_o

    Retired Staff

  • Retired Staff
  • 2,089 posts
Hi. Here is a possible fix
http://support.micro...om/?kbid=320553
upper and lower filters, drive not found
  • 0

#3
manu08

manu08

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 355 posts
No neither of those solved it. Anything else i could possibly do?
  • 0

#4
nixx

nixx

    Member

  • Member
  • PipPipPip
  • 187 posts
this happened to me too. make sure the hd is the primary master, or set as that in the bios. also make sure the connections arnt blocked in bios. then put the devices on the secondary master and slave, leaving only the hd on the primary. they sometimes get territorial lol

Nixx
  • 0

#5
manu08

manu08

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 355 posts
Ok, im not sure how similar our connections are but this is what mine is. I got two hard disks connected as RAID 0 connection, both have SATA connection.
I got 4 optical drives:
Primary Master - TDK Cd-Writer
Primary Slave - Dvd-rom
Secondary Master - NEC Dvd-Writer
Seconday Slave - HP Dvd-writer

Now when i keep the the HP Dvd-Writer also connected to the the seconday IDE Port cable then neither of the 4 drives are available, can't even be seen in BIOS but when i remove the HP Dvd-Writer the remaining three can be seen BUT for some reason my NEC Dvd-writer is not reading and cds/dvds or writing to them. This dvd-writer is brand new, less than a month old & was working perfectly fine before "this problem" came up. What can be done, is it possible my IDE Port is faulty or the cable or is it something with the dvd-writer?
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP