Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

No drivers found for any New Hardware


  • Please log in to reply

#1
Kinjo

Kinjo

    Member

  • Member
  • PipPip
  • 10 posts
After trying to install a USB mouse I have noticed I cannot install devices.

At first I thought it was a USB bug(I am running SP2) so I uninstalled all the USB drivers/hubs and when windows finds the new hardware and the driver wizard pops, searching for drivers automaticly ends in windows saying cannot install device because no software was found for the device. This happens on all of my USB hubs now, and I also noticed that the PS2 mouse I installed to use while I get the USB working again also has no drivers, and attempting to update the drivers for the PS2 mouse from Unknown ends in again the same problem "cannot find any software for this device"

I found seemingly the exact same problem in this thread
http://forum.osnn.ne...ead.php?t=46915

As far as I know the workstation is adware/virus clean with no other known problems
And nothing major has changed with it that I can recall since getting it. (its a Dell workstation)
I have been applying Microsoft automatic updates
  • 0

Advertisements


#2
gerryf

gerryf

    Retired Staff

  • Retired Staff
  • 11,365 posts
when you say you uninstalled all the usb drivers/hubs, what do you mean? You removed the devices? Or you removed the devices from the device manager?

Did you remove the USB host controllers AND root hubs?

In device manager, go to VIEW > Hidden Devices...remove any relating to USB.

What kind of motherboard do you have? A few motherboards actually do not use the default windows xp USB drivers....
  • 0

#3
Kinjo

Kinjo

    Member

  • Topic Starter
  • Member
  • PipPip
  • 10 posts
I uninstalled the devices from device manager
and I have done the show hidden devices.
I still have a scanner USB driver installed I think but I cannot see it in device manager to uninstall it, even with show hidden devices showing.

And its a Intel chipset, no idea what kind of motherboard its in a Dimension 2400 Dell workstation.

I think the problem is not related to the mobo not using default xp USB drivers. Because before I un-installed the USB devices we tried the USB mouse on another computer with the same version of windows and it automaticly found the drivers and installed fine, also this was the same for my scanner when I installed it ages ago.

Even if I do not select automatic install and choose a device from the list it always comes up with no software found in the left pane on the "have disk" screen. I have not tried using a disk because I only have the XP disc that came with it and I dont know where to find the USB drivers on that, also I dont have a disk for the PS2 mouse im using either as its automaticly found on every other computer.

Seems to me, my computer can no longer access its windows driver database?

EDIT, I got the mouse drivers installed off the dell disk
I have installed the official Dell chipset drivers which included USB drivers and now I have 3 out of 4 host controllers installed correctly but no root hubs :/
see image

Attached Thumbnails

  • problem.jpg

Edited by Kinjo, 24 October 2005 - 05:29 PM.

  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP