Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

DVD-Drive Slows Computer


  • Please log in to reply

#1
sokerball86

sokerball86

    Member

  • Member
  • PipPip
  • 26 posts
Hi I am having problems with my Samsung DVD+/-RW drive. When I'm copying a lot of information off a disc or trying to burn onto disks, I get a really low transfer rate (2x on a 16x capable drive), and it slows down my computer a lot. I looked and it is running in PIO mode, even though DMA if available is selected. Here are specs, let me know if you need more:

AMD Athlon 64 3200+
Corsair ValueSelect 2x512mb
Gigabyte K8U motherboard
Chaintec Geforce 6600 256mb video card
Soundblaster Live! 24bit sound card
Western Digital 160gb IDE HD
  • 0

Advertisements


#2
Samm

Samm

    Trusted Tech

  • Member
  • PipPipPipPipPipPip
  • 3,476 posts
Hi there

Have you tried defragging the hard drive? I suggest you clear out the temporary internet files cache & the temp folder first, then defrag.
  • 0

#3
sokerball86

sokerball86

    Member

  • Topic Starter
  • Member
  • PipPip
  • 26 posts
I defrag my HD once a week or so, and I wiped my Temporary Internet Files, which did very little. I seem to have forgotten how to wipe the temp folder though. Plus this is a fairly new computer, it shouldn't be much of a problem.
  • 0

#4
Samm

Samm

    Trusted Tech

  • Member
  • PipPipPipPipPipPip
  • 3,476 posts
It is quite possible that using PIO mode is responsible for slowing the data transfer down. Heres a link to a Microsoft article about DMA & PIO modes for atapi drives. You may find it useful :

http://www.microsoft...ge/IDE-DMA.mspx

Other than that, the only other things I could suggest you look at are the way the drives configured (i.e which IDE controller it's on & its master/slave setting) and possibly the programs you have running in the background. You could try disabling some of them temporarily (e.g antivirus etc) & see if it speeds up the transfer rates.
  • 0

#5
Tyger

Tyger

    Member 2k

  • Member
  • PipPipPipPipPip
  • 2,896 posts
Is your optical drive on the same IDE cable with the hard drive? That can slow things down quite a lot.
  • 0

#6
sokerball86

sokerball86

    Member

  • Topic Starter
  • Member
  • PipPip
  • 26 posts
No, it is on a different ribbon. It is the only optical drive, and the only one on that ribbon. I can't seem to figure out why I can't get it to run in DMA mode, I've tried uninstalling the drive and reinstalling, but that didn't help. Is it possible that there is a flaw with the ribbon?
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP