Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

System won't boot after using Partition Magic to change partition


  • Please log in to reply

#1
John B.

John B.

    New Member

  • Member
  • Pip
  • 1 posts
I built a new system 3 months ago and have been spending lots of time re-installing software from my old system which I intend to retire.

The system is an Intel D945GNT MB, an Intel D820 CPU, and 1 GB of PC4200 RAM. I have 2 Seagate 160 GB SATA HDs. The OS is Windows XP Pro SP2.

I have been using Partition Magic for years, and have never had a problem until now. I had Partition Magic v8.01 installed on this system, and last night I decided to change the size of the partitions on the primary HD. The PM operation appeared to progress normally to conclusion, but when the system tried to re-boot it failed. I was left with a black screen with a blinking cursor at the top. Windows never even began to start.

I had a set of PM rescue disks which I had made on my old system. I tried to load that, but it stops with an error message when it is almost finished loading. I have used these before on other machines, but had never tried them on this one.

I used a Windows 98 startup disk and then ran FDISK to see what it would report about the partitions. On my second HD, which has 2 partitions but no data as yet, FDISK reported both partitions are FAT32, which is correct. On the primary drive, FDISK reported the size of the 2 partitions correctly, reflecting the change I had intended when I ran PM, but it reported the partition type as UNKNOWN instead of FAT32.

Since I bought Partition Magic, the product has been acquired by Symantec. I looked at their website for support. I found the suggestion that I should use use the REPAIR option of Windows XP setup and run FIXBOOT and FIXMBR. After doing that, now when I try to boot I get "ntloader not found", and FDISK reports the primary partition is FAT12. The secondary partition is still shown as UNKNOWN, but it was empty to begin with so that's not really an issue.

I'm currently installing Windows XP on the second HD, with the first one temporarily removed. I'm hoping that maybe when I get Windows XP and Partition Magic running on the second drive, PM will be able to change the partitions on the other drive back to FAT32 and maybe the problem will be solved. But I'm not terribly confident that this will happen.

If this doesn't work, do I have any options short of re-installing all my programs again? Are there any other HD repair utilities available that might be able to correct this?

Thanks in advance for any help!

John B.
  • 0

Advertisements


#2
makai

makai

    Portlock - Oahu

  • Member
  • PipPipPipPipPip
  • 2,793 posts
I actually have no answer for you, but I've also experienced MBR corruption with Partition Magic doing the exact same task you were attempting... which is why I dumped the program years ago. It's always been a hit and miss application with many, many, lost machines. Sorry to hear yours added to the tally! I'll be interested to see how this works out for you.

Good luck!

Edited by makai, 07 December 2005 - 06:17 PM.

  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP