Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Excel automatically formats numeric fields to have 3 decimals


  • Please log in to reply

#1
brk2000

brk2000

    Member

  • Member
  • PipPip
  • 22 posts
I have a PC that has Office 2003. In Excel, it automatically takes the first 3 numbers entered into a cell and places them after the decimal point. For example:

I type: 123 --> Excel shows: .123
I type: 1234 --> Excel shows: 1.234
I type: 12345 --> Excel shows: 12.345

I have tried to changing the column to text and then back to numeric and that doesn't work.
I've tried creating a Special format and that doesn't work.
Others in the our company open the same excel file and have no trouble entering numeric data into the same worksheet.
I was told, although I did not try that excel.xlt or the default excel template file was copied to this machine and still the same results.

I would uninstall and reinstall, but I fear that with the new versions of software these days, I may not be able to reinstall again.

Thanks in advance for any help provided.
  • 0

Advertisements


#2
dsm

dsm

    Member

  • Member
  • PipPip
  • 98 posts
In excel
Tools / Options / Edit / Fixed Decimal Places can be enabled or disabled.

If enabled and set to 3 places, when you enter numbers without a decimal point you will experience the problems stated above.

Disabling the option above should resolve your problem.

HTH
  • 0

#3
brk2000

brk2000

    Member

  • Topic Starter
  • Member
  • PipPip
  • 22 posts
dsm,

Thanks for the suggestion. It worked just great!

Have a good one.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP