Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Stuck in very low screen and color resolution please help


  • Please log in to reply

#1
Soburself03

Soburself03

    Member

  • Member
  • PipPip
  • 10 posts
" I origionally posted in the games forum saying i had a problem installing DirectX 9"

Well thats not my problem anymore. I enabled some things and eventually got Directx 9 to install on my computer. The game installed fine, but whenever i went to play it i would get an error when the init engine would load saying "Failed to initialize Renderer-Check DirectX Version and Graphics settings". So i looked around and i downloaded the v. 1.09 patch for Civ 4( it said that one of the things it fixed was the renderer problem). So i downloaded that but i got the error again( only with a few demensions in the error box) So i thought it would b my graphics settings. So i found that im using Plug and play monitor on Intel® 82845G Graphics controller. So i went to the intel site and downloaded what said to be the "final version" of it or something like that. The problem is while i was downloading that windows said i was low on disk space so i figured i would delete some temporary internet files until i had time to clean it up. I accidently got ride of all my old restore points and when the download was complete i restarted my computer only to find that the screen resolution was stuck at 640 by 480 pixels and the color quality was at its lowest(4 bit) and i wasnt able to change them. I cant find my vaio recovery start up disk and I've tried installing all the windows updates but they didnt do anything to help. Please help me if you can.
  • 0

Advertisements


#2
Fenor

Fenor

    Trusted Tech

  • Retired Staff
  • 5,236 posts
Hi Soburself03!

Even though your onboard video card that you are using is not powerful enough to play Civ 4, which is why you are getting the error you are getting, I can help you to get your video working properly again. What I want you to do is right-click MY COMPUTER, select PROPERTIES, click on the HARDWARE tab and then the DEVICE MANAGER button. In the new Window that appears, click the '+' symbol next to DISPLAY ADAPTERS, and double-click the device listed there, most likely Intel® 82845G Graphics controller, to open it's properties window. Click on the DRIVER tab in this new window and then click on ROLL BACK DRIVER and follow the on-screen prompts. Once it is done you should be asked to reboot your computer, do so and once rebooted, try changing your display settings back to what they were before you tried to update the driver for it.

Fenor
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP