Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

DVD drive not showing in my comp' or device manager


  • Please log in to reply

#1
carlpix

carlpix

    Member

  • Member
  • PipPip
  • 20 posts
Hi hope someone can help.....all of a sudden, well i just realised that the icon for the dvd drive is not showing in 'my comp' or in device manager, nor will it play any cd's. the power is there but just seems in the eyes of the pc to of dissapeared. only noticed when i went to do a 'on the fly copy' any suggestions please.
  • 0

Advertisements


#2
dsenette

dsenette

    Je suis Napoléon!

  • Administrator
  • 26,019 posts
  • MVP
does the drive get recognized in bios?
during boot?
does it just disapear when you try to use it?
or is it always gone?
  • 0

#3
carlpix

carlpix

    Member

  • Topic Starter
  • Member
  • PipPip
  • 20 posts
its allways missing, to be honest ive only just noticed it but i did install anew cd/rw about six months ago and im sure it was working after that.
dont know how to get into the bios, is it when u hold a certain key when booting up?
  • 0

#4
dsenette

dsenette

    Je suis Napoléon!

  • Administrator
  • 26,019 posts
  • MVP
yes that is how you get into bios...you usually press either del or f2 during boot (don't hold it..just tap it repeatedly)
  • 0

#5
carlpix

carlpix

    Member

  • Topic Starter
  • Member
  • PipPip
  • 20 posts
cant get into bios... tried f1 f2 f4 f10 del
is there any other way?
  • 0

#6
dsenette

dsenette

    Je suis Napoléon!

  • Administrator
  • 26,019 posts
  • MVP
during boot there should be a message up at the top of the screen that says the key used to enter setup
  • 0

#7
carlpix

carlpix

    Member

  • Topic Starter
  • Member
  • PipPip
  • 20 posts
finally found it....F8. had to change the keyboard as i was using I/R and realised prob not reconising it untill it was booted. so now i have a menu with safe mode atc but not the blue bios screen, now what. thanx
  • 0

#8
dsenette

dsenette

    Je suis Napoléon!

  • Administrator
  • 26,019 posts
  • MVP
ok....f8 was the wrong selection...but goahead and boot into safe mode and see if it's detected.....if it is...let me know..if not...let me know and then reboot and try del again..really early in the boot process...like...restart the computer...and as soon as you hear it start movine..start pressing del once a second..if that doesn't work...restart and try f2
  • 0

#9
carlpix

carlpix

    Member

  • Topic Starter
  • Member
  • PipPip
  • 20 posts
Hi...not detected in safe mode but 'del' worked.
went into CMOS set up: the IDE PR slaves were there(i have 2 hDD's)

IDE sec slave: Sony CD-RW CRX230
IDE sec slave NONE

tried auto detection, didnt detect
the access mode was set to AUTO but under that it gave me a chance to detect manually but didnt want to touch it without not knowing what to do from there.

Cheers
  • 0

#10
dsenette

dsenette

    Je suis Napoléon!

  • Administrator
  • 26,019 posts
  • MVP
ok...if bios isn't detecting it...it's not a windows problem...how is the drive jumpered?

do you have a spare drive or access to one that you could test?
  • 0

Advertisements


#11
carlpix

carlpix

    Member

  • Topic Starter
  • Member
  • PipPip
  • 20 posts
youve lost me now.....evrything was working fine...both hard drives and both disk drives untill the cd-rw bust and all i did was replace it with a new one just unplugged the cables then plugged them into the new one. didnt even touch the DVD, but it was working after that i remember copying some cds on the fly.
PS dont know what a jumper is, apart from the one u wear..lol
  • 0

#12
dsenette

dsenette

    Je suis Napoléon!

  • Administrator
  • 26,019 posts
  • MVP
ok....let me get refreshed here...

had a dvd drive..and a cd drive...cd drive died..you rpelaced it..now the cd drive works great..but the dvd does not...?

in the computer...you've got what's called a ribbon cable...big wide flat cable that plugs into the back of the drives... is the dvd drive all the way at the end of that cable...or on the connector in the middle?
  • 0

#13
carlpix

carlpix

    Member

  • Topic Starter
  • Member
  • PipPip
  • 20 posts
ya half way there...dont know without opening it up but they both worked ok after i replaced the cd-rw. i think from memory that the cd'rw was plugged in the middle of the ribon cable but cant be too sure.
Ithink your gonna say "looks like a new DVD arn't ya. lol"
  • 0

#14
dsenette

dsenette

    Je suis Napoléon!

  • Administrator
  • 26,019 posts
  • MVP
not yet...i don't give up that easy


go ahead and open the case and check for me...i need to know what location each drive is at...(we're gonna check hardware first then move to software)...
  • 0

#15
carlpix

carlpix

    Member

  • Topic Starter
  • Member
  • PipPip
  • 20 posts
its in the middle (the DVD)
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP