Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Audio and Video sync problems


  • Please log in to reply

#1
djj6835

djj6835

    Member

  • Member
  • PipPip
  • 16 posts
I tried to burn an xvid file to a DVD. The file plays just fine on my computer. The burning process went fine until I tried to play the burned DVD. The audio and video are out of sync. From the very beginning the audio is slightly delayed compared to the video. I've tried using virtualdubmod but I must be doing something wrong because I haven't been able to even open the file using that program. I'm using nero to burn the DVD. I'm also a little unclear as to whether it is even possible to fix the DVD that I already burned or if I need to do something to the file beforehand and then make a new burned copy. Any help would be greatly appreciated.
  • 0

Advertisements


#2
Retired Tech

Retired Tech

    Retired Staff

  • Retired Staff
  • 20,563 posts
Please let me know if this does not help

http://nickyguides.d...audio-synch.htm
  • 0

#3
djj6835

djj6835

    Member

  • Topic Starter
  • Member
  • PipPip
  • 16 posts
I tried opening the file in virtualdub but I get an error that says it can't find decompressor for format xvid. This was when I tried to open the file that is saved on my HD. It would also help if I can use some program that allows me to open the file from the DVD instead of my hard drive because I only have the problem on my DVD. It works fine when I just play the xvid file saved on my HD.
  • 0

#4
Retired Tech

Retired Tech

    Retired Staff

  • Retired Staff
  • 20,563 posts
Try using explore for the DVD then use copy to transfer the file to the hard drive
  • 0

#5
djj6835

djj6835

    Member

  • Topic Starter
  • Member
  • PipPip
  • 16 posts
I copied the files to my HD and now I can access the out of sync file from my HD, I tried opening the files in virtualdub 1.4c and the file type still doesn't appear to be compatible. I believe they are mpeg-2 files. I did however find a program called virtualdubmod that will open my files but I don't have any audio options like I do in virualdub 1.4c so I wasn't able to go any further than opening the file. Only the video appears to work when using virtualdubmod.
  • 0

#6
Retired Tech

Retired Tech

    Retired Staff

  • Retired Staff
  • 20,563 posts
Did you get Terabits from the guide

Do you have a suitable audio editor
  • 0

#7
djj6835

djj6835

    Member

  • Topic Starter
  • Member
  • PipPip
  • 16 posts
I did get terabits from the guide but this appeared to be for fixing stretched audio instead of displaced. I'm fairly sure my problem is just displaced audio. I also noticed that the terabits software if for avi files and my files are not avi files. Is this why I need an audio editor? I just download a free version of audacity audio editor but I don't see an option to convert files to avi format. Are you aware of something free that I can download to do this if need be?
  • 0

#8
Retired Tech

Retired Tech

    Retired Staff

  • Retired Staff
  • 20,563 posts
Displaced audio can be a framerate thing, were any frames dropped

Do you have these options in virtual dub

Under "Video" select "Frame Rate".

In "Source rate adjustment" select "Change so video and audio durations match, OK.

Under "Video" select "Direct stream copy".

Under "File" select Save as
  • 0

#9
djj6835

djj6835

    Member

  • Topic Starter
  • Member
  • PipPip
  • 16 posts
I'm not really sure if any frames were dropped. I assume you wanted me to try using this vurtuadubmod. I loaded the file and went to video and selected frame rate. I then selected the option to match video length to audio length. I then selected direct stream copy. When I went to save the file I recieved the following error "the source video stream uses a compression algorithm that is not compatible with avi files. Direct stream copy cannot be used with video stream."

edit: I switched the file type matroska file and it no longer gave me that error. I then went an played the saved file and it only played audio, no video. I also noticed the length of the file was more than the original. The original that played audio and video but was out of sync was abuot 14 minutes. The new saved one that is just audio says it is 26 minutes.

Edited by djj6835, 28 December 2005 - 11:51 PM.

  • 0

#10
Retired Tech

Retired Tech

    Retired Staff

  • Retired Staff
  • 20,563 posts
Does this help

http://neuron2.net/w...rg/huffyuv.html
  • 0

Advertisements


#11
djj6835

djj6835

    Member

  • Topic Starter
  • Member
  • PipPip
  • 16 posts
I'm not really sure what I'm supposed to do with this after I install it. If I'm supposed to run the application, I'm not even sure where I can access it. I followed the installation instructions but I'm not sure where everything was installed. I wasn't able to specify. If installing this was just supposed to allow virtualdub to be able to save the file that I wasn't able to save earlier, then it did not work.
  • 0

#12
Retired Tech

Retired Tech

    Retired Staff

  • Retired Staff
  • 20,563 posts
If winzip was used, check the folder it unzipped to, you can re-run it and tick overwrite matching files, open the folder it was unzipped to the follow the instructions

Installation
To install Huffyuv just download the zip file above, uncompress the files to a temporary directory, right-click on the huffyuv.inf file and select "Install." You can delete the files in the temporary directory after the installation completes (which takes only a fraction of a second). There should be no need to reboot.

If you're asked to insert a disk named "Huffyuv AVI lossless video codec," just click OK and select the appropriate directory if necessary.

To uninstall Huffyuv, use Add/Remove Programs in the Control Panel.

Capturing with Huffyuv
How to tell your video capture program to use Huffyuv will depend on the program. In general, you should look for a "Video Format" dialog, and set the format to YUY2 or UYVY. Then you should look for a "Compression" dialog and choose Huffyuv from the list. (Do it in this order, because Huffyuv might not show up in the latter dialog unless you've already set the format in the former.)

Some capturing programs (including ATI's Multimedia Center) do not support external compressors and hence can't be used with Huffyuv. If you're using one of these, I recommend switching to Avery Lee's free, GPL'd VirtualDub. (Even if you're not using one of these you should probably switch anyway, since VirtualDub is a lot better than any bundled capture utility.)
  • 0

#13
djj6835

djj6835

    Member

  • Topic Starter
  • Member
  • PipPip
  • 16 posts
I also wanted to add that I think the changing the audio duration to match the video duration did work. It is just that I can't get the video to work now on my new file. I noticed that the file that was out of sync had a play time of 14 minutes but the actual time is the 26 minutes. The timer seems to be moving at about half speed on that file. When I used virtualdub it now says the file is the correct length 26 minutes. It is just that now I only have audio and not video.
  • 0

#14
djj6835

djj6835

    Member

  • Topic Starter
  • Member
  • PipPip
  • 16 posts
I changed the compression format to the huffyuv but I still get the same error that the compression algorithm is not compatible with the avi format. I was able to save the file again as a matroka file but once again I just get audio and no video when I played the matroska file
  • 0

#15
Retired Tech

Retired Tech

    Retired Staff

  • Retired Staff
  • 20,563 posts
I am going to hunt for an answer but don't wait up, will reply as soon as possible
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP