Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

External Hard Drive / Bios problem


  • Please log in to reply

#1
bskit88

bskit88

    Member

  • Member
  • PipPip
  • 20 posts
I added a USB external hard drive to my system, formatted it, gave it a letter, and it works great.

Except now when I try to power up, the usb external adds itself to my boot device priority list in my Bios. It takes the place of the actual drive I need to boot up. So it will not boot up.

I reset the system and went into the Bios. Under "Hard disk drives" it showed my USB external as being number 1, than my 2 internal drives were 2 and 3 on the list. I moved them around and put the external as #3.

I than went under "Boot device priority" and removed the usb external from the list and put my original back in place. I saved everything and exited. System started and ran fine.

I powered down as normal and tried to reboot. I had the same problems over again. So I thought maybe I did not save the Bios before exiting. So I repeated everything in the Bios. Saved it and exited. Booted up.
But on reboot it goes back to the wrong hard drive for Boot up.

How do I get the Bios to stop changing?
Must I unplug the USB external drive every time I power down.
  • 0

Advertisements


#2
Samm

Samm

    Trusted Tech

  • Member
  • PipPipPipPipPipPip
  • 3,476 posts
Hi bskit88

A couple of things you may wish to try :

1. It is possible that the bios battery is low & hence the bios settings are returning to defaults after the system has been powered off. If you have noticed any other settings changing (e.g date & time etc), then its almost certainly the battery.

2. If battery seems fine, then try disabling USB Legacy support in the bios. This will prevent the USB drive from being recognised until Windows loads. However, don't use do this if you use a USB keyboard otherwise you will find that you can no no longer use the keyboard to access the bios or the boot menu etc!
  • 0

#3
austin_o

austin_o

    Retired Staff

  • Retired Staff
  • 2,089 posts
Hi and welcome to Geeks to Go. This is very interesting. I have 4 such devices that I use on both WXP Pro and W2K Pro, just plug and play after I formatted the drive. I never had to do anything to my bios to make it work. I generally power down the device after I "safely remove" it from WXP, then power it down. Even if I fail to do that, next time I boot up no problem. Did you have to make a change in your bios to get it to work in the first place? I don't think you should have had to do that.
  • 0

#4
bskit88

bskit88

    Member

  • Topic Starter
  • Member
  • PipPip
  • 20 posts
It seems my mobo (Asus SK8v) does this on all USB storage devices. There is no way around it according to Asus.


For it to boot up properly next time I must "safely remove" USB device in WinXP before powering down my computer.

Thanks for the quick replys.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP