Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

laptop- new HD- help!


  • Please log in to reply

#1
satrundrop

satrundrop

    New Member

  • Member
  • Pip
  • 3 posts
Im not sure if this Q should be on this forum,but I didnt know where else to put it.
OK
so my HP Omnibook 6000, I just bought the Fujitsu MHT-AH MHT2040AH 40GB 5400 RPM 8MB Cache Notebook Hard Drive - OEM. THis is a generic HD that i was told was compatible with my HP laptop.

Ive installed it but...
1- screen doesnt turn on, the light on the laptop that shows if the screen is on doesnt light up (only for a second when i turn the computer on)

2- The laptop isnt asccessing the HD... the light on the base that refers to the HD doesnt light up either.

Ive tried re-istalling it but nothing--
SOme one said something about checking the BIOS, Im not sure what that is and how can I acces it when theres nothing on the screen.

PLease help me, If you dont know how to fix it at least tell me whats wrong, Cause I am so lost and dont what is wrong

Thanks so much!!
  • 0

Advertisements


#2
shard92

shard92

    Member 1K

  • Member
  • PipPipPipPip
  • 1,129 posts
If you take the drive back out will the laptop come on? IF so I'd say that there is either a problem with the drive or with the interface you plug it into....
  • 0

#3
satrundrop

satrundrop

    New Member

  • Topic Starter
  • Member
  • Pip
  • 3 posts
when I take out the drive-- the computer comes on but still nothing shows on the screen...it stay black but ti can hear the computer running
  • 0

#4
satrundrop

satrundrop

    New Member

  • Topic Starter
  • Member
  • Pip
  • 3 posts
Thanks everyone for all your help and suggestions. Unfortunately Ive tried everything and nothing seems to work. I guess Im just going to have to send it to be repaired. But Thanks Again! :smile:
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP