Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Problem accessing pc on network


  • Please log in to reply

#1
Easy Duzit

Easy Duzit

    New Member

  • Member
  • Pip
  • 4 posts
Hello all

This is a home network with 4 pc's connected to a D-Link 704p router. For some reason no one can access my computer on the network, but I can access theirs!
I get this message every time I try to access files on my rig from one of the other pc's:
\\XXXX is not accessible. You might not have permission to use this network resource. Contact the administrator of the server to find out if you have access permissions.


My pc is the most recent to be added to the network so I ran the network wizard.
All pc's are in the same workgroup.
I have never changed any permissions.
My pc shows up in the view workgroup computers window but if I click on it I get the above message.
File and printer sharing is turned on. Folders I want to share are enabled for sharing.
I have tried it with windows firewall on and off, no difference.
I can ping my computer from other pc's on the network with no trouble. I can access all shared files from the other computers on the network, they just can't access mine.
Swapped cable ports on the router but that made no difference either.

I'm hoping it's a setting somewhere that I've overlooked, but I can't figure out what it might be. I'm open to all suggestions and ideas.

Easy Duzit

Edited by Easy Duzit, 11 January 2006 - 01:04 PM.

  • 0

Advertisements


#2
Dan

Dan

    Trusted Tech

  • Retired Staff
  • 1,771 posts
Hi Easy Duzit,

You seem to have covered all the necessary steps in setting up your network; therefore I would assume that this problem is caused by some form of software, most likely your Windows Firewall. Have you tried disabling your Windows Firewall, restarting your computer and then attempting to share files?

Are there any other software-based firewalls on your computer?

I'm assuming that all of the PC's on your network are using the same OS?
  • 0

#3
Easy Duzit

Easy Duzit

    New Member

  • Topic Starter
  • Member
  • Pip
  • 4 posts
The network was up and running for quite a while ( over a year) before I connected my pc to it. I set it up for my friend and his kids computers so they could all share 1 dsl connection. Never any problems at all. Then I connect my pc to it and nobody can get anything from me, but I can down-load from them.

All 4 pc's run Windows XP pro and they all only have windows firewall. I have disabled my firewall and it doesn't help. Still get the same message. I haven't messed with permissions much so I'm not even sure what to check to see if somehow they need to be changed on my pc.

Appreciate the reply Dan and if anyone else has an idea of what permissions I should check, or anything else that could cause this, feel free to offer it up. I'm open to all suggestions.

Edit- All the Pc's are running either Norton System works 2005, or Norton Anti Virus 2005. They are also scanned with Ad Aware and Spybot regularly.

Edited by Easy Duzit, 11 January 2006 - 06:36 AM.

  • 0

#4
Dan

Dan

    Trusted Tech

  • Retired Staff
  • 1,771 posts
I still have a feeling that this is most likely caused by some form of software; can you please try restarting the new computer in 'Safe Mode with Networking' and then attempt to connect to the new PC from one of the 'oldies'. If you can now share, then you'll know some form of software is getting in the way.

If you still can't share, then restart back into normal mode.

Now, open Control Panel, select 'Security Center', then 'Windows Firewall', in this new window, click on 'Exceptions', and make sure 'File and Printer Sharing' has a tick beside it. Now try to share files with your firewall enabled.
  • 0

#5
Easy Duzit

Easy Duzit

    New Member

  • Topic Starter
  • Member
  • Pip
  • 4 posts
Well, I tried running in safe mode and gave the computer over 1/2 hour to show up on the network. Still get the same message. And windows firewall is disabled on all of the pc's in the network for 2 reasons. One, its not really necessary since all pc's are connected thru a router, and two, because Norton Anti Virus recommends it be disabled and to let it's worm protection work in place of the firewall. (Yeah, I know it sounds strange but thats what Norton recommends.)
Anyway, heres a few other things that may or may not be clues.
I can surf the web with no problems.
When I go to "My Network Places" on my friends pc, the shared folders on my own rig don't show up. But if I go to "View workgroup computers" on my friends pc, my computer shows up on the network. But when I click on it there, instead of showing my shared folders, thats where I get the message: XXX is not accessible. You might not have permission to use this network resource. Contact the administrator of the server to find out if you have access permissions.

Heres a few other things I've checked.
IP addresses and subnets are correct.
Netbios over TCP/IP is enabled. [actually set to default which uses Netbios setting from DHCP server (router)]
PCs have the same workgroup.
Workstation, Server, TCP/IP Netbios helper, and Computer Browser Services are all running.
Net guest account is active.

I've even scoured the web and verified these XP Security policies on my pc:

- Access this computer from the network: add guest
- Deny logon locally: remove guest
- Network access:Sharing and security model... -> Guest only
- Deny access to this computer from the network-> check Guest is not here

Hoping to find a solution soon because using an external usb drive to xfer large files is a pain since the pc I'm xfering them to is about 3 1/2 years old, and doesn't have usb 2.0 :tazz:

I'm thinking about reformatting and reinstalling XP but I really, really don't want to do that. Even though it's been about 1 1/2 years since the last time I did that, my pc is still quick as ever and I would hate to do it just because of this.

Thats all I can think of now but one other thing thats bugging me is that my pc was on this same network about a year ago with no problems.

ALL IDEAS ARE WELCOME :) :) :woot:



Easy Duzit
  • 0

#6
Dan

Dan

    Trusted Tech

  • Retired Staff
  • 1,771 posts

Netbios over TCP/IP is enabled

I thought you said all of the computers were running Windows XP?

I highly doubt formatting will solve this, unless your problem is caused by an errant piece of software. Does Norton System works 2005 have any components that might interfere with network traffic?

One, its not really necessary since all pc's are connected thru a router

I would never trust my security to a hardware firewall; they are notoriously insufficient to protect your network. I would highly recommend keeping your Windows Firewall enabled.

wo, because Norton Anti Virus recommends it be disabled and to let it's worm protection work in place of the firewall

I've never really trusted Norton products with my security. If I were you, I would have my Firewall enabled over Norton's supposed "worm protection".

And speaking of Norton; have you tried disabling Norton System works 2005, and your firewall, and then connecting?
  • 0

#7
Easy Duzit

Easy Duzit

    New Member

  • Topic Starter
  • Member
  • Pip
  • 4 posts
Hi Dan and thanks for the replies.

This morning I had an idea and I'm happy to say, PROBLEM SOLVED!!! :tazz:
Wish I could say it was a stroke of genius or some rare computer glitch that I figured out like some geek version of Sherlock Holmes but it wasn't. A few days ago after I pinged my box from the other pc's on the network with no problem, I tried typing the path to my computer from any of the other pc's and I got the no access message.
But this morning I logged into to my friends pc and tried typing the FULL PATH in the address bar to a specific shared folder on my pc and WHAM.....there it is!!!

I still can't see any of my shares in "my network places" on any of the other pc's. And I still can't access my shared folders from any of the other pc's by simply browsing to them. But by simply typing the full path in the address bar to a specific shared folder, I have access!

Is this a little strange? Yes. Will I lose anymore sleep over this? Not one more wink.

Anyway thanks for the help, your effort is appreciated. I hope this helps someone else!

Easy Duzit

Edited by Easy Duzit, 12 January 2006 - 03:32 PM.

  • 0

#8
kroc

kroc

    New Member

  • Member
  • Pip
  • 4 posts
Hi,

I setup a mini P2P wireless network using XP (host) & Win2000 (client).
Initially I only wanted to share files so I did not enable ICS. I got the sharing to work eventually and it works well (File and Printer sharing).

Then, I decided to enable ICS. IP addresses changed from 169.x.x.x to 192.x.x.x. Fine, did some DNS changes and managed to get the PC's pinging each other and even got the client pinging the web, but could not browse the websites or connect to shared directories. I gave up on ICS and downloaded:

http://www.analogx.c...twork/proxy.htm

Changed the IP addresses to 10.0.0.1(server) and 10.0.0.2 (client).
Now I can access the web from the client, can ping both ways but still cannot access the shared folders.

Any ideas? Ideally ICS sharing the web plus the internal network is what I need.

Thanks.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP