Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

How to read USB portable drive


  • Please log in to reply

#1
bamakodaker

bamakodaker

    Member

  • Member
  • PipPipPip
  • 470 posts
WIN98 - Lexar 256 USB jump drive.
The light lit up on the drive at first plug in. Now nothing. Yes, I put the drive in first - that's what I'd do on my Mac's at work. I have downloaded a driver but now I don't even see the drive showing up.

Thanks for your time,
bamakodaker
  • 0

Advertisements


#2
Neil Jones

Neil Jones

    Member 5k

  • Member
  • PipPipPipPipPipPipPipPip
  • 8,476 posts
Try different USB port?
  • 0

#3
shard92

shard92

    Member 1K

  • Member
  • PipPipPipPip
  • 1,129 posts
Is it win98 or win98se? I've seen windows 98 have problems with usb devices. Also are you sure you installed the driver correctly? ANy yellow marks in device manager?
  • 0

#4
bamakodaker

bamakodaker

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 470 posts
I have Win98. I tried different port, no good. I'm sorry but I'll have to be walked through to find where those yellow marks are.

bamakodaker
  • 0

#5
Doomed_to_a_pathetic_computer

Doomed_to_a_pathetic_computer

    Member

  • Member
  • PipPip
  • 67 posts
When you attach the device, do you get a "New Hardware Detected..." message?
  • 0

#6
shard92

shard92

    Member 1K

  • Member
  • PipPipPipPip
  • 1,129 posts

I have Win98. I tried different port, no good. I'm sorry but I'll have to be walked through to find where those yellow marks are.

bamakodaker



Right click "My Computer"
Select "Properties" in the menu
At the top of the page click "Device Manager"

Look for any yellow marks. Also look for a heading " Universal Serial Bus Controllers " usually at or near bottom of list....
  • 0

#7
bamakodaker

bamakodaker

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 470 posts
I do have 2 USB devices showing. USB Root Hub and PCI to USB Universal Host Controller, neither are yellow. Somewhere I believe I heard that the computer will not detect the mini-drive is you plug it in first THEN download a driver for it. I guess I need to delete the driver then reboot, download the driver, install it THEN try the mini-drive. Does that sound right? Now I just have to find the site I downloaded the driver, find it's name, remove that from my PC and reboot - just to start!

Any thing else?

bamakodaker
  • 0

#8
shard92

shard92

    Member 1K

  • Member
  • PipPipPipPip
  • 1,129 posts
I haven't heard that for usb drives but some usb devices have to have the software in first so it is a possibility. Also like I said I've heard of some drives not working with win98 but working okay with win98se...

Good Luck
  • 0

#9
BabyTech

BabyTech

    Member

  • Member
  • PipPip
  • 69 posts
It's a common problem specific to Lexxar USB Jump drives. Uninstall any drivers you installed on your system for the jumpdrive, take out the drive from the USB port, install the drivers BEFORE you insert it, reboot, plug in the jump drive and see if it works. Let me know if that helps
  • 0

#10
peterm

peterm

    Trusted Tech

  • Technician
  • 3,173 posts
I Just looked at the Lexar site there are 12 different jump drives which one do you have
They do have just a plain 256 jumpdrive (not pro etc) but no windows 98 drivers
I think you will need to upgrade to 98SE
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP