Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

networking with twin wan routers


  • Please log in to reply

#1
uberslacker

uberslacker

    Member

  • Member
  • PipPip
  • 24 posts
I have just built my new PC and purchased a twin wan router to go with it. I have cable and DSL, and have ran the home network set up wizards, and am able to see each pc on the other but when I go to share files or printers, I get an error message saying that I do not have rights to access, check with sys admin. Both have symantic client firewall with the IP and PC names set to allow access. Any suggestion??
  • 0

Advertisements


#2
Dan

Dan

    Trusted Tech

  • Retired Staff
  • 1,771 posts
Hello ubserslacker,

When troubleshooting, it is always a good idea to temporarily disable any and all firewalls. However, if you are confident that you have the correct configuration, then feel free to leave them enabled.

Basic Checklist for Networking
1. Ensure that all firewalls are disabled for all computers involved.
2. Ensure that all computers on the network are in the same workgroup.
3. Ensure each computer has File and Printer Sharing installed.
4. Ensure that you have File Sharing enabled - to do this, right-click on any Drive or Folder on one (or all) of the other computers, and select Sharing and Security.... Ensure that Share this folder on the Network is enabled.

Please ensure that you have all correct permissions set:
Start --> Settings --> Control Panel --> Performance and Maintenance --> Administrative Tools --> Local Security Policy --> Expand Local Policies --> Select User Rights Assignment

Now, check the following:
Access this computer from the network --> Ensure that Administrator, Guest and Everyone is on this list; if not, choose Add User Group and add them.
Deny access to this computer from the network --> Ensure that Everyone and Guest are not on this list.
Deny logon locally --> Ensure that Guest is not part of this list.

Now, under Security Options, check the following:
Accounts: Administrator account status --> Enabled
Accounts: Guest account status --> Enabled
Network Access: Let everyone permissions apply to anonymous users --> Enabled
Network access: Sharing and security model... --> Guest only
  • 0

#3
uberslacker

uberslacker

    Member

  • Topic Starter
  • Member
  • PipPip
  • 24 posts
It was the firewall, I guess manually adding the pc wasnt enough I had to disable, access the files and then while running files from the remote pc, turned the firewall back on to force it to recognize the connection. It is only working one way though. I can get files from my old system to my new but not the other way around. Also the printer still cannot be found. I have went to the printer and selected share with the network, but still the old pc wont recognize the network. Atleast I can save what I want to Print and pull it up on the pc with the printer. One other thing when I went to admin tools there is no local security policies setting could it be because Im using xp home on both pc's??
  • 0

#4
Dan

Dan

    Trusted Tech

  • Retired Staff
  • 1,771 posts
uberslacker,

Also the printer still cannot be found. I have went to the printer and selected share with the network, but still the old pc wont recognize the network.

Some printers require you to manually install them on all computers before they can be shared. To do this, you will need to attach your printer to your 'old' PC, insert any CD that came with the printer, and install or download any drivers/software -- you should then try to print to make sure everything is installed properly. Once done, you should be able to re-attach the printer back to the 'new' PC and then attempt to re-share it.

It is only working one way though. I can get files from my old system to my new but not the other way around.

I have a feeling that if you solve this, then the Printer might fall into line.

One other thing when I went to admin tools there is no local security policies setting could it be because Im using xp home on both pc's??

Can you please return to Administrative Tools, and then list all of the options within that folder.

Please do the following command:
Goto Start --> Run --> Type CMD and press OK --> Now type: cacls Shared Drive --note: Your shared drive is whatever you have shared... ie: cacls D:\ -- or: cacls D:\Shared Folder

Please copy/paste the results by right-clicking on the Command Prompt window, selecting 'Select All', pressing Ctrl+C, and then posting on this forum.

Thanks,
Dan.

Edited by Dan G, 16 January 2006 - 06:44 PM.

  • 0

#5
uberslacker

uberslacker

    Member

  • Topic Starter
  • Member
  • PipPip
  • 24 posts
Ok first of I just want to thank you for your time. This has been driving me crazy for a week now. The only things I have listed under admin tools are short cuts to the following:

component serives
computer management
data sources (odbc)
event viewer
performance
services

Both PC's old (sony viao P4 2.66 ghz 1 gig ram 500 gig HDD) and New (stats listed below in signiture), have the same things listed.

Next the info below is the same for both pc's minus the name after c:\document settings at the end.


Microsoft Windows XP [Version 5.1.2600]
© Copyright 1985-2001 Microsoft Corp.

C:\Documents and Settings\Uber>cacls shared drive
Displays or modifies access control lists (ACLs) of files

CACLS filename [/T] [/E] [/C] [/G user:perm] [/R user [...]]
[/P user:perm [...]] [/D user [...]]
filename Displays ACLs.
/T Changes ACLs of specified files in
the current directory and all subdirectories.
/E Edit ACL instead of replacing it.
/C Continue on access denied errors.
/G user:perm Grant specified user access rights.
Perm can be: R Read
W Write
C Change (write)
F Full control
/R user Revoke specified user's access rights (only valid with /E).
/P user:perm Replace specified user's access rights.
Perm can be: N None
R Read
W Write
C Change (write)
F Full control
/D user Deny specified user access.
Wildcards can be used to specify more that one file in a command.
You can specify more than one user in a command.

Abbreviations:
CI - Container Inherit.
The ACE will be inherited by directories.
OI - Object Inherit.
The ACE will be inherited by files.
IO - Inherit Only.
The ACE does not apply to the current file/directory.

C:\Documents and Settings\Uber>
  • 0

#6
Dan

Dan

    Trusted Tech

  • Retired Staff
  • 1,771 posts

C:\Documents and Settings\Uber>cacls shared drive

The syntax of your command is wrong; it should be something like: C:\Documents and Settings\Uber>cacls D:\Shared Folder -- or, if you have shared a whole drive -- cacls D:\

You need to type: cacls and then the Path to your shared folders/drives.
  • 0

#7
uberslacker

uberslacker

    Member

  • Topic Starter
  • Member
  • PipPip
  • 24 posts
Opps is this what your looking for

Microsoft Windows XP [Version 5.1.2600]
© Copyright 1985-2001 Microsoft Corp.

C:\Documents and Settings\Uber>cacls d:\
d:\ BUILTIN\Administrators:F
BUILTIN\Administrators:(OI)(CI)(IO)F
NT AUTHORITY\SYSTEM:F
NT AUTHORITY\SYSTEM:(OI)(CI)(IO)F
CREATOR OWNER:(OI)(CI)(IO)F
BUILTIN\Users:R
BUILTIN\Users:(OI)(CI)(IO)(special access:)
GENERIC_READ
GENERIC_EXECUTE

BUILTIN\Users:(CI)(special access:)
FILE_APPEND_DATA

BUILTIN\Users:(CI)(IO)(special access:)
FILE_WRITE_DATA

Everyone:R
Everyone:(OI)(CI)R


C:\Documents and Settings\Uber>

C:\Documents and Settings\Uber>

C:\Documents and Settings\Uber>

C:\Documents and Settings\Uber>

C:\Documents and Settings\Uber>
  • 0

#8
Dan

Dan

    Trusted Tech

  • Retired Staff
  • 1,771 posts
That's right :tazz:
Could you please do this on both computers.
Thanks.
  • 0

#9
uberslacker

uberslacker

    Member

  • Topic Starter
  • Member
  • PipPip
  • 24 posts
the new pc shows this:
Microsoft Windows XP [Version 5.1.2600]
© Copyright 1985-2001 Microsoft Corp.

C:\Documents and Settings\Uber>cacls d:\
d:\ BUILTIN\Administrators:F
BUILTIN\Administrators:(OI)(CI)(IO)F
NT AUTHORITY\SYSTEM:F
NT AUTHORITY\SYSTEM:(OI)(CI)(IO)F
CREATOR OWNER:(OI)(CI)(IO)F
BUILTIN\Users:R
BUILTIN\Users:(OI)(CI)(IO)(special access:)
GENERIC_READ
GENERIC_EXECUTE

BUILTIN\Users:(CI)(special access:)
FILE_APPEND_DATA

BUILTIN\Users:(CI)(IO)(special access:)
FILE_WRITE_DATA

Everyone:R
Everyone:(OI)(CI)R


C:\Documents and Settings\Uber>

C:\Documents and Settings\Uber>

C:\Documents and Settings\Uber>

C:\Documents and Settings\Uber>

C:\Documents and Settings\Uber>

and the old pc this:

Microsoft Windows XP [Version 5.1.2600]
© Copyright 1985-2001 Microsoft Corp.

C:\Documents and Settings\ME>cacls d:\
d:\ BUILTIN\Administrators:F
BUILTIN\Administrators:(OI)(CI)(IO)F
NT AUTHORITY\SYSTEM:F
NT AUTHORITY\SYSTEM:(OI)(CI)(IO)F
CREATOR OWNER:(OI)(CI)(IO)F
BUILTIN\Users:R
BUILTIN\Users:(OI)(CI)(IO)(special access:)
GENERIC_READ
GENERIC_EXECUTE

BUILTIN\Users:(CI)(special access:)
FILE_APPEND_DATA

BUILTIN\Users:(CI)(IO)(special access:)
FILE_WRITE_DATA

Everyone:R
Everyone:(OI)(CI)C


C:\Documents and Settings\ME>

C:\Documents and Settings\ME>

C:\Documents and Settings\ME>

C:\Documents and Settings\ME>cacls e:\
e:\ BUILTIN\Administrators:F
BUILTIN\Administrators:(OI)(CI)(IO)F
NT AUTHORITY\SYSTEM:F
NT AUTHORITY\SYSTEM:(OI)(CI)(IO)F
CREATOR OWNER:(OI)(CI)(IO)F
BUILTIN\Users:R
BUILTIN\Users:(OI)(CI)(IO)(special access:)
GENERIC_READ
GENERIC_EXECUTE

BUILTIN\Users:(CI)(special access:)
FILE_APPEND_DATA

BUILTIN\Users:(CI)(IO)(special access:)
FILE_WRITE_DATA

Everyone:R
Everyone:(OI)(CI)R


C:\Documents and Settings\ME>clcs f:\
'clcs' is not recognized as an internal or external command,
operable program or batch file.

C:\Documents and Settings\ME>calcs f:\
'calcs' is not recognized as an internal or external command,
operable program or batch file.

C:\Documents and Settings\ME>cacls f:\
f:\ BUILTIN\Administrators:F
BUILTIN\Administrators:(OI)(CI)(IO)F
NT AUTHORITY\SYSTEM:F
NT AUTHORITY\SYSTEM:(OI)(CI)(IO)F
CREATOR OWNER:(OI)(CI)(IO)F
BUILTIN\Users:R
BUILTIN\Users:(OI)(CI)(IO)(special access:)
GENERIC_READ
GENERIC_EXECUTE

BUILTIN\Users:(CI)(special access:)
FILE_APPEND_DATA

BUILTIN\Users:(CI)(IO)(special access:)
FILE_WRITE_DATA

Everyone:R
Everyone:(OI)(CI)R


C:\Documents and Settings\ME>
  • 0

#10
Dan

Dan

    Trusted Tech

  • Retired Staff
  • 1,771 posts
For testing purposes, I'm going to get you to give Everyone full access on your network -- please do the following on both computers:

cacls D:\ /g everyone:f -- NOTE: There is a space between the \ and / along with a space between the g and everyone -- there is no space between the everyone, : and f

Please post the results -- also, now try to share files both ways; does it work?
  • 0

#11
uberslacker

uberslacker

    Member

  • Topic Starter
  • Member
  • PipPip
  • 24 posts
Well thats the ticket both have full access and I can print from both.....

Now what do I need to do to limit the access to just these two pc's instead of the whole WWW.

Oh and by the way THANK YOU
  • 0

#12
uberslacker

uberslacker

    Member

  • Topic Starter
  • Member
  • PipPip
  • 24 posts
I am guessing it is going to look something like cacls D:\ /d guest so that since there is only admin and guest on this pc then by setting it to deny the guest I should be safe and have not just left a big hole for any to play in :tazz:
  • 0

#13
Dan

Dan

    Trusted Tech

  • Retired Staff
  • 1,771 posts
Well, the current access priveleges are actually fine... The only problem would be if some one connected to your router along with your other computers. However, so long as you don't let a hacker into your house, and allow him to connect to your router, then you really should be fine.

That said, if you don't feel comfortable, then I'll post how to limit the access -- it might also impair network connectivity.
  • 0

#14
uberslacker

uberslacker

    Member

  • Topic Starter
  • Member
  • PipPip
  • 24 posts
No thats fine, I am just glad its working and I see what I accually allowed now, besides the hardware firewall I have software on both pc's so i should be safe enough. Once again thank you.
  • 0

#15
Dan

Dan

    Trusted Tech

  • Retired Staff
  • 1,771 posts

No thats fine, I am just glad its working and I see what I accually allowed now, besides the hardware firewall I have software on both pc's so i should be safe enough. Once again thank you.

Yep -- as long as you have all of your anti-virus and anti-spyware applications up-to-date and functioning, then you'll be fine :tazz:

I'd also recommend you take a peek at this -- a very good list of resources to defend against malware there.

I'm always happy to help friendly people :)
Thanks for choosing GeeksToGo! :)
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP