Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

sharing files and printers between computers


  • Please log in to reply

#1
mda4

mda4

    Member

  • Member
  • PipPip
  • 36 posts
I have three computers on my home network:

1. A new desktop running Windows XP SP2

2. A laptop running XP SP2

3. An older desktop (5 years old) running W2K

I have a Dlink DI-524 router and a cable ISP connection

I've set all my C drives to share. I've also set the printer connected to my new desktop to share. I tried to set the printer connected to the old desktop to share but it won't allow me to do so.

Problems:

1. I can "see" shared folders that are on my laptop from my new desktop, but I can't "see" any files that are on my new desktop from my laptop.

2. I can't see any files on the old desktop from either other computer.

3. Until recently, I could print to the printer connected to the new desktop from either that desktop, or from the laptop, wirelessly. Now I con only print to that printer using the new desktop that is attached to the printer. When I try to add a new printer, my laptop can't find the printer

4. I can only print to the printer conected to the old desktop from the old desktop.
  • 0

Advertisements


#2
Dan

Dan

    Trusted Tech

  • Retired Staff
  • 1,771 posts
Hi mda4,

Before you added the new desktop, was your network working? Could you share files between the laptop and the old desktop?

3. Until recently, I could print to the printer connected to the new desktop from either that desktop, or from the laptop, wirelessly. Now I con only print to that printer using the new desktop that is attached to the printer. When I try to add a new printer, my laptop can't find the printer

That's an odd one -- have you installed any new firewall on the old desktop? Can you please disable all firewalls whilst troubleshooting.

You have a fairly convoluted problem -- to make it easier, first of all I'm just going to focus on sharing and printing between the laptop and the new Desktop.

On your new desktop, please do the following -- goto Start --> Run --> Type CMD and press OK --> Now, type this command:
cacls C:\ /g everyone:f -- NOTE: There is a space between the \ and / along with a space between the g and everyone -- there is no space between the everyone, : and f

Can you now connect to the new desktop from the laptop?

If not, check these permissions on the new desktop:
Start --> Settings --> Control Panel --> Performance and Maintenance --> Administrative Tools --> Local Security Policy --> Expand Local Policies --> Select User Rights Assignment

Now, check the following:
Access this computer from the network --> Ensure that Administrator, Guest and Everyone is on this list; if not, choose Add User Group and add them.
Deny access to this computer from the network --> Ensure that Everyone and Guest are not on this list.
Deny logon locally --> Ensure that Guest is not part of this list.

Now, under Security Options, check the following:
Accounts: Administrator account status --> Enabled
Accounts: Guest account status --> Enabled
Network Access: Let everyone permissions apply to anonymous users --> Enabled
Network access: Sharing and security model... --> Guest only
  • 0

#3
mda4

mda4

    Member

  • Topic Starter
  • Member
  • PipPip
  • 36 posts
Thaks for your reply. I appreciate your help.

Before you added the new desktop, was your network working? Could you share files between the laptop and the old desktop? That's an odd one -- have you installed any new firewall on the old desktop? Can you please disable all firewalls whilst troubleshooting.

Actually, I've had the "new" desktop for 18 months; the laptop is 6 months old. I did acquire a nasty little virus two weeks ago, which www.geekstogo.com helped me eradicate.

You have a fairly convoluted problem -- to make it easier, first of all I'm just going to focus on sharing and printing between the laptop and the new Desktop.

I should add I had a problem I've seen appear on the malware forum quite frequently, in that I suddenly couldn't access my firewall. It was set by "group policy". I followed a fix suggested by a geekstogo staff and re-acquired the rights to access and control my firewall.

On your new desktop, please do the following -- goto Start --> Run --> Type CMD and press OK --> Now, type this command:
cacls C:\ /g everyone:f -- NOTE: There is a space between the \ and / along with a space between the g and everyone -- there is no space between the everyone, : and f

Can you now connect to the new desktop from the laptop?
No, still can't see files from the desktop on the laptop.

If not, check these permissions on the new desktop:
Start --> Settings --> Control Panel --> Performance and Maintenance --> Administrative Tools --> Local Security Policy --> Expand Local Policies --> Select User Rights Assignment

I could follow this until: Local Security Policy --> Expand Local Policies --> Select User Rights Assignment This option isn't available to me.


I'm sorry, but I don't understand the following questions. I can share or not share the folders, but I don't have the option to add a group on XP. I think I've seen these options on the W2k "old" desktop, though.


Now, check the following:
Access this computer from the network --> Ensure that Administrator, Guest and Everyone is on this list; if not, choose Add User Group and add them.
Deny access to this computer from the network --> Ensure that Everyone and Guest are not on this list.
Deny logon locally --> Ensure that Guest is not part of this list.

Now, under Security Options, check the following:
Accounts: Administrator account status --> Enabled
Accounts: Guest account status --> Enabled
Network Access: Let everyone permissions apply to anonymous users --> Enabled
Network access: Sharing and security model... --> Guest only
[/quote]


Again, thanks for helping. I hope we can resolve this.
  • 0

#4
mda4

mda4

    Member

  • Topic Starter
  • Member
  • PipPip
  • 36 posts
I hope you can iunderstand my previous post. I guess posting in between your questions doesn't come out too clear.
  • 0

#5
Dan

Dan

    Trusted Tech

  • Retired Staff
  • 1,771 posts

I hope you can iunderstand my previous post. I guess posting in between your questions doesn't come out too clear.

That's fine -- however, in the future you could put each of my questions in a quote -- to do this, simply put ["Quote"]Question["/Quote"] (without the "'s) ie: your quote on my screen looks like: ["Quote"]I hope you can iunderstand my previous post. I guess posting in between your questions doesn't come out too clear.["/Quote"] -- once again, just remove the " inside the ['s.

I should add I had a problem I've seen appear on the malware forum quite frequently, in that I suddenly couldn't access my firewall. It was set by "group policy". I followed a fix suggested by a geekstogo staff and re-acquired the rights to access and control my firewall.

For troubleshooting purposes, please disable that firewall and see if you can now share files.
  • 0

#6
mda4

mda4

    Member

  • Topic Starter
  • Member
  • PipPip
  • 36 posts

That's fine -- however, in the future you could put each of my questions in a quote -- to do this, simply put ["Quote"]Question["/Quote"] (without the "'s) ie: your quote on my screen looks like: ["Quote"]I hope you can iunderstand my previous post. I guess posting in between your questions doesn't come out too clear.["/Quote"] -- once again, just remove the " inside the ['s.
For troubleshooting purposes, please disable that firewall and see if you can now share files.



The firewall is disabled on both the desktop and the laptop.
  • 0

#7
mda4

mda4

    Member

  • Topic Starter
  • Member
  • PipPip
  • 36 posts

The firewall is disabled on both the desktop and the laptop.


But I still can't share files. I tried using the Network setup wizard and can now see the desktop from the laptop, but when I click on the desktop icon I get an error msg saying I don't have rights to acccess this computer.
  • 0

#8
Dan

Dan

    Trusted Tech

  • Retired Staff
  • 1,771 posts

But I still can't share files. I tried using the Network setup wizard and can now see the desktop from the laptop, but when I click on the desktop icon I get an error msg saying I don't have rights to acccess this computer.

Can you please repeat this step:

On your new desktop, please do the following -- goto Start --> Run --> Type CMD and press OK --> Now, type this command:
cacls C:\ /g everyone:f -- NOTE: There is a space between the \ and / along with a space between the g and everyone -- there is no space between the everyone, : and f


  • 0

#9
mda4

mda4

    Member

  • Topic Starter
  • Member
  • PipPip
  • 36 posts

Can you please repeat this step:


I did this on step one, and just repeated it, but it didn't give me any access from the laptop.
  • 0

#10
Dan

Dan

    Trusted Tech

  • Retired Staff
  • 1,771 posts
Are you positive you have your whole C:\ drive shared on your new desktop?

Ensure that you have File Sharing enabled - to do this, right-click on any Drive or Folder on one (or all) of the other computers, and select Sharing and Security.... Ensure that Share this folder on the Network is enabled.

Please download HijackThis. Run it and perform a scan -- save the log and then from the log, please post all of the Running Processes.
  • 0

Advertisements


#11
mda4

mda4

    Member

  • Topic Starter
  • Member
  • PipPip
  • 36 posts

Are you positive you have your whole C:\ drive shared on your new desktop?

Ensure that you have File Sharing enabled - to do this, right-click on any Drive or Folder on one (or all) of the other computers, and select Sharing and Security.... Ensure that Share this folder on the Network is enabled.

Please download HijackThis. Run it and perform a scan -- save the log and then from the log, please post all of the Running Processes.


Yes, I'm sure I have the C drive shared. Here's mt Hijack this:

Logfile of HijackThis v1.99.1
Scan saved at 7:15:15 PM, on 1/17/2006
Platform: Windows XP SP2 (WinNT 5.01.2600)
MSIE: Internet Explorer v6.00 SP2 (6.00.2900.2180)

Running processes:
C:\WINDOWS\System32\smss.exe
C:\WINDOWS\system32\winlogon.exe
C:\WINDOWS\system32\services.exe
C:\WINDOWS\system32\lsass.exe
C:\WINDOWS\system32\Ati2evxx.exe
C:\WINDOWS\system32\svchost.exe
C:\WINDOWS\System32\svchost.exe
C:\WINDOWS\system32\spoolsv.exe
C:\WINDOWS\Explorer.EXE
C:\PROGRA~1\SYMANT~1\SYMANT~1\vptray.exe
C:\Program Files\Java\jre1.5.0_06\bin\jusched.exe
C:\Program Files\MSN Video Enhanced\MSNVE.exe
C:\WINDOWS\CNYHKey.exe
C:\Program Files\Intel\Modem Event Monitor\IntelMEM.exe
C:\Program Files\Intel\Intel Application Accelerator\iaanotif.exe
C:\WINDOWS\ehome\ehtray.exe
C:\Program Files\CyberLink\PowerDVD\DVDLauncher.exe
C:\WINDOWS\system32\dla\tfswctrl.exe
C:\WINDOWS\mHotkey.exe
C:\Program Files\Microsoft AntiSpyware\gcasServ.exe
C:\Program Files\Dell Support\DSAgnt.exe
C:\Program Files\Misc programs\WillowRd.exe
C:\Program Files\Microsoft AntiSpyware\gcasDtServ.exe
C:\PROGRA~1\COMMON~1\AOL\ACS\acsd.exe
C:\PROGRA~1\SYMANT~1\SYMANT~1\DefWatch.exe
C:\WINDOWS\eHome\ehRecvr.exe
C:\WINDOWS\eHome\ehSched.exe
C:\Program Files\ewido anti-malware\ewidoctrl.exe
C:\Program Files\Intel\Intel Application Accelerator\iaantmon.exe
C:\PROGRA~1\SYMANT~1\SYMANT~1\Rtvscan.exe
C:\WINDOWS\system32\svchost.exe
C:\WINDOWS\wanmpsvc.exe
C:\WINDOWS\system32\BRMFRSMG.EXE
C:\WINDOWS\system32\dllhost.exe
C:\WINDOWS\eHome\ehmsas.exe
C:\WINDOWS\System32\svchost.exe
C:\Program Files\Internet Explorer\iexplore.exe
C:\WINDOWS\system32\rundll32.exe
C:\spyware programs\HijackThis.exe

R0 - HKCU\Software\Microsoft\Internet Explorer\Main,Start Page = http://www.cnn.com/
R0 - HKLM\Software\Microsoft\Internet Explorer\Main,Start Page = http://www.cnn.com/
N3 - Netscape 7: user_pref("browser.search.defaultengine", "engine://C%3A%5CProgram%20Files%5CNetscape%5CNetscape%5Csearchplugins%5CSBWeb_01.src"); (C:\Documents and Settings\Dad\Application Data\Mozilla\Profiles\default\ipi2w17w.slt\prefs.js)
O2 - BHO: AcroIEHlprObj Class - {06849E9F-C8D7-4D59-B87D-784B7D6BE0B3} - C:\Program Files\Adobe\Acrobat 7.0\ActiveX\AcroIEHelper.dll
O2 - BHO: (no name) - {53707962-6F74-2D53-2644-206D7942484F} - C:\Program Files\Spybot - Search & Destroy\SDHelper.dll
O2 - BHO: DriveLetterAccess - {5CA3D70E-1895-11CF-8E15-001234567890} - C:\WINDOWS\system32\dla\tfswshx.dll
O2 - BHO: SSVHelper Class - {761497BB-D6F0-462C-B6EB-D4DAF1D92D43} - C:\Program Files\Java\jre1.5.0_06\bin\ssv.dll
O2 - BHO: (no name) - {88069C82-7012-7FEF-4140-2850A25765B4} - C:\WINDOWS\system32\sahmn.dll
O3 - Toolbar: (no name) - {BA52B914-B692-46c4-B683-905236F6F655} - (no file)
O3 - Toolbar: Yahoo! Toolbar - {EF99BD32-C1FB-11D2-892F-0090271D4F88} - C:\Program Files\Yahoo!\Companion\Installs\cpn\yt.dll
O4 - HKLM\..\Run: [vptray] C:\PROGRA~1\SYMANT~1\SYMANT~1\vptray.exe
O4 - HKLM\..\Run: [UpdateManager] "C:\Program Files\Common Files\Sonic\Update Manager\sgtray.exe" /r
O4 - HKLM\..\Run: [SunJavaUpdateSched] C:\Program Files\Java\jre1.5.0_06\bin\jusched.exe
O4 - HKLM\..\Run: [MSN Video Enhanced] "C:\Program Files\MSN Video Enhanced\MSNVE.exe"
O4 - HKLM\..\Run: [ledpointer] CNYHKey.exe
O4 - HKLM\..\Run: [IntelMeM] C:\Program Files\Intel\Modem Event Monitor\IntelMEM.exe
O4 - HKLM\..\Run: [IAAnotif] C:\Program Files\Intel\Intel Application Accelerator\iaanotif.exe
O4 - HKLM\..\Run: [ehTray] C:\WINDOWS\ehome\ehtray.exe
O4 - HKLM\..\Run: [DVDLauncher] "C:\Program Files\CyberLink\PowerDVD\DVDLauncher.exe"
O4 - HKLM\..\Run: [dla] C:\WINDOWS\system32\dla\tfswctrl.exe
O4 - HKLM\..\Run: [CHotkey] mHotkey.exe
O4 - HKLM\..\Run: [ATIPTA] C:\Program Files\ATI Technologies\ATI Control Panel\atiptaxx.exe
O4 - HKLM\..\Run: [gcasServ] "C:\Program Files\Microsoft AntiSpyware\gcasServ.exe"
O4 - HKCU\..\Run: [DellSupport] "C:\Program Files\Dell Support\DSAgnt.exe" /startup
O4 - Global Startup: Microsoft Office.lnk = C:\Program Files\Microsoft Office\Office10\OSA.EXE
O4 - Global Startup: ScreenArt.lnk = C:\Program Files\Misc programs\WillowRd.exe
O8 - Extra context menu item: E&xport to Microsoft Excel - res://C:\PROGRA~1\MI1933~1\OFFICE11\EXCEL.EXE/3000
O9 - Extra button: (no name) - {08B0E5C0-4FCB-11CF-AAA5-00401C608501} - C:\Program Files\Java\jre1.5.0_06\bin\ssv.dll
O9 - Extra 'Tools' menuitem: Sun Java Console - {08B0E5C0-4FCB-11CF-AAA5-00401C608501} - C:\Program Files\Java\jre1.5.0_06\bin\ssv.dll
O9 - Extra button: Research - {92780B25-18CC-41C8-B9BE-3C9C571A8263} - C:\PROGRA~1\MI1933~1\OFFICE11\REFIEBAR.DLL
O9 - Extra button: AIM - {AC9E2541-2814-11d5-BC6D-00B0D0A1DE45} - C:\Program Files\AIM\aim.exe
O9 - Extra button: Real.com - {CD67F990-D8E9-11d2-98FE-00C0F0318AFE} - C:\WINDOWS\system32\Shdocvw.dll
O9 - Extra button: Messenger - {FB5F1910-F110-11d2-BB9E-00C04F795683} - C:\Program Files\Messenger\msmsgs.exe
O9 - Extra 'Tools' menuitem: Windows Messenger - {FB5F1910-F110-11d2-BB9E-00C04F795683} - C:\Program Files\Messenger\msmsgs.exe
O16 - DPF: {17492023-C23A-453E-A040-C7C580BBF700} (Windows Genuine Advantage Validation Tool) - http://go.microsoft....k/?linkid=39204
O16 - DPF: {2BC66F54-93A8-11D3-BEB6-00105AA9B6AE} (Symantec AntiVirus scanner) - http://security.syma...bin/AvSniff.cab
O16 - DPF: {4ED9DDF0-7479-4BBE-9335-5A1EDB1D8A21} - http://bin.mcafee.co...84/mcinsctl.cab
O16 - DPF: {644E432F-49D3-41A1-8DD5-E099162EEEC5} (Symantec RuFSI Utility Class) - http://security.syma...n/bin/cabsa.cab
O16 - DPF: {BCC0FF27-31D9-4614-A68E-C18E1ADA4389} - http://bin.mcafee.co...,21/mcgdmgr.cab
O16 - DPF: {F58E1CEF-A068-4C15-BA5E-587CAF3EE8C6} (MSN Chat Control 4.5) - http://chat.msn.com/...s/msnchat45.cab
O20 - Winlogon Notify: awtqn - awtqn.dll (file missing)
O20 - Winlogon Notify: NavLogon - C:\WINDOWS\system32\NavLogon.dll
O23 - Service: AOL Connectivity Service (AOL ACS) - America Online, Inc. - C:\PROGRA~1\COMMON~1\AOL\ACS\acsd.exe
O23 - Service: Ati HotKey Poller - Unknown owner - C:\WINDOWS\system32\Ati2evxx.exe
O23 - Service: DefWatch - Symantec Corporation - C:\PROGRA~1\SYMANT~1\SYMANT~1\DefWatch.exe
O23 - Service: ewido security suite control - ewido networks - C:\Program Files\ewido anti-malware\ewidoctrl.exe
O23 - Service: IAA Event Monitor (IAANTMon) - Intel Corporation - C:\Program Files\Intel\Intel Application Accelerator\iaantmon.exe
O23 - Service: Local Security Authority Subsystem Service (lsass) - Unknown owner - C:\WINDOWS\scvhost.exe (file missing)
O23 - Service: Symantec AntiVirus Client (Norton AntiVirus Server) - Symantec Corporation - C:\PROGRA~1\SYMANT~1\SYMANT~1\Rtvscan.exe
O23 - Service: WAN Miniport (ATW) Service (WANMiniportService) - America Online, Inc. - C:\WINDOWS\wanmpsvc.exe
  • 0

#12
Dan

Dan

    Trusted Tech

  • Retired Staff
  • 1,771 posts
Can you please restart the desktop computer into Safe Mode with Networking and then attempt to share files.
  • 0

#13
mda4

mda4

    Member

  • Topic Starter
  • Member
  • PipPip
  • 36 posts

Can you please restart the desktop computer into Safe Mode with Networking and then attempt to share files.



I did this, and still get the same error message box when I try to access the desktop:

\\Den is not accessible. You might not have permission to use this network resourse, Contact the administrator of this server to find out if you have access permissions.

Logon failure: the user has not been granted the requested logon type at this computer.
  • 0

#14
Dan

Dan

    Trusted Tech

  • Retired Staff
  • 1,771 posts
On the new desktop, please do the following:
Goto Start --> Run --> Type CMD and press OK --> Now, please type:
cacls C:\ -- please post the results here by right-clicking on the Command Prompt window, selecting 'Select All', pressing Ctrl+C, and then posting on this forum.

Edited by Dan G, 17 January 2006 - 09:08 PM.

  • 0

#15
mda4

mda4

    Member

  • Topic Starter
  • Member
  • PipPip
  • 36 posts

On the new desktop, please do the following:
Goto Start --> Run --> Type CMD and press OK --> Now, please type:
cacls C:\ -- please post the results here by right-clicking on the Command Prompt window, selecting 'Select All', pressing Ctrl+C, and then posting on this forum.



Microsoft Windows XP [Version 5.1.2600]
© Copyright 1985-2001 Microsoft Corp.

C:\Documents and Settings\Dad>cacl C:\
'cacl' is not recognized as an internal or external command,
operable program or batch file.

C:\Documents and Settings\Dad>cacls C:\
C:\ Everyone:F
Everyone:(OI)(CI)(IO)F
Everyone:(OI)(CI)R


C:\Documents and Settings\Dad>
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP