Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

desktop wireless adapter - gets signal, but won't connect


  • Please log in to reply

#1
Zuisa

Zuisa

    Member

  • Member
  • PipPip
  • 20 posts
My friend just bought a new Dell desktop computer, and since our campus is entirely wireless, she bought a Netgear PCI wireless adapter. It is set up correctly, and she receives a strong signal from the network (and my laptop works fine in the same room), but she can't connect to the internet. At first we were getting a "limited or no connectivity" signal, but we fixed that, but I think all we did was make the message go away. It looks like Netgear won't recognize the computer's IP address. According to their helpfiles, to work properly the IP address needs to be between certain numbers, and the one she was assigned by Windows is not. Can you just arbitrarily set an IP address? Is there anything else we can do? Netgear says we're connected, Windows says we're connected....but we're not. The fact that Netgear lists the IP address as 0.0.0.0 seems to be the only issue, but they don't allow you to set it manually.

I'm sorry if that was confusing... this problem has been frustrating me for days and I'm beginning to feel incredibly inadequate as a computer geek due to the fact that I cannot fix this.
  • 0

Advertisements


#2
Dan

Dan

    Trusted Tech

  • Retired Staff
  • 1,771 posts
Hi Zuisa,

At first we were getting a "limited or no connectivity" signal, but we fixed that, but I think all we did was make the message go away

Please goto Start --> Programs --> Accessories --> Communications --> Network Connections --> Right-click on the Local Area Connection and select Properties --> Now, make sure that the following option is checked -- "Notify me when this connection has limited or no connectivity" -- if it is not checked, then it means you have simply disabled the message. This doesn't help the problem, but rather only makes troubleshooting more difficult. So I would highly recommend (re)enabling that :tazz:

Can you just arbitrarily set an IP address?

You can setup a Static IP address -- however, since you are on a fairly big Network, it will mean that the Network will have DHCP enabled (automatically assigning IP's). So, there is no way for you to know what IP's are in use, and what are not. Therefore, if you assign an IP to your computer that some one else is already using, then it will result in a conflict of IP's. For this reason, I would highly recommend trying to get onto your Network with DHCP enabled.

If you did have the aforementioned option unchecked, and once you recheck, do you recieve the Limited or no connectivity message? This will be the key to solving your problem.

Please goto Start, Run, type CMD, press 'OK' and then type: IPCONFIG /ALL - please post the results here by right-clicking on the Command Prompt window, selecting 'Select All', pressing the Enter key, and then pasting/posting on this forum. Alternately, you can save your information to a text file by using the following command: IPCONFIG /ALL > C:\ipconfig.txt -- navigate to that text file, and copy/paste the information from it.

Test your Network
1. Goto Start, Run, type: NETSH DIAG GUI - press 'OK'. A Command Prompt window will open temporarily; don't touch it, it will disappear in a moment.
2. A Microsoft Help and Support window will then open; select the option 'Scan your system'.
3. Wait for the scan to finish and then scroll down to the heading 'Modems and Network Adapters'. Look at 'Network Adapters' (don't expand it yet). Beside your connection information, you should see a green 'PASSED'; if you do not (if you see a red 'FAILED') then expand 'Network Adapters', scroll down the list until you see the heading with the 'FAILED', expand that option and copy and paste the results here.
In the NETSH DIAG GUI, you should be looking for any red 'FAILED', however the key one is Network Adapters for you. If you see any other red FAILED, expand the component and copy the results.

Thanks,
Dan.
  • 0

#3
Zuisa

Zuisa

    Member

  • Topic Starter
  • Member
  • PipPip
  • 20 posts
Here's the IPCONFIG info:

Microsoft Windows XP [Version 5.1.2600]
© Copyright 1985-2001 Microsoft Corp.

C:\Documents and Settings\Blaedlocke>IPCONFIG /ALL

Windows IP Configuration

Host Name . . . . . . . . . . . . : D68LY591
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Hybrid
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Wireless Network Connection 2:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : NETGEAR WG311v3 802.11g Wireless PCI
Adapter
Physical Address. . . . . . . . . : 00-0F-B5-87-53-A5
Dhcp Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Autoconfiguration IP Address. . . : 169.254.10.23
Subnet Mask . . . . . . . . . . . : 255.255.0.0
Default Gateway . . . . . . . . . :

Ethernet adapter Local Area Connection:

Media State . . . . . . . . . . . : Media disconnected
Description . . . . . . . . . . . : Intel® PRO/1000 PL Network Connect
ion
Physical Address. . . . . . . . . : 00-13-72-06-56-88

C:\Documents and Settings\Blaedlocke>



Here's the Test Your Network:

DHCPServer = 255.255.255.255(Invalid IP Address)


IPAddress = 169.254.10.23 (PASSED)
Pinging 169.254.10.23 with 32 bytes of data:
Reply from 169.254.10.23: bytes=32 time<1ms TTL=0
Reply from 169.254.10.23: bytes=32 time<1ms TTL=0
Reply from 169.254.10.23: bytes=32 time<1ms TTL=0
Reply from 169.254.10.23: bytes=32 time<1ms TTL=0
Ping statistics for 169.254.10.23:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss)
Approximate round trip times in milli-seconds:
Minimum = 0ms, Maximum = 0ms, Average = 0ms


BUT, she's pretty sure she's using an invalid IP address and is confused as to why it passed.
  • 0

#4
Dan

Dan

    Trusted Tech

  • Retired Staff
  • 1,771 posts

BUT, she's pretty sure she's using an invalid IP address and is confused as to why it passed.

She's right -- any 169. address is an indication that you aren't connecting to the DHCP server, and so Windows automatically assigns you an IP.

Have you run the Wireless Network Setup Wizard on her computer?

Could you please do an ipconfig /all on your computer, so I can see what sort of IP schema your Network is using.

Thanks,
Dan.
  • 0

#5
Zuisa

Zuisa

    Member

  • Topic Starter
  • Member
  • PipPip
  • 20 posts
Didn't we already paste an IPCONFIG /ALL? We can do it again if you'd like, though.


We did run the wireless setup wizard. A lot of places we've checked have told us to try restarting the router, but it's the school's network and so obviously we aren't at liberty to do that.
  • 0

#6
Dan

Dan

    Trusted Tech

  • Retired Staff
  • 1,771 posts
Yes, you did an ipconfig /all on her computer (the computer that's not working). I asked for an ipconfig /all from your computer (the one that is working / is connected to the Network).
  • 0

#7
Zuisa

Zuisa

    Member

  • Topic Starter
  • Member
  • PipPip
  • 20 posts
I can read, I promise. Sorry! Here you go:



Microsoft Windows XP [Version 5.1.2600]
© Copyright 1985-2001 Microsoft Corp.

C:\Documents and Settings\Jacki>ipconfig /all

Windows IP Configuration

Host Name . . . . . . . . . . . . : JACKI
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Hybrid
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Local Area Connection:

Media State . . . . . . . . . . . : Media disconnected
Description . . . . . . . . . . . : Realtek RTL8139/810x Family Fast Eth
ernet NIC
Physical Address. . . . . . . . . : 00-02-3F-23-35-A1

Ethernet adapter Wireless Network Connection:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Broadcom 54g MaxPerformance 802.11g
Physical Address. . . . . . . . . : 00-90-4B-54-C1-86
Dhcp Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IP Address. . . . . . . . . . . . : 10.11.1.198
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 10.11.1.1
DHCP Server . . . . . . . . . . . : 192.168.200.200
DNS Servers . . . . . . . . . . . : 192.168.200.200
192.168.200.201
Lease Obtained. . . . . . . . . . : Saturday, January 21, 2006 11:05:34
PM
Lease Expires . . . . . . . . . . : Sunday, January 22, 2006 11:07:14 PM


C:\Documents and Settings\Jacki>
  • 0

#8
Dan

Dan

    Trusted Tech

  • Retired Staff
  • 1,771 posts
Thanks :tazz:

I can read, I promise.

:) It was my fault -- I didn't exactly make it clear which computer I was referring to, so I'm sorry :woot:

Okay, to make things clear, and to make it easier for me to type, from now on I'll refer to the problematic computer as P1 and to the working computer as W1 :P

First things first -- does P1 have any firewalls installed? ie: Windows Firewall? If it does, please disable the firewalls, and then continue.

On P1, please do the following:
Start --> Run --> type CMD --> press OK. Now type:
  • ipconfig /release -- wait for the connection to release; then
  • ipconfig /renew -- wait for the connection to re-establish, or alternatively for an error message to display -- if it is an error message, please post the message. If it is not an error message, please post the IP.
Alternatively, to make sure there is no software interfering with your connection attempts, try restarting P1 into Safe Mode with Networking, and then attempt to connect to your network (and also re-try the ipconfig /release /renew steps).

Thanks :)
  • 0

#9
Dan

Dan

    Trusted Tech

  • Retired Staff
  • 1,771 posts
Also, please goto Start --> Run --> type EVENTVWR --> press OK --> Now, look under the System log for any errors and/or warnings. If you find any, please post the relevant details by double clicking on them, and then copy/pasting the information inside.

Thanks.
  • 0

#10
Zuisa

Zuisa

    Member

  • Topic Starter
  • Member
  • PipPip
  • 20 posts
It had apparently already been realeased, so:

C:\Documents and Settings\Blaedlocke>IPCONFIG /RENEW

Windows IP Configuration

An error occurred while renewing interface Wireless Network Connection 2 : unabl
e to contact your DHCP server. Request has timed out.
No operation can be performed on Local Area Connection while it has its media di
sconnected.

C:\Documents and Settings\Blaedlocke>


We ran the EVENTVWR and we get a LOT of errors; we've been fighting with this wireless fiasco for days so I suppose we've caused a lot of them. Are there any specifically we should be looking for? Most of them seem generally relevant.
  • 0

#11
Dan

Dan

    Trusted Tech

  • Retired Staff
  • 1,771 posts
Mainly DHCP / TCPIP errors. What are the other erros referring to?

Also, when you ran the Wireless Network Setup Wizard, did you input the correct SSID and WEP keys?

Did you try disabling any firewall(s)?
  • 0

#12
Dan

Dan

    Trusted Tech

  • Retired Staff
  • 1,771 posts
Another question -- what version of Windows is P1 using? Is there any way you can get files onto that computer (ie: USB?) -- if so, try WinsockFix:
Download and run WinsockFix. Once run, reboot and test your connection.

If that fails, and P1 is running Windows XP, please goto Start, Run, type CMD, press 'OK', then do the following:
1. Reset WINSOCK entries to installation defaults: netsh winsock reset catalog

2. Reset TCP/IP stack to installation defaults: netsh int ip reset reset.log

Reboot and test.

And if you do have a USB that you can use, do this as well --
Please download LSPFix from here. Run the LSPFix.exe that you have just finished downloading, and please list all of the protocols that are in the 'Keep' and 'Remove' list; if there are protocols in the 'Remove' list, then please don't click 'Finish>>'. Simply close the program by pressing ALT+F4 or the Close [x] button.

Edited by Dan G, 22 January 2006 - 12:31 AM.

  • 0

#13
Zuisa

Zuisa

    Member

  • Topic Starter
  • Member
  • PipPip
  • 20 posts
I'm sorry for not replying earlier - after she restarted her computer in safe mode and then back again in normal mode, the internet just started working. We're not sure why or how, but we're just not going to question it for the time being.

Thank you for your help!
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP