Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

CD-ROM Drivers... >_>


  • Please log in to reply

#1
D3_Kamikaze

D3_Kamikaze

    Member

  • Member
  • PipPip
  • 59 posts
Okay, this is quite possibly in the wrong forum, I just couldn't find anywhere where this fit, so I threw it in here.

Heres my problem:

I have a very old game on a cd that was made to run in DOS. I've been wanting to play it for years, but never could get it up and running. I recently tried to get it to work again, using a DOS emulator called DOSbox (Its like a DOS shell, except better, or something o.O). I managed to install it fine, but when I go to play it, in pure DOS or DOSBOX, it gives me an error on startup: "please ensure the cd is in the drive and you have loaded the MSCDEX driver".

Now, I did alot of research on my own and found that the MSCDEX driver is for DOS to recognise your CD drives. Its *supposed* to be in the config.sys (or autoexe, can't remember now) but it wasn't on my pc. I recently changed all my Optical drives, so this may have smething to do with it. I tried adding it to config.sys but to no avail, i still get the error message, though MSCDEX seems to load on startup now.

Thank you for any help!

-Kami
  • 0

Advertisements


#2
Neil Jones

Neil Jones

    Member 5k

  • Member
  • PipPipPipPipPipPipPipPip
  • 8,476 posts
Download the attached ZIP, this is a generic CD driver unit for DOS. Extract it to the root (C:\).

Make alterations to two files as follows (you may have some of these lines already). You'll find config.sys and autoexec.bat in the root of the drive, or just type in "sysedit" on the Run section of the Windows start menu.

CONFIG.SYS <-- name of file to edit

device=C:\windows\himem.sys
device=C:\windows\emm386.exe
device=C:\oakcdrom.sys /D:CD001

AUTOEXEC.BAT <-- name of file to edit

MSCDEX /D:CD001

Then reboot. You should see something very similiar to this come up on the screen if you press ESC on the first Windows bootscreen (I've forgotten the exact wording):

OAKCDROM.SYS
Device Name: CD001
Devices:  1

MSCDEX v2.25
CD Drive:  D (Device: CD001)

Therefore you should now be able to reboot in DOS mode and fire up the game to see the CD.

Attached File  OAKCDROM.zip   12.21KB   81 downloads
  • 0

#3
D3_Kamikaze

D3_Kamikaze

    Member

  • Topic Starter
  • Member
  • PipPip
  • 59 posts
Thanks for your reply, unfortunately, it seems to not have worked.

I'm still getting the same error.

Here is what my config.sys file looks like:

DEVICE=C:\WINDOWS\HIMEM.SYS
DEVICE=C:\WINDOWS\EMM386.EXE
DEVICE=C:\OAKCDROM.SYS /D:CD001

And my autoexec.bat:

C:\PROGRA~1\GRISOFT\AVGFRE~1\BOOTUP.EXE
SET BLASTER=A220 I7 D1 H5 P330 T6
SET CTSYN=C:\WINDOWS
C:\PROGRA~1\CREATIVE\SBLIVE\DOSDRV\SBEINIT.COM

SET PATH=%PATH%;C:\PROGRA~1\ATITEC~1\ATICON~1


SET PATH=%PATH%;d:\files\crichri\sigmak~1\gimp\2.0\bin


MSCDEX /D:CD001


Am I doing something wrong?

-Kami

EDIT: Silly me... I had the cd in the wrong drive for that attempt -.-'. It seems to get past that part fine, but I am now encountering a new error. It consists of something like "Could not find somethingorother.xxxx"

I'm going to try a fresh install of the game and see if it works then. If you can fix this problem now, I'd be greatful. I will get you more information on the error in the morning, such as the actual filename (its really late here... time for bed!)

Note: the actual extension of the file seems to be .xxx or .xxxx . I'm just not quite sure what the filename itself was, though I will edit this post or make a new one with it in the morning.

Thanks again for your assistance!

-Kami

Edited by D3_Kamikaze, 23 January 2006 - 10:17 PM.

  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP