Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Unable to telnet to Linux (ftp ok and putty ok)


  • Please log in to reply

#1
Youssef JD

Youssef JD

    New Member

  • Member
  • Pip
  • 2 posts
I have just finshed installing Red Hat Linux Enterprise 3. I configured telnet to be enabled (default anyway). I can telnet but the password keeps failing. Eventhough that I can ftp with the same login and password successfully. I can also use putty with the same password and login successfully. But telnet keeps saying password incorrect.
Can you help?

Edited by Youssef JD, 28 January 2006 - 10:09 PM.

  • 0

Advertisements


#2
Kemasa

Kemasa

    Nobody

  • Technician
  • 1,633 posts
Are you using a non-root account? Have you checked /var/log/secure and/or other logs to see why it is failing?

What occurs? Is there any error message?

Do you have telnetd installed? Is it enabled as a service?

You might also consider using ssh instead of telnet for security reasons.

Edited by Kemasa, 28 January 2006 - 10:54 PM.

  • 0

#3
Youssef JD

Youssef JD

    New Member

  • Topic Starter
  • Member
  • Pip
  • 2 posts
I am using a root login with root password (same one used for ftp and ssh).
the var/log/secure indicates an Authentication Failure.
telnetd is installed and enabled as a service.
  • 0

#4
Kemasa

Kemasa

    Nobody

  • Technician
  • 1,633 posts
Try it with a non-root account and I think you will find that it works.

You are running into a security issue which does not allow root access. You can move the file /etc/securetty which will allow root access or edit the file to allow access on the requested ports or don't login as root (a good idea).
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP