Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Hi, rdriv.sys problem after fix got side effects


  • Please log in to reply

#1
SuperSam

SuperSam

    Member

  • Member
  • PipPipPip
  • 693 posts
Hi all.

I have installed XP on my PC again today as it needed a fresh install (running a bit slow) and after doing windows updates I found I was infected with the rdriv.sys virus. I googled "rdriv.sys removal" and found a fix (courtesy of your page) the link being: http://www.geekstogo...showtopic=78516 . I followed everything "Cloutz" said to do, and I thank him for helping me fix this problem. However, since using the fixes I have lost my Windows XP themes (the original themes - nothing custom) now I only have windows classic themes...

Any help?

Thanks in advance - SuperSam
  • 0

Advertisements


#2
BabyTech

BabyTech

    Member

  • Member
  • PipPip
  • 69 posts
Just curious, but didn't you say that you just reinstalled XP? any custom settings you had before formatting would be lost at that point, not after using a fix.
  • 0

#3
SuperSam

SuperSam

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 693 posts
Whenever you reinstall a version of XP you get the original XP theme (luna) now I do not have this after fixing the problems, I have only the classic theme, and when I go into my theme settings I dont have the option to change back to Win XP default theme...
  • 0

#4
gerryf

gerryf

    Retired Staff

  • Retired Staff
  • 11,365 posts
Start > run
regedit
<enter>

navigate to the following key

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies


Anything in there?
  • 0

#5
SuperSam

SuperSam

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 693 posts
I'll check now Gerryf...
  • 0

#6
SuperSam

SuperSam

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 693 posts
:tazz: Something to worry about?

Posted Image
  • 0

#7
gerryf

gerryf

    Retired Staff

  • Retired Staff
  • 11,365 posts
no...darn

when you right click on desktop, and choose PROPERTIES, are all the tabs there?
  • 0

#8
SuperSam

SuperSam

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 693 posts
Yeah, all tabs are there... :tazz:

Posted Image

Edited by SuperSam, 01 February 2006 - 10:03 AM.

  • 0

#9
SuperSam

SuperSam

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 693 posts
Does registry work like sorta, I copy your registry then mine works, or is it nothing at all like that? - BRB Resetting...

Edited by SuperSam, 01 February 2006 - 10:17 AM.

  • 0

#10
gerryf

gerryf

    Retired Staff

  • Retired Staff
  • 11,365 posts
in some ways, yes, but that would be a very bad idea if you did not know what you were doing...for example, copying hklm to a different machine would absolutely kill your machine....

but anyway, you said that you did not have the xp theme, but your image shows an xp theme! What you failed to mention is that it was just the taskbar and start button that were not displaying.

This is an entirerly different issue

Right click MY COMPUTER in the start menu, choose PROPERTIES, choose ADVANCED tab, click the SETTINGS button inthe PERFORMANCE area, then click ADJUST FOR BEST APPEARANCE, then OK OK...does that change the appearance? but perhaps make the system a little slow?
  • 0

Advertisements


#11
SuperSam

SuperSam

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 693 posts
Done all that, still no XP theme, checked in appearence in display properties too :'(
  • 0

#12
gerryf

gerryf

    Retired Staff

  • Retired Staff
  • 11,365 posts
go to device manager, anything with a yellow !
  • 0

#13
SuperSam

SuperSam

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 693 posts
I've had missing drivers of these two devices before, however it didn't affect any of my previous installations of XP... And it has only broken AFTER this fix...

"SM Bus Controller" and "Unknown Device"

Edited by SuperSam, 01 February 2006 - 12:07 PM.

  • 0

#14
gerryf

gerryf

    Retired Staff

  • Retired Staff
  • 11,365 posts
ok test

download the following-- a Microsoft theme called royale blue...extract and install.

Did you actually make a post of your own in malware, or did you just follow someone else's ?

Attached Files


  • 0

#15
SuperSam

SuperSam

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 693 posts
Followed... Somebody elses, but I had the same problem...
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP