Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

SOLVED - Sharing printers


  • Please log in to reply

#1
dabombshop

dabombshop

    Member

  • Member
  • PipPip
  • 43 posts
Can somebody give me a walkthrough on how to share the printer on two computers? I have a desktop which is connected to the printer by USB, and a laptop with a wireless card. I've tried doing the networking on the computer and making the network disk, but everytime I try to set it up on the laptop, there always seems to be some type of error. What can I do to ensure success?

Edited by dabombshop, 05 February 2006 - 01:27 PM.

  • 0

Advertisements


#2
rivekm

rivekm

    Member

  • Member
  • PipPip
  • 65 posts
Can somebody give me a walkthrough on how to share the printer on two computers? I have a desktop which is connected to the printer by USB, and a laptop with a wireless card. I've tried doing the networking on the computer and making the network disk, but everytime I try to set it up on the laptop, there always seems to be some type of error. What can I do to ensure success?


ok, are both computers on xp? What kind of error message are you getting? Next time if you get an error, do a print screen and put it in the reply.
you must create the network, run network setup wizard on both computers- make certain they are both in the same workgroup: use the default name. next you must enable file and print sharing on both computers.

Follow instructions below:

To share your printer
Open Printers and Faxes.
Right-click the printer you want to share, and then click Sharing.
The options you see on the Sharing tab differ depending on whether sharing is enabled on your computer. For instructions on what to do next, click the option that describes what you see on the Sharing tab.
I see text stating that printer sharing must be turned on

You need to enable printer sharing by running the Network Setup Wizard. Start it by clicking the link on the Sharing tab, and then follow the instructions. Once sharing is enabled, begin this procedure again. I see options for sharing or not sharing the printer

On the Sharing tab, click Share this printer, and then, in the Share name box, type a name for the shared printer.
If you share the printer with users on different hardware or different operating systems, click Additional Drivers. Click the environment and operating system for the other computers, and then click OK to install the additional drivers.
Drivers for users running other versions of Windows (Windows 95, Windows 98, or Windows NT 4.0) are located on the Support CD. Printer drivers for Windows NT 3.1 and Windows NT 3.5 are not included.

Click OK, or, if you have installed additional drivers, click Close.
If you have followed the steps listed above and still cannot share this printer, open Windows Firewall. (To open Windows Firewall, click Start, click Control Panel, and then double-click Windows Firewall.) Then, on the Exceptions tab, select the File and Printer Sharing check box.
  • 0

#3
dabombshop

dabombshop

    Member

  • Topic Starter
  • Member
  • PipPip
  • 43 posts
Both windows are on XP. I've set up a network (using Netowrk Setup Wizard, not Wireless Setup Wizard) and I can see the shared files on both computers. When I go on the laptop to add a network printer, I click to browse for a printer and the only item that appears on the list is "Microsoft Windows Network." There are no printer names or anything. I've also enabled printer sharing on the desktop.

-------

PROBLEM SOLVED. Someone please close this thread.

Edited by dabombshop, 05 February 2006 - 01:26 PM.

  • 0

#4
Dan

Dan

    Trusted Tech

  • Retired Staff
  • 1,771 posts
Hi dabombshop,
I'm glad that you managed to solve your problem, however I would appreciate it alot if you would take the time to post your solution, as it may very well help other users to solve their own problems.

Someone please close this thread.

We don't make a habit of closing threads in forums other than the Malware forum unless the topic violates our Terms of Use, or is a duplicate post.

Thanks,
Dan.
  • 0

#5
dabombshop

dabombshop

    Member

  • Topic Starter
  • Member
  • PipPip
  • 43 posts
Solution: Basically I discovered that the laptop was not able to access any of the shared files on the desktop (I was getting messages like "Computer \\COMPUTERNAME.EXAMPLE.COM cannot be managed. The network path was not found.") So I searched online and I came across a Microsoft Support page that said that the Windows firewall was blocking incoming network traffic on Transmission Control Protocol (TCP) port 445. The page gave me these steps to resolve the issue:

Method 1: Use a the Netsh command-line tool
On the remote Windows XP SP2-based computer, run a netsh command to permit traffic through Windows Firewall on TCP port 445: 1. Click Start, click Run, type cmd in the Open box, and then click OK.
2. Type the following command, and then press ENTER:
netsh firewall set portopening tcp 445 smb enable
You receive the following message:
Ok.
3. Quit the command prompt.
To implement this change throughout your organization, run this netsh command-line from a batch file or from a script.
Back to the top

Method 2: Use the Graphical User Interface
On the remote Windows XP SP2-based computer, modify Windows Firewall to permit incoming TCP traffic on port 445: 1. Click Start, and then click Control Panel.
2. Click Security Center, and then click Windows Firewall.
3. Click the Exceptions tab, click to select the File and Printer Sharing check box, and then click Edit.
4. Click to select the TCP 445 check box, click Change scope, and then take one of the following actions: • Click My network (subnet) only.
• Click Custom list, and then type the IP addresses that you want to manage this computer.

5. Click OK four times.

Once I did this, I was able to search/browse for the printer in the add printer wizard and complete the installation.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP