Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Batch file


  • Please log in to reply

#1
Kniht

Kniht

    Member

  • Member
  • PipPipPip
  • 236 posts
Am using ERUNT to backup my registry. In windows "Scheduled Tasks" I created a batch file to backup the registry at startup.

This is the batch file I created for this purpose:

AUTOBACK.EXE %SystemRoot%\ERDNT\#Date#/noprogresswindow /noconfirmdelete /days:7

Everything works fine, runs on startup, backs up to appropriate folder, but even though I used the switch /noprogresswindow, I still get the progress window appearing on my desktop.

What's wrong with this .bat file? :tazz:
  • 0

Advertisements


#2
gerryf

gerryf

    Retired Staff

  • Retired Staff
  • 11,365 posts
Why did you schedule it this way....seems wrong. Does not that program place an entry in your startup folder, rather than through a scheduled task.....fuzzy recall here...need to take a look
  • 0

#3
Kniht

Kniht

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 236 posts
gerryf,

I scheduled it this way due to an article I read by Peter Bromberg MVP, Ph.D, that was posted on the Egghead Cafe Forum, directly relating to ERUNT.

I think a batch file can be created for this backup and a shortcut placed in the startup folder, but I was so impressed with Peter's credentials and arrogance, that I tried it his way. Of course, I've been on this planet long enough to know the so called "experts" may not know everything (no disrespect to good ole' Pete).

Even if I create the shortcut to the .bat file and place it in the startup folder, the program will run the same as Pete's way did, the progress window will still come up until I can figure out what in the cmd line is not correct. :tazz:
  • 0

#4
Kniht

Kniht

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 236 posts
gerryf,

After staring at this cmd. line half the night, figured out what was wrong. Needed a space between the
# and /. Program works fine.

Also, decided to create a shortcut for this .bat file and place in the startup folder. This way I can turn off the Scheduled Tasks service and save a little more resource. Like as few processes running in the background as possible.

Thanks for your reply to my post. :tazz:
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP