Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

CHKDSK


  • Please log in to reply

#1
h0tpants

h0tpants

    Member

  • Member
  • PipPip
  • 33 posts
Hello,
Whenever I restart my computer it automatically runs the chkdsk before it starts windows xp up. I dont mind this too much, but it does gett annoying when i'm trying to install programs and whatnot. Just wondering what causes this and if there is anything i can do to remedy it. I split my drive into two partitions and this is about when this started happening.

Also, sometimes when i right click on a file in explorer i get a "Windows Explorer has encountered a problem and needs to close. We are sorry for the inconvenience." then i click on the report button and here is what comes up "Error signature
AppName: explorer.exe AppVer: 6.0.2900.2180 ModName: xvid.ax
ModVer: 0.0.0.0 Offset: 0003c4bc".
Would anyone know what causes this and how to fix it. Thanks.
  • 0

Advertisements


#2
DeSade

DeSade

    Member

  • Member
  • PipPipPip
  • 377 posts
Do you let the checkdisc run or do you cancel it in favor of a faster boot?
  • 0

#3
h0tpants

h0tpants

    Member

  • Topic Starter
  • Member
  • PipPip
  • 33 posts
i just let it run
  • 0

#4
wannabe1

wannabe1

    Tech Staff

  • Technician
  • 16,645 posts
Hello h0tpants

Click Start, then Run, type regedit, and click "Ok".

In the left pane, expand (click +) HKEY_LOCAL_MACHINE, then SYSTEM, then CurrentControlSet, then Control, and click on Session Manager.

Look in the right pane for the entry BootExecute. What is the value listed under the Data heading?
It should be autocheck autochk *

Please do not make any changes to the registry unless asked to do so by a Staff Memeber.

Let me know what you find...

wannabe1

Edited by wannabe1, 10 February 2006 - 08:13 AM.

  • 0

#5
h0tpants

h0tpants

    Member

  • Topic Starter
  • Member
  • PipPip
  • 33 posts
first of all, sorry for the delay. secondly, I checked all that and it the value was autocheck autochk*.
  • 0

#6
Retired Tech

Retired Tech

    Retired Staff

  • Retired Staff
  • 20,563 posts
Another option

Click Start, Run, and type in cmd then press enter

Then type in
chkntfs /x c:

This will stop Autochk from scanning drive c. If your main drive is the D:\ then type
chkntfs /x d:

Close out of the command window when the next prompt appears

To undo this setting at a later point:

Go to Start, Run, and type in cmd

Then type in
chkntfs /d
  • 0

#7
h0tpants

h0tpants

    Member

  • Topic Starter
  • Member
  • PipPip
  • 33 posts
okay, i tried the above and restarted but it still ran chkdsk at startup...anymore suggestions?? thanks.
  • 0

#8
wannabe1

wannabe1

    Tech Staff

  • Technician
  • 16,645 posts
For some reason, the "dirty bit" is not being unset... :tazz: Let's see if we can get it to do that. Please note the spaces in the following commands.

First click Start, then Run, bring up a command prompt by typing cmd in the Open box, and click "Ok". At the prompt in the Command window, type fsutil dirty query c: and press "Enter". This queries the drive, and more than likely it will tell you that it is dirty. Next, type chkntfs /x c: and press "Enter". The X tells Windows to NOT check that particular drive on the next reboot. At this time, manually reboot your computer, it should not do a chkdsk and take you directly to Windows.

Then click Start, then Run, bring up a command prompt by typing cmd in the Open box, and click "Ok". At the command prompt, type chkdsk /f /r c: and press "Enter" to manually run a full chkdsk operation. This should take you through 5 stages of the scan and will unset that dirty bit.

Finally, type fsutil dirty query c:, press "Enter", and Windows will confirm that the dirty bit is not set on that drive.

Now reboot again and see if chkdsk still runs on bootup.

Let us know how this goes...

wannabe1
  • 0

#9
h0tpants

h0tpants

    Member

  • Topic Starter
  • Member
  • PipPip
  • 33 posts
"C:\Documents and Settings\HP_Owner>chkdsk /f /r c:
The type of the file system is NTFS.
Cannot lock current drive.

Chkdsk cannot run because the volume is in use by another
process. Would you like to schedule this volume to be
checked the next time the system restarts? <Y/N>"

this is what i got after manually restarting the comp (it DID load Windows right up). i chose no to the scheduled check...??
  • 0

#10
wannabe1

wannabe1

    Tech Staff

  • Technician
  • 16,645 posts
Click Yes to run it...this is the part that should unset the dirty bit... :tazz:
  • 0

#11
h0tpants

h0tpants

    Member

  • Topic Starter
  • Member
  • PipPip
  • 33 posts
well, looks like its fixed. ran the dirty query and it said the drive is NOT dirty, rebooted and chkdsk did not run. thanks so much!!
  • 0

#12
wannabe1

wannabe1

    Tech Staff

  • Technician
  • 16,645 posts
Whew! Glad we got that sorted out! :tazz:

Glad we could help... :)

wannabe1

Edited by wannabe1, 17 February 2006 - 03:52 PM.

  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP