Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Slow Data Read Speed, LG CDRW CED-8080, TDK CDRW 5200B


  • Please log in to reply

#1
dakine

dakine

    New Member

  • Member
  • Pip
  • 4 posts
I am using a Dell Dimension 8100 pc that has two cd-rw drives installed. They are an LG CED-8080 and a TDK 5200B. Recently both drives started to read extremely slow. The LG burns at 8x. The TDK will not burn at all. I have changed my os from windows 2000 to xp pro and the problem is still there. The device manager says both drives are working fine. Any ideas???
  • 0

Advertisements


#2
makai

makai

    Portlock - Oahu

  • Member
  • PipPipPipPipPip
  • 2,793 posts
Aloha dakine... Welcome to GTG!

There may be several causes to your problem... once of which is corrupted firmware on the drives. Also, it could be that DMA transfers are not enabled, or have changed... also possibly due to corrupted drive firmware.

What you can do to check some things are...

Go to Start/My Computer... choose Properties
In the System Properties window, choose the Hardware tab, then click on Device Manager
In the Device manager window, look down the list and locate IDE ATA/ATAPI Controllers, and click on the (+) sign. Double click on Primary IDE channel
In the Primary IDE channel Properties window, choose the Advanced Settings tab. Under Transfer Mode, select DMA if available if it's not already the case. (Note the Current Transfer mode for reference... see Note below), then click on OK.
You may be prompted to restart your computer if you have made any changes, but don't restart yet.
If there are two IDE channels, you should also see an entry for Secondary IDE channel... double click on that and the Secondary IDE channel Properties window will open.
Do the same thing and ensure that DMA if available is selected... click on OK.
If prompted to restart your computer, do so now.

Note: If the current Transfer mode was PIO for either Primary or Secondary IDE channels, then the read/transfer speeds of your devices would be slower than normal. DMA is the prefered transfer speed.

After your computer restarts, go back into Device manager and check the Current transfer speeds for both channels. If both refer to some form of Ultra DMA transfer, then that should help your CD read problems.

The second thing to do is check for firmware updates for both of your drives. You may have to go to the manufactures website and download the correct firmware that pertains to your particular drive. DO NOT use an incorrect firmware or you can kill the drive.

I won't address what could be wrong with your TDK drive until we see if any of the above has helped. Let me know how it goes.

Edited by makai, 26 February 2006 - 11:48 PM.

  • 0

#3
dakine

dakine

    New Member

  • Topic Starter
  • Member
  • Pip
  • 4 posts
Thanks for the information Makai and mahalo!

My transfer mode was set to DMA if available. I updated the firmware on the TDK drive and it still runs slow. I was not able to find any firmware for the LG drive only drivers which I did not update. Here is some additional system information.

System Properties:
Manufacturer Dell Computer Corporation
Product Desktop Dimension 4100 XPS-Z

Computer:
Operating System Microsoft Windows XP Professional
OS Service Pack Service Pack 2
Internet Explorer 6.0.2900.2180
DirectX 4.09.00.0904 (DirectX 9.0)

Motherboard:
CPU Type Intel Pentium IIIE, 733 MHz (5.5 x 133)
Motherboard Name Intel Easton D815EEA (5 PCI, 1 AGP, 3 DIMM, Audio, Video)
Motherboard Chipset Intel Solano i815E
System Memory 256 MB (SDRAM)
BIOS Type AMI (08/29/00)
Communication Port Communications Port (COM1)
Communication Port Printer Port (LPT1)

Display:
Video Adapter NVIDIA RIVA TNT2 Model 64/Model 64 Pro (Microsoft Corporation) (32 MB)
3D Accelerator nVIDIA RIVA TNT2 M64
Monitor Samsung SyncMaster 955DF (H3LN209195)

Multimedia:
Audio Adapter Creative SB Live! Value (CT4780) Sound Card

Storage:
Floppy Drive Floppy disk drive
Disk Drive Maxtor 52049H3 (20 GB, 7200 RPM, Ultra-ATA/100)
Optical Drive LG CD-RW CED-8080B (8x/4x/32x CD-RW)
Optical Drive TDK CDRW5200B (52x/24x/48x CD-RW)

Partitions:
C: (NTFS) 19461 MB (11640 MB free)

Input:
Keyboard Standard 101/102-Key or Microsoft Natural PS/2 Keyboard
Mouse HID-compliant mouse
Mouse Microsoft PS/2 Mouse

Network:
Network Adapter 3Com EtherLink XL 10/100 PCI For Complete PC Management NIC (3C905C-TX)

Peripherals:
Printer HP DeskJet 840C/841C/842C/843C
USB Device USB Human Interface Device
  • 0

#4
makai

makai

    Portlock - Oahu

  • Member
  • PipPipPipPipPip
  • 2,793 posts
Hello dakine,

My transfer mode was set to DMA if available

What was the current transfer mode set to... Ultra DMA 2 or PIO mode?

Looking at your specs, I assume your machine was running Win98 prior to upgrading to XP.

When did you start having this problem? Did your drives run fine and then one day they started to run slow?

Edited by makai, 11 March 2006 - 05:12 PM.

  • 0

#5
dakine

dakine

    New Member

  • Topic Starter
  • Member
  • Pip
  • 4 posts
Thanks again Makai,

The current transfer mode for the Primary Ide Channel is
Device 0 = Ultra DMA Mode 5
Device 1 = Not Applicable

The current transfer mode for Secondary IDE Channel is
Device 0 = Multi-Mode DMA Word 2
Device 1 = Ultra DMA Mode 2

The prolem started about 3 months ago. The drives were working fine. The problem occured suddenly not gradually. I was using Windows 2000 Pro successfully for 2 years prior. I wiped the hard drive clean, reformatted and installed Windows XP Pro. Both drives still act the same way with Windows XP Pro.
  • 0

#6
makai

makai

    Portlock - Oahu

  • Member
  • PipPipPipPipPip
  • 2,793 posts
Hi dakine,

The current transfer mode for Secondary IDE Channel is
Device 0 = Multi-Mode DMA Word 2
Device 1 = Ultra DMA Mode 2



In the old days, computer IDE channels would run at the slowest speed of whatever devices were connected to it.

Your Device 0 is the the LG CED 8080. This drive is spec'd at PIO Mode 4 (Multi-Mode DMA Word-2). The transfer rate is only 16mb/s and it's possible it may be dragging down your TDK. Not only that, it's sitting in the Master slot.

Do you know if the drives are set up Cable Select, or Master and Slave?

You might want to do a couple things...

Go HERE and download Nero CD-DVD Speed. Run a transfer test on your drives before making any of the changes below. Record the speeds for later reference.

Next, set the TDK as the Master drive, and the LG as Slave. You will have to set jumpers on the drives to accomplish this. If you need help setting the jumpers, let me know. Restart and run Nero CD-DVD Speed again and see if anything changed.

Another thing you can do is disconnect the LG drive altogether and see if the TDK will speed up.

I don't think it's a bios thing, but it could be. Did you happen to change any bios settings at any time?

Edited by makai, 13 March 2006 - 08:26 PM.

  • 0

#7
dakine

dakine

    New Member

  • Topic Starter
  • Member
  • Pip
  • 4 posts
Still no luck:(

Both drives were setup as Cable Select. I disconected the LG drive. I switched between Cable Select and Master jumper settings on the TDK drive. I now have only the LG drive connected and set on Cable Select. There has been no improvement to either drive.

Should I look at the bios settings?

Maybe I need a new IDE cable?
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP