Jump to content

Welcome to Geeks to Go - Register now for FREE

Need help with your computer or device? Want to learn new tech skills? You're in the right place!
Geeks to Go is a friendly community of tech experts who can solve any problem you have. Just create a free account and post your question. Our volunteers will reply quickly and guide you through the steps. Don't let tech troubles stop you. Join Geeks to Go now and get the support you need!

How it Works Create Account

Wireless Network IP Problem

  • Please log in to reply



    New Member

  • Member
  • Pip
  • 2 posts
Ok, I'll go strait to it I suppose. I've been having problems recently with my home wireless connection between the family's desktop computer and my personal laptop. I'll explain the background on the two computers and the network first, then overview the problem I'm having and the 'solutions' I've experimented with.

So, the two computers:
The Laptop is a Toshiba Satellite L25-S119, with an Intel Celeron M Processor running at 1.50GHz. 192 MB of RAM.
The Desktop is an older version Gateway PC.
Both computers are running Windows XP Home Edition. Both computers have the standard Windows firewall established, and the desktop runs Norton Anti-Virus.

And the Network:
The Desktop is linked to the internet through an ethernet cable routed through a Linksys wireless router, which generates a Access Point, WPA secured network under the name 'linksys'. The laptop links to this network via wireless. It has a Netgear 108 Mbps Wireless PC Card WG511T.

The Story:
The wireless network was set up between these computers a few months ago. Initially, the network seemed to opperate without problem, and for the most part has continued to run smoothly; the only issues I've encourtered were solved by restarting the router. Just recently, though, I've encountered a problem that I've been unable to solve.
The problems began after taking my laptop to a relative's house, where I attempted to log in to their network. Their network, also a Linksys system, was itself proving unstable that day, but I was able to connect for short periods of time. Even though I was able to access internet at this time, however, the connection would continue to read "Not Connected." (I'm not sure if this part of the story is applicable, but I wanted to put it up just in case. One of my theories is that because their network was a Linksys network as well, my computer may have ... for lack of a better word, 'assimilated' the problems.)
Anyways, I took the laptop home and attempted to connect to my wireless network. Previously, it had done this automatically. When it attempted to connect this time, however, it spent nearly half an hour "aquiring network adress", and when this process ended, it read "Limited or No Connectivity." The signal strength was a full 'five bars', but I was unable to access the internet.

I immidiately began searching for the problem. My first action was to reset the router, which did not appear to change anything. I then attempted to turn the wireless of the laptop off, then on using the physical button stationed on the laptop. This, again, did not change anything.

I then went to the network connection area of the computer. I was suprised to see that there were too wireless networks. I opened the properties windows for both. The first, named "Wireless Network Connection", stated "Connect Using: Atheros AR5005G Wireless Network" ... The second, named "Wireless Network Connection 3", stated "Connect Using: NETGEAR 108 Mbps Wireless PC C".

I went through a regement of enabling one, disabling the other, enabling them both, etc, each time resetting the router and laptop. When using the first, it would only allow me to use the Windows network finding ... thing. When using "#3", it would only allow me to use the software that came with the Netgear card.
Either way, however, the result seemed to be the same. They would both continue to scan/search for network address, and never reach it. (Aside note: I noticed that whatever password I put in the WPA access prompt, as long as it was eight degits, it would work the same. It does, however, default each time to password that worked the first time ... so, I doubt this is applicable).

Next, when I tried to "repair" the network, it would end with a message indicating it could not properly renew the IP adress. I looked further, and noticed the IP address read: "", etc.
My attempted solution to this was to imput an IP address manually into both computers. (For the IP, I looked at what the PC used in the LAN that formed when the computers were linked by ethernet cable). This way, I was able to break through the first wall, but I stumbled on the rubble. Manually setting the IP allowed the wireless network to connect, but neither computer could then use the internet. So, I then set them both back to "Automatically Aquire IP Address", and was right back where I started.

In a final attempt, I ran the command promt: "cmd /k ipconfig"

What I got was:

Windows IP Configuration

Ethernet adapter Local Area Connection:
Media State .........: Media Disconnected
Ethernet adapter Wireless Network Connection:
Media State..........: Media Disconnected

In a final attempt, I asked a friend to look at it, and he created a .bat file with the following text:

ipconfig /release
ipconfig /renew
ipconfig /all

This didn't seem to have any effect, however.
I decided it was about time to go to the web for help. I hope I provided enough information to make the problem clear/apparent, and I appologize if this post is verbosely long >_<
Thanks in advance for any help, it will be greatly appreciated.

[PS] Oh, one last note. In the command window my friend's bat opened, I noticed a line: "IP Routing Enabled ......: No". I thought this might actually be the problem, but I couldn't find anywhere to 'enable' it.
  • 0





  • Member
  • PipPipPip
  • 217 posts
There is a known issue with some Toshiba laptops and the "limited or no connectivity" message. The fix is to download the latest wifi drivers from Toshiba's website.


Another thing that I've found helpful is to connect to www.support.microsoft.com and install the latest updates for your machine. This fixes alot of flaky wifi probs.
  • 0



    Member 2k

  • Member
  • PipPipPipPipPip
  • 2,896 posts
Also I reccomend that you change the connection name from the default linksys to some unique name. There may be other linksys networks in your neighborhood.
  • 0



    New Member

  • Topic Starter
  • Member
  • Pip
  • 2 posts
Thanks for the recommendations :whistling:

Downloading the drivers actually solved the problem of me having two networks ... somehow or another ... and I ended up with just the Netgear one running, which was pretty helpful to my cause.

We ended up re-installing the network software on the PC, and after some toying with options, it ended up working in the strange way computer things do.
  • 0

Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP