Jump to content

Welcome to Geeks to Go - Register now for FREE

Need help with your computer or device? Want to learn new tech skills? You're in the right place!
Geeks to Go is a friendly community of tech experts who can solve any problem you have. Just create a free account and post your question. Our volunteers will reply quickly and guide you through the steps. Don't let tech troubles stop you. Join Geeks to Go now and get the support you need!

How it Works Create Account

Win98 Does Not Offer IRQ for NIC

  • Please log in to reply




  • Member
  • PipPip
  • 13 posts
Howdy all. I'm working on a friend's computer that has Win98 SE installed. It's an old Pentium 133 (do you remember those???) but she just wants to surf the net. Here's the problem. When I insert the NIC into the PCI slot and load the drivers, an IRQ is not even offered for the NIC (which is required of course). I have tried four different NICS in four different PCI slots on the same motherboard to no avail. The PCI video card works on all four slots, so I think the PCI slots are cool. No matter which card is installed (or slot), an IRQ is not made available in the Resource Type listing. IRQ steering is working just fine, other devices are utilizing IRQ's, IRQ's can be viewed and reserved, and one IRQ is completely available (nothing else on it; IRQ 11). Basically if I could force an IRQ on a card, I would be cool, but that isn't possible.

Any ideas what is going on and how to fix it??? Thx in advance!

  • 0




    Trusted Tech

  • Member
  • PipPipPipPipPipPip
  • 3,476 posts
Some NICs won't work if the PCI bus doesn't support bus mastering. Nearly all Pentium PCs after 1998 do, but your friends machine sounds like it could be too old.
Open device manager & look under hard disk controllers. In win98 the hard disk controller normally (but not always) states bus master after the name if supported.

You could also try booting up in safe mode & removing any ghost entries from device manager for the NIC card. If you've have tried to install it several times, the chances are a lot of entries exist even though the card has been removed. These are only visible in safe mode.

After that, go into the bios & free up as many IRQs as possible - disable any unused com ports/parallel ports etc. Make sure the IRQs have not been reserved for ISA/legacy devices (except the ones that need to be).

You could also try playing about with the PnP OS setting & Resources Controlled manual/auto setting.

Failing that, try an ISA NIC. If IRQ 11 is still available, make sure it is reserved for ISA Legacy in the bios so hopefully the card will use that one.
  • 0

Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP