Jump to content

Welcome to Geeks to Go - Register now for FREE

Need help with your computer or device? Want to learn new tech skills? You're in the right place!
Geeks to Go is a friendly community of tech experts who can solve any problem you have. Just create a free account and post your question. Our volunteers will reply quickly and guide you through the steps. Don't let tech troubles stop you. Join Geeks to Go now and get the support you need!

How it Works Create Account

Win7: Driver Issue: Acer Aspire 6530 Synaptics Touchpad

  • Please log in to reply




  • Member
  • PipPipPip
  • 163 posts
I have recently purchased an Acer Aspire 6530 laptop, which comes shipped with Windows Vista x86. I promptly made the restore DVDs, and installed Windows 7 x64, with no issues, except, one rather important one: the TouchPad driver does not work.

When Windows first booted, the driver that comes with Windows worked fine. You did not get the scroll functionallity from the side of the pad, which is meant to act like a scroll, but it recognized movement and the two click buttons. After getting on the internet, Windows automatically went out and found the Synaptics TouchPad driver for me.

Now, according to Device Manager, the driver will function after a restart. TouchPad works fine, go to restart, driver is applied, and.. nothing. The mouse will not move. Any USB mouse if plugged in works fine, but the click buttons and the movement on the pad do nothing.

If you go into Device Manage and uninstall the device, the TouchPad works again! It seems whatever TouchPad drivers that are loaded with Windows 7 work like a charm, besides the built in scroll area, work wonderfully, but the driver that it automatically downloads/installs on boot does not after restarting and applying that driver, even though the device is fully functional according to Device Manager.

Is there any way to FORCE the built in Windows 7 drivers, or a known fix to get the normal ones to work? Does this have to do with 64bit vs 32bit at all?

Note: I have downloaded the driver from the Acer website for Vista and ran it in compadibility mode for Vista, with no change, so it is not just the one Win is automatically finding.

Note2: I tried booting without any internet connection after disabling the driver, but Windows went ahead and installed the driver anyway. It was either still downloaded, or in fact comes with 7 and is not gotten through Windows Update, but is not installed initially? Plug and play is weird sometimes =/.

Any help would be greatly appreciated.
  • 0




    New Member

  • Member
  • Pip
  • 1 posts
Hi... Well, I have am Aspire 6530 too. My mouse works very well, except de drill function, with de lateral arrows(to move up to down de side bar).

I don't do any special action, I only intalled the win 7.

Did you ever tryed re-install win 7? :)

PD: weel, now I remember, I don't now how I can desable the mouse like I can do with win Vista...

Edited by heptalquimista-mx-DF, 07 September 2009 - 03:52 PM.

  • 0

Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP