Jump to content

Welcome to Geeks to Go - Register now for FREE

Need help with your computer or device? Want to learn new tech skills? You're in the right place!
Geeks to Go is a friendly community of tech experts who can solve any problem you have. Just create a free account and post your question. Our volunteers will reply quickly and guide you through the steps. Don't let tech troubles stop you. Join Geeks to Go now and get the support you need!

How it Works Create Account


  • Please log in to reply




  • Member
  • PipPip
  • 10 posts
I keep getting this error everytime I try to update my laptop. I have Windows vista home premium edition.
I have tried what others suggested but may be i am doing them wrong. Below is what somewhat had written on another site, but it didn't work for me.Can someone help me with this?

After careful review, .NET 1.1 has been ammended to work correctly with Vista.
I think this may solve the issue for those who are affected:
Download and run the Windows Installer Cleanup Utility, and remove the .NET framework 1.1 from the machine.
Download .NET framework 1.1 from the Microsoft website and install it
Reboot your machine, then install .NET 1.1 SP1 from the Microsoft website and reboot your computer again. Then try to take the update once again.

Please let me know if this works, I have tried it on 2 machines and it seems to work okay, allowing the update to be installed.

Windows Installer Cleanup Utility
.NET Framework 1.1
.NET 1.1 SP1
  • 0


Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP