Jump to content

Welcome to Geeks to Go - Register now for FREE

Need help with your computer or device? Want to learn new tech skills? You're in the right place!
Geeks to Go is a friendly community of tech experts who can solve any problem you have. Just create a free account and post your question. Our volunteers will reply quickly and guide you through the steps. Don't let tech troubles stop you. Join Geeks to Go now and get the support you need!

How it Works Create Account

I can't get my Sidebar back without the administrator but I am the

  • Please log in to reply



    New Member

  • Member
  • Pip
  • 1 posts
Hi geeks!

I got my Vista laptop back in 2008 and when I got it, I hid the Sidebar as I found it annoying. I don't know whether I actually did hide it but I did something to it to make it disappear.
I now want it back but nothing I have done works.

Whenever I right click on Sidebar in my start menu, it says to me:
"Windows Sidebar is managed by your system administrator"
But I am the administrator and only user of my laptop. I doubled checked this with my user settings and it is correct. I changed the Sidebar properties so that all users of the computer have access to the Sidebar settings.
I found a forum and took it's advice and did the following:

"I've also had this problem for the last few weeks, though happily I fixed it

This was in part with a call with MS support, and in part watching what
sidebar.exe was doing with Procmon. I'm not certain that my reasoning is
correct below, but you may get some mileage from it.

I suspect that an application had installed a duff copy of atl.dll (in my
case I think it was from HP's IPaq Choice Points program - as procmon showed
a reference to an HP directory when sidebar tried to start up).

I uninstalled the HP program to be sure. In the same way you may wish to
search your machine to see if you have multiple copies of atl.dll before

Upon the advice of MS support, I unregistered a couple of sidebar DLLs. This
took me a little while as I didn't realise the DLL's are in Program
Files\Windows Sidebar directory (windows search never found them for me,
which is a touch annoying). Anyway to do this bit:

1. Start an elevated privileges command prompt
2. cd "\Program Files\Windows Sidebar"
3. regsvr32 -u sbdrop.dll
4. regsvr32 -u wlsrvc.dll

I then tried to re-register them, but it wouldn't work - I just got an error
message. After some hunting around, I decided to first register (re-register
?) ati.dll. I didn't try to unregister it first, and as I definitely only
had one ati.dll now, I didn't have to go looking for it to check I had the
right one - but you might have to. I don't know what will happen in you
unregister ati.dll so be warned.

So the next bit as I did it is:

1. From the same elevated command prompt (still in the C:\Program
Files\Windows Sidebar) directory
2. regsvr32 ati.dll
3. regsvr32 sbdrop.dll
4. regsvr32 wlsrvc.dll

With the ati.dll done first, the Sidebar DLLs registered fine. Then I tried
to start sidebar.exe again and it came up fine.

I had over previous weeks deleted all the sidebar settings and such like in
an attempt to get it working, so I guess that might still be necessary as
well - but my feeling is that it's really to do with the dll's above and the
settings removal isn't important.

Hope it works out for you, because this was annoying the heck out of me for


I did the first bit that unregisters them but as soon as I try the second bit, the ati.dll, it gives me this message: The module "ati.dll" failed to load. Make sure the binary is stored at the specified path or debug it to check for problems with the binary or dependent .DLL files. The specified module could not be found.

Under the sidebar properties > shortcut > advanced, I have selected "Run as Administator". Still nothing.
I have tried that and so much more but nothing is working.
  • 0


Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP