Jump to content

Welcome to Geeks to Go - Register now for FREE

Need help with your computer or device? Want to learn new tech skills? You're in the right place!
Geeks to Go is a friendly community of tech experts who can solve any problem you have. Just create a free account and post your question. Our volunteers will reply quickly and guide you through the steps. Don't let tech troubles stop you. Join Geeks to Go now and get the support you need!

How it Works Create Account

Windows Vista, Age of Empires 111 Windows XP

  • Please log in to reply



    New Member

  • Member
  • Pip
  • 1 posts
Hi guys

Hope you can help or point me in the right direction. My son has just bought an Age of Empires 111 game which is Windows XP, but our computer is Windows vista. I have tried to download the game with the install disc but it keeps coming up with "error 1646" network location. Have rung the games shop where we got it from and they said it should work,however I have tried everything this end, but as I am seriously not very computer literate, I am now lost as to what to do? Should it work? Is there anything i can do on my computer to get the game working?

Hope you can help, and if so could you explain it to me very simply as I am not computer savvy at all!! Sorry!!


  • 0


Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP