Jump to content

Welcome to Geeks to Go - Register now for FREE

Need help with your computer or device? Want to learn new tech skills? You're in the right place!
Geeks to Go is a friendly community of tech experts who can solve any problem you have. Just create a free account and post your question. Our volunteers will reply quickly and guide you through the steps. Don't let tech troubles stop you. Join Geeks to Go now and get the support you need!

How it Works Create Account

“The dependency service or group failed to start”

  • Please log in to reply



    New Member

  • Member
  • Pip
  • 1 posts
Hello everyone,

I am having a problem with my internet connection. My internet seems to be connected as normal – all the right lights are flashing on my modem! However, all of my programmes come up with error messages when trying to update or connect to the internet, and my browser says “server not found”.

The icon in the tray says “The dependency service or group failed to start”. After searching on some other forums, I tried running “sfc /scannow” but no luck and System Restore says I do not have any restore points.

This all seems to have happened after I ran a McAfee virus scan and also Malwarebytes Anti-Malware and SUPERAntiSpyware, but that may be a coincidence.

Any help appreciated.


  • 0


Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP