Jump to content

Welcome to Geeks to Go - Register now for FREE

Need help with your computer or device? Want to learn new tech skills? You're in the right place!
Geeks to Go is a friendly community of tech experts who can solve any problem you have. Just create a free account and post your question. Our volunteers will reply quickly and guide you through the steps. Don't let tech troubles stop you. Join Geeks to Go now and get the support you need!

How it Works Create Account

Windows server 2008 can't connect to a service

  • Please log in to reply




  • Member
  • PipPip
  • 20 posts
So I am going to see if you guys has more ideas than I do, else I am going to reinstall the whole thing. The problem started last week, the customer calls me in to let me know he can't connect to the server with RDP. It says 'can't connect to RPC server'. I fixed real quick by restarting both services : RPC & RPC Locator and verified that Printer spooler was up and running. Restarts the server (which takes 27 minutes as it has a DNS server for the exchange server!). Then it started to work back again. I logoff, 1 hour later he calls me back nothing works anymore, he added a printer (Canon IR3750) and nothing works, the wallpaper doesn't appear and most of desktop icons neither. So goes for the start menu. The start meny and the whole theme is back to windows 98.

I had to go down to it as it wasn't able to connect remotely thru any interface, once there I had to do a chkdsk c: /F /R as it was very very slow. which helped a ltl the boot time. But there is no way to do anything in the start meny, nothing related to mmc is available, it states in french 'Le canal n'est pas disponible' which means 'the channel isn't available'. Doesn't ring me any bell...

In safe mode I can access to my desktop but still nothing seems to work. I messed with services as it ways saying that It couldn't connect to profile service first. I put everything back as it was, for the simple reason that it just moves the problem to another service after that, I tried several hours to just play around with them it constantly moves to something different... Basically I have really no more idea else than to uninstall any .net above 2.0 if there is some, I fixed already any catroot2 error that should happen, I tried with a clean boot... Nothing works yet. I just can't believe what is happening there, I feel responsible in the fact that I restarted RPC services without doubting that something that huge was to pop.

So I am offering the guy to fix hes server this way: backup (I'll have to backup manually files as nothing works, I'll try NTBackup in Safe mode just in case) then import in a virtual server which I'ld host on a server I'll lend to them. If it is successfull I transfer all the actual employees to my server while I reinstall a brand new server then I reimport all the data.

All of this is a mess as for me to backup manually the whole exchange 2007 will be a pain (DNS,AD,Exchange,Mails,Files,Applications). They are accountings so they have new version of software for every last 10 years...

Truly if someone has better ideas than what I've already performed or any cue that should led a light in my shed, feel free to comment!

P.S.: Hardware seems all OK: Dell xeon 2.66 quad core 8G ddr 800 hdd 320G Lan 1G/s
  • 0


Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP