Jump to content

Welcome to Geeks to Go - Register now for FREE

Need help with your computer or device? Want to learn new tech skills? You're in the right place!
Geeks to Go is a friendly community of tech experts who can solve any problem you have. Just create a free account and post your question. Our volunteers will reply quickly and guide you through the steps. Don't let tech troubles stop you. Join Geeks to Go now and get the support you need!

How it Works Create Account
Photo

ati radeon x1720 malfunctioning


  • Please log in to reply

#1
lordbalzac17

lordbalzac17

    New Member

  • Member
  • Pip
  • 1 posts
When I boot up, I receive the following message:

Could not load file or assembly 'MOM.Implementation, Version=2.0.2758.39150, Culture=neutral, PublicKeyToken=90ba9c70f846762e' or one of its dependencies. The system could not find the file specified.

I'm running vista home premium on a dell inspiron 1521 and the ati radeon x1720 does not work. I have uninstalled it from device manager and reinstalled but that doesn't work.

Any thoughts?
  • 0

Advertisements


#2
phillpower2

phillpower2

    Mechanised Mod

  • Global Moderator
  • 24,702 posts
:welcome: lordbalzac17

That error message is caused by problems with the Catalyst Control Centre which as you will be aware is concerned with your AMD driver software.

See if this helps, uninstall all drivers and other software related to your video card, run driver sweeper to make sure that there are no stray files remaining that can interfere with a clean re-install http://www.guru3d.co...er-sweeper.html and then download new drivers from http://sites.amd.com.../downloads.aspx

Good luck but should you need it some additional guidance and troubleshooting steps http://support.amd.c...ementation.aspx
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP