Jump to content

Welcome to Geeks to Go - Register now for FREE

Need help with your computer or device? Want to learn new tech skills? You're in the right place!
Geeks to Go is a friendly community of tech experts who can solve any problem you have. Just create a free account and post your question. Our volunteers will reply quickly and guide you through the steps. Don't let tech troubles stop you. Join Geeks to Go now and get the support you need!

How it Works Create Account

Built New PC; Wireless Internet Problems

  • Please log in to reply



    New Member

  • Member
  • Pip
  • 1 posts

I'm sorry if this is the wrong place to post this topic on the forums; this is my first post. Anyways, I built my first PC. It has a Sabertooth Z77 motherboard, i5 Processor, 8 GB RAM, EVGA Geforce GTX 660Ti and all the other essentials. After building the computer outside of the case everything started up fine when I did the test run. I proceeded to transfer the components into the case, and after everything still worked fine. I installed Windows 7 64-bit. I decided to install a PCE-N53 PCI-E wireless Adaptor, N600, since I can not have an ethernet cable reach the computer from the other room. I installed the software to the adaptor using the ASUS WLAN utilities. After successfully connecting to the internet and even going to google.com to test, I noticed the internet speed was incredibly slow. I could not download Google Chrome since. It said it would take about 10 hours. I tried to do a system update and my internet speed is too slow to do it I believe. I have tried unplugging the adaptor and plugging it back in; however, it still is slow. I currently have the adaptor plugged into the PCIEX1_1 slot and I have the video card plugged into the PCIEX16_1 slot on the motherboard. I can not figure out what the problem is. I have a laptop in the same room (exact same distance as the computer built), and it's speeds are fast. Therefore, I'm almost certain that it's not the router or internet provider. I have not tried plugging an ethernet cable in because it is too far from the router to do so.

Long story short, is it possible that I have the PCI-E adaptor plugged into the wrong place on the motherboard? Or am I possibly installing the software incorrectly? Or even using the software incorrectly to connect to the router?

I've tried other things like unintalling and then installing using the windows wireless function. Now I can't even load a page on the browser.
  • 0


Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP