Jump to content

Welcome to Geeks to Go - Register now for FREE

Need help with your computer or device? Want to learn new tech skills? You're in the right place!
Geeks to Go is a friendly community of tech experts who can solve any problem you have. Just create a free account and post your question. Our volunteers will reply quickly and guide you through the steps. Don't let tech troubles stop you. Join Geeks to Go now and get the support you need!

How it Works Create Account

Data Recovery Issue

  • Please log in to reply




  • Member
  • PipPip
  • 12 posts
I enabled bitlocker encryption on my 1 drive and then I turn it off.
everything was working fine.
Then when I reboot my system I saw that my drive is nt accessible, I have to format it.
I have dual boot with redhat and I try to access it from there I got an error when I try to mount it invalid ntfs signature.
I tried bt5, ubuntu to access it but I am nt able to get access to, only 1 option is showing format.
I mean What the..., bitlocker encryption.
Guys I need your help bady I have 250gb data on it, I dunno what to do now .
I already tried following tools
segate file recovery software
EASEUS Data Recovery
remo recover windows
stellar phonix data recover system

and still googling

Help guys

Edited by CompCav, 19 January 2014 - 03:07 PM.
removed profanity

  • 0


Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP