Jump to content

Welcome to Geeks to Go - Register now for FREE

Need help with your computer or device? Want to learn new tech skills? You're in the right place!
Geeks to Go is a friendly community of tech experts who can solve any problem you have. Just create a free account and post your question. Our volunteers will reply quickly and guide you through the steps. Don't let tech troubles stop you. Join Geeks to Go now and get the support you need!

How it Works Create Account
Photo

safesearch on google


  • Please log in to reply

#1
alexis011

alexis011

    New Member

  • Member
  • Pip
  • 3 posts
hi everyone. I've been having some problems with this safesearch option on google browsers, whether they are on my ipad or on my computer. It appears to be on even though I want it to be off, and yes, I do know how to turn it off, but it just won't work, every time I try to change it it just goes back to filtering my google search. What worries me even more is that i have never turned it on myself, so I have doubts about this being a bigger problem than it might be. Should I be worried about this, and also how can i fix the problem?
  • 0

Advertisements


#2
phillpower2

phillpower2

    Mechanised Mod

  • Global Moderator
  • 24,809 posts
:welcome:   alexis011

 

Try the following and let us know if it resolves the issue;

 

  1. Remove SafeSearch Toolbar extensions from Google Chrome.
    Click the Chrome menu Chrome-button.png  button on the browser toolbar, select Tools and then click on Extensions.
    In the Extensions tab, remove (by clicking on the Recycle Bin) the SafeSearch extension from your Google Chrome.
    SafeSearch-Chrome-extension.jpg
  2. Set Google Chrome default search engine from safesearch.net to google.com .
    Click the Chrome menu Chrome-button.png  button, then select Settings and click on Manage search engines in the Search section.
    In the Search Engines dialog that appears, select Google and click the Make Default button that appears in the row.
    Search for SafeSearch in the Search Engines list, and click the X that appears at the end of the row.
    Default-serach-engine-Google.png
  3. Change Google Chrome homepage from safesearch.net to its default.
    The SafeSearch Toolbar has modified your Google settings to open their webpage whenever you start your browser, so we will need to revert this change.
    Click the Chrome menu Chrome-button.png  button, then select Settings and click on One the New Tab page in the On Startup section.
    on-startup-Chrome-default.jpg

  • 1

#3
alexis011

alexis011

    New Member

  • Topic Starter
  • Member
  • Pip
  • 3 posts
oh wow thank you so much! i will try this and let you know how it went.
  • 0

#4
alexis011

alexis011

    New Member

  • Topic Starter
  • Member
  • Pip
  • 3 posts
the second advice worked :) thank you so much :)
  • 0

#5
phillpower2

phillpower2

    Mechanised Mod

  • Global Moderator
  • 24,809 posts

You are most welcome and thank you for the follow up  :thumbsup:


  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP