Jump to content

Welcome to Geeks to Go - Register now for FREE

Need help with your computer or device? Want to learn new tech skills? You're in the right place!
Geeks to Go is a friendly community of tech experts who can solve any problem you have. Just create a free account and post your question. Our volunteers will reply quickly and guide you through the steps. Don't let tech troubles stop you. Join Geeks to Go now and get the support you need!

How it Works Create Account


  • Please log in to reply



    New Member

  • Member
  • Pip
  • 3 posts
hi, iv just formatted my drive, everything seems fine, but i attached my external hard drive to the usb port and well it recognises it but when i go to my computer nothing is there, i.e. the hard drive (h:) is not there i can only see the usual, c, d: and e:

i tried to download drivers for lacie from their website and also any other universal usb hub driver for windows 98, but no luck. i ran aida32 and got the following report, which i have attached.

pls heelp!!

thanks a bunch!

p.s. iv added a quick report rather than a full one, becuase everytime i attempt a full report via the wizard or aida32 it goes to a blue error screen and it terminates! :S

Attached Files

  • 0


Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP