Jump to content

Welcome to Geeks to Go - Register now for FREE

Need help with your computer or device? Want to learn new tech skills? You're in the right place!
Geeks to Go is a friendly community of tech experts who can solve any problem you have. Just create a free account and post your question. Our volunteers will reply quickly and guide you through the steps. Don't let tech troubles stop you. Join Geeks to Go now and get the support you need!

How it Works Create Account

Having trouble with partitions during a Windows 10 install.

- - - - -

  • Please log in to reply



    New Member

  • Member
  • Pip
  • 1 posts

Information copied across from a Reddit thread: https://www.reddit.c..._while_booting/


Long story short, I upgraded to Windows 10 from Windows 8.1, and it worked fine; I couldn't have been happier. Then, like a schmuck, I decided to try and do a clean install using the tools already in Windows (that is, not from recovery media). That's when things went wrong. Ever since then, when I've tried to boot up, I've got the standard blue screen with an INACCESSIBLE_BOOT_DEVICE error. The computer is a Dell Inspiron 5748, about 14 months old.


I've run the diagnostics that are on the F12 setup, and it didn't report any errors, so I'm relatively confident -- at least, as confident as I can be, not really knowing much about the advanced side of things -- that this isn't a hardware problem. It only happened when I tried to do a clean install -- that is to say, when I did an upgrade it worked OK -- so I'm hoping that this is something that should be relatively easy to fix and that I'm just overlooking something obvious.


When I go into the F2 setup, I can either set the Boot List Option to UEFI, or I can use a legacy option that allows me to set the first boot priority as a USB storage device (which is where I have my Windows 10 software, cheerily downloaded from the official Microsoft site). There's no way that I can find to change the boot priority when it's set to UEFI.


If I boot up using UEFI, no matter what other settings I use, I get the blue screen and the INACCESSIBLE_BOOT_DEVICE error. The computer then restarts and sends me through into the exact same spiral, not recognising the USB stick even when it's plugged in. If I boot up using the legacy option, however, it does recognise the USB stick and takes me through to the Windows Recovery Environment, complete with options to 'Install now' and 'Repair your computer'. Selecting repair gives me the option to troubleshoot, but...

  • Selecting Reset my PC gives the following error message: 'Unable to reset your PC. A required drive partition is missing.'
  • If I go into the advanced options, I can access the command prompt fine (but I have no idea what I'd do with it; it still works, though).
  • 'System Image Restore' gives me the message: 'Windows cannot find a system image on this computer. Attach the backup hard disk or insert the final DVD from a backup set and click Retry. Alternatively close this dialog for more options.' Cancelling that gives me the option to select the location of the backup, but there's nothing in the list.
  • Start Up Repair gives me a back screen that says 'Diagnosing', and then a blue screen saying 'Start-Up Repair couldn't repair your PC', and then instructs me to go back to 'Advanced Options'.
  • 'Go back to the previous build' tells me 'We ran into a problem and won't be able to take you back to the previous build. Try resetting your current build instead.'

If, however, I choose 'Install Now', it gives me the option to enter the product key (it's a legitimate install, and I had Windows 10 running perfectly for a couple of days, so as far as I can tell my computer is capable of checking that I have a real key even if I can't access it myself now; it was an update from Windows 8.1, so I didn't have to type the key in at any point in the upgrade) or to skip. I don't have access to it, so I skip. There's a standard-looking EULA, and then the question: 'Which type of installation do you want?'

  • Upgrade: Install Windows and keep files, settings and applications. When I click it, I get the following message: 'The computer started using the Windows installation media. Remove the installation media and restart your computer so that Windows starts normally. Then, insert the installation media and restart the upgrade. (Do not select Custom (advanced) to perform an upgrade. Custom (advanced) installs a new copy of Windows and deletes your programs and settings.)' I can't start Windows normally -- the whole INACCESSIBLE_BOOT_DEVICE -- and so I'm guessing that this option is out.

  • Custom: Install Windows only (advanced). Clicking this gives me a window labelled 'Where do you want to install Windows?' and a list of partitions (Drive 0 Partition 1: ESP; Drive 0 Partition 2: DIAGS; Drive 0 Partition 3; Drive 0 Partition 4: WINRETOOLS; Drive 0 Partition 5: O2 -- the biggest one, with a total size of 918 GB; Drive 0 Partition 6; and Drive 0 Partition 7 PBR Image). 1 is of the type 'System'; 2 is 'OEM (Reserved)'; 3 is 'MSR (Reserved)'; 4, 6 and 7 are 'Recovery'; 5 is 'Primary'. There are options to Refresh, Delete, Format (for everything except Partition 3), and Load Driver for all of them, and also buttons that say 'New' and 'Extend' (although these are greyed out). However, whichever one I select I get the alert 'Windows can't be installed on [drive 0 partition whatever-number]'. Partition 5 seems the most likely, and for that I get the notice 'Windows cannot be installed to this disk. The selected disk is of the GPT partition style'.

From what I can gather from sites like this one[1] , the problem is that I can't install on a GPT partition when I'm in anything other than in UEFI mode, but I can't boot from my USB when I am in UEFI mode. Again, not an expert in this, so I could be widely off the mark. I think the solution is to change the format from GPT to something else (MBR, if that sketchy-looking website is to believed), install Windows on it and then set it back to GPT once I have my computer working again, but I've never dealt with partitions before and it seems like the kind of thing that can easily go very wrong. Am I completely off the mark? Is anyone out there able to give me some guidance or maybe direct me towards what I need to do to get my computer working again?

  • 0




    Member 5k

  • Technician
  • 7,091 posts

Use MediaCreationTool to create the ISO.

Use Rufus to create the flash drive in UEFI/GPT mode.


Boot the flash drive and clean install Windows 10, deleting all partitions so you have a complete, unallocated hard drive.


Windows 10 - Clean Install

  • 0

Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP