Jump to content

Welcome to Geeks to Go - Register now for FREE

Need help with your computer or device? Want to learn new tech skills? You're in the right place!
Geeks to Go is a friendly community of tech experts who can solve any problem you have. Just create a free account and post your question. Our volunteers will reply quickly and guide you through the steps. Don't let tech troubles stop you. Join Geeks to Go now and get the support you need!

How it Works Create Account

Asus Laptop Stuck on Aptio Setup Utility Screen

windows 8.1 asus aptio bios

  • Please log in to reply



    New Member

  • Member
  • Pip
  • 1 posts
A few days before Christmas, my laptop suddenly froze and when to the "Aptio Setup Utility" screen. After exiting and saving, I was able to shut-down the computer and then launch windows normally. This continued on and Asus Laptop Stuck on Aptio Setup Utility Screenoff for two days, my laptop would freeze and I would "save and exit" in the Aptio Setup utility and relaunch windows as normal. After two days, the computer got stuck completely at the "Aptio Setup Utility" screen and choosing save and exit just relaunches back into the "Aptio Setup Utility" screen in a loop. I have tried 2 methods to fix it.  I tried the completely draining the battery by keeping the laptop on ( I didn't take it out of the laptop though) and that also relaunches back into the "Aptio Setup Utility" screen. I have also tried disabling "Secure boot Control" and enabling "Launch CSM" but that just takes me to a black screen saying "Reboot and Select proper Boot device or Insert Boot Media in selected Boot device and press a key".
Make and full model number of the laptop:
Asus UX301L NotebookPC (Windows 8.1/Intel Core I7)
What I was doing when it stopped working:
using Skype
In answer to some common questions:
Have you made any hardware changes?


Have you dropped or banged your laptop. ?


Does the LED blink?

I dont have an LED

Does it detect the hard drive?

Under the "SATA Configuration" it seems to be detecting the two hard drives.

Do you have a restore disk?

Unfortunately Not


Edited by Kikgirlll23, 06 January 2016 - 02:32 PM.

  • 0




    Member 5k

  • Technician
  • 7,091 posts

Found this, don't know if it will help or not.



If you see the bars at the top of the screen, there are five of them. What you want to do is go in all of them and look for update. You want to update and  then click < save changes and reset > and then your done.
You will see a blank screen for a couple of seconds and windows will boot up.
Thank You,
Colleen gregory Collins
Google,Youtube and Facebook


If not, see this post about how to reset BIOS:  http://rog.asus.com/...ll=1#post289588

  • 0

Similar Topics

Also tagged with one or more of these keywords: windows 8.1, asus, aptio, bios

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP