Jump to content

Welcome to Geeks to Go - Register now for FREE

Need help with your computer or device? Want to learn new tech skills? You're in the right place!
Geeks to Go is a friendly community of tech experts who can solve any problem you have. Just create a free account and post your question. Our volunteers will reply quickly and guide you through the steps. Don't let tech troubles stop you. Join Geeks to Go now and get the support you need!

How it Works Create Account

Windows PE3.0 does not detect SSD -- Driver Injection

  • Please log in to reply

Armand Snow

Armand Snow

    New Member

  • Member
  • Pip
  • 1 posts


I’m having an issue with getting Windows PE 3.0 to recognize hard drive. At least I think this is the problem. I’m attempting to boot a Dell Latitude E7470 Solid State Drive, Windows 7 64-bit machine from a WINPE3.0 USB thumb drive.

Initially, before I dug into injecting drivers, I would plug in USB and boot from USB and the Windows PE grey splash screen would show and attempt to load system files and then it would fail and restart and load Windows partition normally.

I try to boot from WINPE again and I press f8 quickly to access a command prompt, and run diskpart to see what drives are being detected. It turns out that WINPE3.0 is not detecting my solid state drive.

I then search out the right drivers for this model and I find out that I need these two: Picture: https://sli.mg/5pV7nu

I run 7zip to extract out these files/folders and then I run DISM to mount my boot.wim (from WinPE) and run the DISM command to inject the drivers into the unmounted .wim file.

I try two different ways of injecting drivers:

1) The first way is I use the DISM command to add in the drivers with the recurse switch option. I put all driver files above in one folder and run recurse. Picture: https://sli.mg/H9InCw

This inject works and takes a few minutes. I then unmount and commit and copy over my newly injected WINPE package and copy it over to my USB and attempt to boot and it gives me an error pointing to a .sys file. I tried deleting the .sys file but I realize that this won’t work because the .sys is unpackaged and has many dependencies tied to it.

2) Next, I narrow my focus inject only relevant drivers. I inject each driver and point to an .inf file and no success. I then point to the folder containing the driver files and no success. This time I get the same problem with WINPE just failing to detect driver and restarting.

What am I doing wrong here? Is this some problem with WinPE3.0 and SSDs because I tried this same WINPE3.0 environment on a different model Dell laptop (Win 7 64-bit) with a HDD and it works fine.

I appreciate any guidance here. Is there anything I’m missing? Thank you.

  • 0




    Founder Geek

  • Community Leader
  • 24,639 posts

Hey Armand, welcome to Geeks to Go! :D


Is your SSD drive detected by BIOS (press F2 at boot)? 

  • 0

Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP