Jump to content

Welcome to Geeks to Go - Register now for FREE

Need help with your computer or device? Want to learn new tech skills? You're in the right place!
Geeks to Go is a friendly community of tech experts who can solve any problem you have. Just create a free account and post your question. Our volunteers will reply quickly and guide you through the steps. Don't let tech troubles stop you. Join Geeks to Go now and get the support you need!

How it Works Create Account

Installing WIN7 to Acer ES15 Linpus Linux - Stuck - Please help! -

windows7 acer es15 linpus startingwindows bootable usb bios uefi

  • Please log in to reply



    New Member

  • Member
  • Pip
  • 1 posts

Dear  All,

This is my first post and topic , thank you for your attention and help in advance!
Today's my little sister birthday, so far I thought I could easily solve this case but so far no luck, that's why I'm asking you Ladies and Gentlemen to help!
Situation is the following:

Acer Aspire ES15-533-C3TW - Comes with Linpus Linux Lite - Brand new , first power on was done today.


I managed to get over the following obstacles:
-Pressed F2 to enter BIOS.

-Under Security I have set up Supervisor password

-This allowed me to Disable Secure boot uder Boot menu.

-Changed the priority order to boot from USB HDD: SanDisk cruzer blade
-The cruzer blade is 16GB size.
-WIth the help of the newest version of Rufus created the bootable usb drive :
    - FAT32 format (with NTFS didn't work previously it wasn't recognised, )
    - Tried both GPT partition and MBR partition for UEFI
   -Created it with the correct iso file
-In Boot menu in BIOS there is NO LEGACY mode only UEFI

-Saved the changes of course and restarted Windows in hopes that finally I can install windows 7 and could proceed with eating birthday cakes etc.

Windows is loading files - OK complete

Startng Windows <- this is a screen I got stuck

I have tried with 2 different versions of windows 7.

I've read this could be some driver error, but this laptop hasn't been used before, nothing is attached to the laptop.
As the boot starts ok it gets stuck on the Starting windows sign only.
I have waited 3 hours for something to happen but it didn't.


I would love to hear your suggestions , ideas, solutions.
The only thing what I've thought of is to install ubuntu first, and then try to install windows 7.
Sorry if I made any grammar mistakes I'm not a native speaker
I will monitor this topic 24/7 to reply asap as this is quite important for me as it is my little sister birthday present.

Thank you in advance
Wishing you a nice and geeky day


  • 0




    Malware Expert

  • Expert
  • 24,483 posts
  • MVP

There are a lot of unhappy users with similar problems on the Acer forum.  Doesn't look like your BIOS supports anything but UEFI.  


I wonder if a PXE boot would work as a workaround?  You need a second PC and they have to be able to talk over the network at boot so no WiFi on the target.  Has to be wired.


Then carefully follow the instructions here:




Haven't tried it myself but it should work.

  • 0

Similar Topics

Also tagged with one or more of these keywords: windows7, acer, es15, linpus, startingwindows, bootable usb, bios, uefi

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP