Jump to content

Welcome to Geeks to Go - Register now for FREE

Need help with your computer or device? Want to learn new tech skills? You're in the right place!
Geeks to Go is a friendly community of tech experts who can solve any problem you have. Just create a free account and post your question. Our volunteers will reply quickly and guide you through the steps. Don't let tech troubles stop you. Join Geeks to Go now and get the support you need!

How it Works Create Account

netsh question

  • Please log in to reply



    Visiting Consultant

  • Visiting Consultant
  • 48 posts



Trying to help someone with a Dutch computer having both a wired networkcard and wi-fi installed. These sometimes fail to work when swapping between wi-fi to the wired connection or vice-versa.

Tried to add some "set interface" lines using the netsh command.

The following commands do not work.

netsh interface ipv4 set interface "LAN-verbinding* 9" forwarding=enabled advertise=enabled nud=enabled ignoredefaultroutes=disabled
netsh interface ipv4 set interface "Wi-Fi" forwarding=enabled advertise=enabled nud=enabled ignoredefaultroutes=disabled

Returns with the message "incorrect parameter"


 What is wrong ?

  • 0




    Malware Expert

  • Expert
  • 24,538 posts
  • MVP

Best to run (from an elevated command prompt):

netsh interface ipv4 show interfaces

Which gives something like:



Idx     Met         MTU          State                Name
---  ----------  ----------  ------------  ---------------------------
 12          35        1500  connected     Ethernet
  1          75  4294967295  connected     Loopback Pseudo-Interface 1




then use the index number  (Idx) of the interface.  Also note the State of the interface.  If it says disconnected nothing you do is going to have an effect.

netsh interface ipv4 set interface "12"



Then add each parameter one at a time and see which one is causing the problem.  For what it is worth I don't see the need for any of your parameters.  The "netsh interface ipv4 set interface" command is not going to switch from using one interface to the other.  If the interface doesn't show "connected" in "netsh interface ipv4 show interfaces" it's not going to work.


Instead of netsh I would look at device manager

then right click on each network adapter and select Properties then Power Management (tab).  Uncheck

"Allow the computer to turn off this device to save power"

then hit OK.


Windows sometimes doesn't turn the adapter back on when it should.


Also look at newer drivers for your adapters.  Realtek in particular has had problems with Win 10.  Don't trust Windows to know if the drivers are the best.  Get them directly from the maker's site.


You might also look at

netstat -rn | more

(from an elevated command prompt)

Look at the metric for each IPv4 interface.  Assume you would want it to use the Ethernet if both were active so its metric should be set lower than than that of the WiFi



  • 0

Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP