Jump to content

Welcome to Geeks to Go - Register now for FREE

Need help with your computer or device? Want to learn new tech skills? You're in the right place!
Geeks to Go is a friendly community of tech experts who can solve any problem you have. Just create a free account and post your question. Our volunteers will reply quickly and guide you through the steps. Don't let tech troubles stop you. Join Geeks to Go now and get the support you need!

How it Works Create Account

Memory Management Error caused BSOD - Memtest86 results

Best Answer peyote , 09 February 2020 - 02:22 PM

Hi Phillpower2, thank you for the reply and sorry for the late reply. I ordered another set of TridentZs, a model that was actually on the MSI Tomahawk QVL, I ordered a listed compatible set (... Go to the full post »

  • Please log in to reply




  • Member
  • PipPipPip
  • 161 posts

Hi there,


I just built a new PC and today while gaming I had, for the first time, an instant shut-down with the Windows error "Memory Management Error". It instantly re-booted without issue and I ran the Windows memory diagnostic tool which came back "no errors" so I made a USB memtest86 image and ran the test. It took over 3 hours to complete and it came back with a number of errors and a FAIL.


I am not sure what these errors mean or if they point to a specific issue with the memory/ram ? The test was run with XMP on, which was the only over-clock as my rams default speed was 2133MHz and I had to enable an XMP profile to get it to its advertised speed, 3200MHz. I am just about to run the test again with XMP off but as it takes over 3 hours to complete I may not get the results until I wake tomorrow.


I recycled my PSU from my previous build and although I have had no issues at all with my current PSU (Corsair CS650M) and it is only 2-3 years old, only by chance, I did order a better model PSU today (Corsair RM650X)  as I wanted to get a better rated one and a better quality, the BSOD happened a couple of hours after I placed the order, it is arriving tomorrow so I will run the test again with XMP off and a new PSU, I will have this results tomorrow, only mentioning this as some have said that failing/faulty PSUs can cause a memory management errors but as said, I have not had any issues at all or no reason to suspect it is the PSU.


Other than this BSOD, it has been running fine with a few benchmarks performed with 3dMark and some stress tests with prime95, Furmark, ect., just the usual stuff when building and testing newly built PCs. I had some small problems when updating the BIOS, windows trying to boot from previous, but no longer installed, OS on SSD but resolved this. Also a very slow boot up time which turned out to be the GPU was not fully aligned with the back of the PC tower which caused the HDMI connector, which plugs into the GPU HDMI port, to touch the chassis bracket on the back of the PC, when sorted fixed the slow boot time instantly. Just wanted to mention this as this build has not been completely without its issues but everything was perfect up until today., no other major issues but this sudden, unexpected BSOD.


I have copy 'n' pasted the report below. If you need any other details let me know, the only other thing that is not in the details below is that the GPU is an RX580 (8gb), if this adds anything useful.


Thank you  for looking.







Report Date 2020-02-03 19:50:55

Generated by MemTest86 V8.3 Free (64-bit)

Result FAIL


System Information


EFI Specifications 2.70




Manufacturer Micro-Star International Co., Ltd

Product Name MS-7C02

Version 1.0

Serial Number To be filled by O.E.M.



Vendor American Megatrends Inc.

Version 3.50

Release Date 11/07/2019



Manufacturer Micro-Star International Co., Ltd

Product Name B450 TOMAHAWK MAX (MS-7C02)

Version 1.0

Serial Number JB16608588

CPU Type AMD Ryzen 5 2600X Six-Core

CPU Clock 3637 MHz [Turbo: 4293.1 MHz]

# Logical Processors 12

L1 Cache 12 x 96K (94642 MB/s)

L2 Cache 12 x 512K (78849 MB/s)

L3 Cache 1 x 16384K (33868 MB/s)

Memory 16347M (18265 MB/s)


DIMM Slot #0    8GB DDR4 XMP PC4-25600

                           G Skill Intl / F4-3200C16-8GTZB

                           16-18-18-38 / 3200 MHz / 1.350V


DIMM Slot #1    8GB DDR4 XMP PC4-25600

                            G Skill Intl / F4-3200C16-8GTZB

                           16-18-18-38 / 3200 MHz / 1.350V


Result summary


Test Start Time - 2020-02-03 16:34:54

Elapsed Time - 3:12:50

Memory Range Tested 0x0 - 41F380000 (16883MB)

CPU Selection Mode Parallel (All CPUs)

ECC Polling Enabled

# Tests Passed 43/48 (89%)


Lowest Error Address 0x2FE379564 (12259MB)

Highest Error Address 0x3041F5564 (12353MB)

Bits in Error Mask 0000000000000020

Bits in Error 1

Max Contiguous Errors 1


Test                                                                    # Tests Passed         Errors

Test 0 [Address test, walking ones, 1 CPU]       4/4 (100%)             0

Test 1 [Address test, own address, 1 CPU]        4/4 (100%)             0

Test 2 [Address test, own address]                     4/4 (100%)             0

Test 3 [Moving inversions, ones & zeroes]        4/4 (100%)             0

Test 4 [Moving inversions, 8-bit pattern]           3/4 (75%)               1

Test 5 [Moving inversions, random pattern]       3/4 (75%)              1

Test 6 [Block move, 64-byte blocks]                  4/4 (100%)             0

Test 7 [Moving inversions, 32-bit pattern]         1/4 (25%)               5

Test 8 [Random number sequence]                     4/4 (100%)             0

Test 9 [Modulo 20, ones & zeros]                       4/4 (100%)             0

Test 10 [Bit fade test, 2 patterns, 1 CPU]            4/4 (100%)             0

Test 13 [Hammer test]                                         4/4 (100%)             0



Last 10 Errors

2020-02-03 19:10:25 - [Data Error] Test: 7, CPU: 8, Address: 2FE379564, Expected: 00000040, Actual: 00000060

2020-02-03 19:10:25 - [Data Error] Test: 7, CPU: 8, Address: 2FF021564, Expected: 00000020, Actual: 00000000

2020-02-03 19:10:10 - [Data Error] Test: 7, CPU: 9, Address: 301045564, Expected: 00000020, Actual: 00000000

2020-02-03 18:17:48 - [Data Error] Test: 7, CPU: 9, Address: 3000E1564, Expected: FFFF7FFF, Actual: FFFF7FDF

2020-02-03 18:05:00 - [Data Error] Test: 4, CPU: 10, Address: 3041F5564, Expected: 04040404, Actual: 04040424

2020-02-03 17:25:22 - [Data Error] Test: 7, CPU: 8, Address: 2FEA0D464, Expected: FFFFBFFF, Actual: FFFFBFDF

2020-02-03 16:37:03 - [Data Error] Test: 5, CPU: 9, Address: 301FD9464, Expected: 62D5B271, Actual: 62D5B251

Edited by peyote, 03 February 2020 - 03:02 PM.

  • 0




    Mechanised Mod

  • Global Moderator
  • 24,820 posts

Hello peyote,


Any crash dmps for us;


1. Copy any dmp files from C:\Windows\Minidump onto the desktop.
2. Select all of them, right-click on one, and click on Send To> New Compressed (zipped) Folder.
3. Upload the zip folder using the Attach button, bottom left of the dialogue input box 


Download then run Speccy (free) and post the resultant url for us, details here, this will provide us with information about your computer hardware + any software that you have installed that may explain the present issue/s. 


To publish a Speccy profile to the Web:

  1. In Speccy, click File, and then click Publish Snapshot.
  2. In the Publish Snapshot dialog box, click Yes to enable Speccy to proceed.
  3. Speccy publishes the profile and displays a second Publish Snapshot. You can open the URL in your default browser, copy it to the clipboard, or close the dialog box.

Testing RAM properly takes many hrs as each stick needs to be tested independently and in different slots, we can provide the full steps for this once we have the above info to go through.

  • 1




  • Topic Starter
  • Member
  • PipPipPip
  • 161 posts
✓  Best Answer

Hi Phillpower2, thank you for the reply and sorry for the late reply.


I ordered another set of TridentZs, a model that was actually on the MSI Tomahawk QVL, I ordered a listed compatible set (F4-3200C14D-16GTZSW), the set arrived and I fitted them, ran Memtest86 at the RAM's default speed, and again with the XMP profile on (3200Mhz), both tests found no errors at all, and that is with each test running for over 3 hours and 26 different sub-tests in total; 100% pass and not a single error. So, either the original set (F4-3600C19D-16GTZRB) were faulty or the errors were a result of incompatibility, even though they are on the G.Skill QVL but not on the MSI Tomahawk Max QVL. I will know in a week or two as I sent the F4-3600C19D-16GTZRB back to the shop and they are sending me a new set, I will test them and see if they produce errors, if they do not then I will know that they were faulty and not due to incompatibility.


The set I have fitted now, and working perfectly (F4-3200C14D-16GTZSW), unfortunately they cost much more, nearly triple the cost of the set that have been returned for a replacement and they only difference is colour, B-die chips instead of E-die and CL14 instead of CL16. I could not wait for the replacement set to arrive as I would be without the computer for 1-2 weeks while they are returned, received by the shop an then re-shipped and the new set were the cheapest similar set that were on the QVL and they only ones available at the time, the CL14 version had to come from Germany as they were nowhere to be found in the UK and I had my mind set on G.Skill TridentZs.

  • 0



    Mechanised Mod

  • Global Moderator
  • 24,820 posts

Hello peyote,


No worries and thanks for the update  :thumbsup:


In case you are not already aware, the earlier gens of Ryzen CPUs are notoriously picky about the spec of RAM that they will work with but AMD seem to have sorted this with the 3rd generation of Ryzens.


Regarding the cost of the replacement RAM, the lower the Cas Latency the higher the cost I`m afraid, you are paying for the better performance.

  • 1




  • Topic Starter
  • Member
  • PipPipPip
  • 161 posts

I just stared playing a game (RE2 Remake) and had another crash, it looked like the same BSOD (Memory Management Error) but I could not see it in full as the screen was all green apart from the corner of the screen that was blue with part of the windows sad face :( but I bet it was the same error.


I just looked for the crash report in the event viewer and this is what is there;


Fault bucket 2109835725553938940, type 4
Event Name: APPCRASH
Response: Not available
Cab Id: 0

Problem signature:
P1: Radeonsoftware.exe
P3: 5e2b44b6
P4: Radeonsoftware.exe
P6: 5e2b44b6
P7: c0000005
P8: 0000000000405577

Attached files:

These files may be available here:

Analysis symbol:
Rechecking for solution: 0
Report Id: 9a281e6b-989f-4f2f-8f0c-3fd351468c72
Report Status: 268435456
Hashed bucket: 6a9871c56b38cefc9d47a469fc1231fc


Below the crash report is an error which says "Application Error" Event ID 1000 Task Category (100) with the following text;


Faulting application name: Radeonsoftware.exe, version:, time stamp: 0x5e2b44b6
Faulting module name: Radeonsoftware.exe, version:, time stamp: 0x5e2b44b6
Exception code: 0xc0000005
Fault offset: 0x0000000000405577
Faulting process ID: 0x278c
Faulting application start time: 0x01d5e32c6b94af49
Faulting application path: C:\Program Files\AMD\CNext\CNext\Radeonsoftware.exe
Faulting module path: C:\Program Files\AMD\CNext\CNext\Radeonsoftware.exe
Report ID: 9a281e6b-989f-4f2f-8f0c-3fd351468c72
Faulting package full name:
Faulting package-relative application ID:


I had a look at event viewer > windows log > application, and there seems to be a number of errors but only the above error has caused a BSOD and this is the first BSOD since replacing the memory.


Any ideas what this could be? I can post what ever details you need but not sure what I need to post that would be useful. I thought I had this fixed.

  • 0



    Mechanised Mod

  • Global Moderator
  • 24,820 posts

Two different issues by the look of it and this one software not RAM related I`m afraid  :(


I suggest that you start a new thread on the appropriate Windows forum and someone will help you there, include in your OP the crash dmps and Speccy url as detailed in my reply #2 above, please note that it is important that you only upload the dmp files using the method that I provided.

  • 0




  • Topic Starter
  • Member
  • PipPipPip
  • 161 posts

OK thank you, I will. Thanks for your help!

  • 0



    Mechanised Mod

  • Global Moderator
  • 24,820 posts

You are welcome  :)

  • 0

Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP