Jump to content

Welcome to Geeks to Go - Register now for FREE

Need help with your computer or device? Want to learn new tech skills? You're in the right place!
Geeks to Go is a friendly community of tech experts who can solve any problem you have. Just create a free account and post your question. Our volunteers will reply quickly and guide you through the steps. Don't let tech troubles stop you. Join Geeks to Go now and get the support you need!

How it Works Create Account

RDP won't connect anymore remote server

- - - - -

Best Answer HaraMo , 04 June 2020 - 03:08 AM

Dear issue found, my ISP model with build in router and firewall. I'm sure I disabled the firewall and still could't get  connected. I have this filling that the ISP firewall is... Go to the full post »

  • Please log in to reply




  • Member
  • PipPipPip
  • 456 posts



I'm not sure if this happens because I recently upates my own windows 10 client laptop, and also the server.


But for some reason, I cannot log in to the server with microsoft rdp.


As if the server is ofline.


I checked all basic on server side, and seems ok.


I still can't get connected.



What is strange, I have two ISP, when I switch to the second one, suddenly I could connect, but this was only one time.


so it' after I tried many thing, I went back to the basics. on the server side:


checking port 3389 with a portschecker, after closing the remote desktop services , the port , udp en tcp are open.


AFter starting the service, only the udp cannot be checked anymore because the remote desktop service is active. But I still can check the Tcp port 3389 and get green message that port is open.


But shouldn't be this port in use after staring the remote desktop service?



I don't knowi if it's my laptop or something with the server. I even removed the latest update from my laptop, but issue is not solved. disabled my firewal (bitdefender) ... .



I do have to add: I have another server, that is first to be started with vpn, then I can connect to my account using the rdp icon related to it. for this server , my laptop has no issues.




After trying and trying to connect to the first server ,that has nothing to do with the other server, I see sometimes the message: configuring remote session and gets stuck at this for a long time


If I repeat it again to connect: then I got the message: the remote connection is being started.. (traslanted), and not long I receive the message  in a window , showing the reasons why the connection cannot be established: computer is off, ... 


HOpe someone can help me with this issue.






  • 0





  • Topic Starter
  • Member
  • PipPipPip
  • 456 posts
✓  Best Answer



issue found, my ISP model with build in router and firewall.


I'm sure I disabled the firewall and still could't get  connected.


I have this filling that the ISP firewall is not 100% accurate when it turns on or of, even it gives no error, you think all is ok, ... .


Anyway, will this time make a log of this firewall, each time i change something, just to see if the firewall has an issue!.




I could not even call using WhatSapp.. strange, this worked whole time, while firewall was set on high , but this time, it seems as if the high option just went in to action.. very strange.

  • 0

Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP