Jump to content

Welcome to Geeks to Go - Register now for FREE

Need help with your computer or device? Want to learn new tech skills? You're in the right place!
Geeks to Go is a friendly community of tech experts who can solve any problem you have. Just create a free account and post your question. Our volunteers will reply quickly and guide you through the steps. Don't let tech troubles stop you. Join Geeks to Go now and get the support you need!

How it Works Create Account

Blasted History

  • Please log in to reply



    New Member

  • Member
  • Pip
  • 2 posts

In internet explorer I have wiped the history, deleted all temp files and cookies, and even deleted all my bookmarked sites but some sites still appear when I go to enter a URL:

These are sites I have not visited recently. and
Any ideas where these sites are stored and how I can delete them?
  • 0




    Member 4k

  • Member
  • PipPipPipPipPipPipPip
  • 4,867 posts
Hi sundials, welcome to GTG. I assume you are refering to the autocomplete function in IE. To turn this off, please go to the following in Internet Explorer:

Tools > Internet Options
Content > AutoComplete
Under "Use AutoComplete for" uncheck the box labeled "Web addresses"

If you require more assistance with this topic, please post a reply.

  • 0

Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP