Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Event viewer's error


  • Please log in to reply

#1
inite

inite

    Member

  • Member
  • PipPipPip
  • 409 posts
Posted Image

For no reason, my connection just d/c itself, and when i checked the event viewer, thats the error and its description. Any clue wads wrong?

"The operation was canceled by the user." <-- obviously i didnt do this.
  • 0

Advertisements


#2
Dan

Dan

    Trusted Tech

  • Retired Staff
  • 1,771 posts
Hi inite,

Is this a recurring error? Is it still causing you problems? If not, it's really not too big of a deal. Every so often your connection can just become stale, resulting in the same error as you're recieving, and the temporary loss of connection. It only becomes an issue if it is a recurring error.

"The operation was canceled by the user." <-- obviously i didnt do this.

That simply means that is was cancelled on your end; not necessarily by you. Once again, this can be caused by many things, but is really not a problem if it's a one-time occurrance. If it pops up again / often, then please let us know, and we'll look into it. If not, then there's nothing to really worry about.

- Dan
  • 0

#3
inite

inite

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 409 posts
it happens once every 2 days or so. Might not be very serious, but it can be very irritating.

However in the last 15 mins or so , it has happened twice.

Posted Image

Edit : Btw, just had my 3rd d/c by that error again... Could it be due to over usage of bandwidth somehow? Everything is fine right after i restart comp, even if the connection is down 30 secs ago .

Edited by inite, 04 March 2006 - 06:02 AM.

  • 0

#4
Dan

Dan

    Trusted Tech

  • Retired Staff
  • 1,771 posts
Okay well, yes now it's a problem :tazz:

The most likely cause of this error is software, and more specifically, a Firewall. What sort of Firewall do you have on the computer experiencing problems?

What you can try to do is add your DNS Servers, and your router's IP Address to your Firewalls Trusted Zone. This will ensure that your firewall isn't getting in the way with your computer's connection to the Internet. The fact that it's so intermittent makes it a little harder to troubleshoot :)
  • 0

#5
inite

inite

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 409 posts
Im only using zone alarm, and i have heard that xp sp 2 has a firewall in itself already, so could i have 2 firewalls clashing into each other?

Anyway, most of the time i close down zone alarm the very second i reach window cos zone alarm slows me down terribly. So my guess is the built-in firewall's doing?

"DNS Servers, and your router's IP Address " I know my router's ip address, but where can i get a DNS server and add them to my firewall?

Sorry if those sounds n00b, cos that is wad i am =)
  • 0

#6
Dan

Dan

    Trusted Tech

  • Retired Staff
  • 1,771 posts

Sorry if those sounds n00b, cos that is wad i am =)

Not at all :tazz: Usually I post the steps on how to do what I suggest, however last night I was sleepy :) So, sorry.

Im only using zone alarm, and i have heard that xp sp 2 has a firewall in itself already, so could i have 2 firewalls clashing into each other?

That's definitely a possibility. I would highly recommend turning off the Windows Firewall.

Goto Start --> Settings --> Control Panel --> Click on Security Center --> Select Windows Firewall --> Select Off (not recommended) and then click Apply.

Now, goto Start --> Run --> Type Services.msc --> Scroll down to Windows Firewall/Internet Connection Sharing (ICS) --> Right-click and select Properties --> Change the Start-up type to Disabled and then click the Stop button --> Press Apply and then close those windows.

To find your DNS Servers, goto Start --> Run --> type CMD and press OK --> then type: IPCONFIG /ALL --> Look for DNS Servers .... [IP Addresses] -- there should be more than one.

To add it to your ZA's trusted Zone --
  • Select Firewall Zones.
  • Click Add and then select Host/Site.
  • Select Trusted from the Zones drop-down list.
  • Type one DNS Server address in the Host name field.
  • Type a description, ie DNS Server
Repeat these steps for each DNS Server.

Once done, restart your computer and then see if you still lose your connection / recieve that error.
  • 0

#7
inite

inite

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 409 posts
Posted Image

I've actually only one dns server.

And also, in the screenshot, i believe my DNS server is already added in the first entry. The 3 rd one is my entry, seems like a replication of the default. Should i just delete it?

If my DNS server is already added to my firewall, then what could have caused the problem? =/
  • 0

#8
Dan

Dan

    Trusted Tech

  • Retired Staff
  • 1,771 posts

And also, in the screenshot, i believe my DNS server is already added in the first entry. The 3 rd one is my entry, seems like a replication of the default. Should i just delete it?

If you like; shouldn't hurt either way.

Are there any other computer's on your Network? If so, are any of these experiencing disconnects?

Goto Start --> Programs --> Accessories --> Communications --> Network Connections --> Right-click your Local Area Connection --> Select Properties --> Press the Configure... button, next to your NIC --> Select the Advanced tab --> Under Property, select Media Type --OR-- Link speed/Duplex Mode --OR-- Network Link Selection, Connection Type, Duplex Mode, or any similarly-named property which can have Values looking like Auto-Negotiation, or 10BT, or 10BaseT. --> Now you'll see the Value: -- this will tell you what Duplex it is set at. In the Value box, select a value which either (a) explicitly says half-duplex or semi-duplex, or (b) at least does not say full-duplex [e.g. 10BaseT on its own is OK]. If there is a choice between 10 and 100 with half-duplex, choose the 10. Do not choose 10Base5, 10Base2, or AUI.

Once done, restart your computer and then see if you still become disconnected. Still getting disconnected? Then, for kicks and giggles you could setup a Static IP, which would, in theory, remove the need to communicate with the DHCP Server, and subsequently stop you from becoming disconnected.

Goto Start --> Programs --> Accessories --> Communications --> Network Connections --> Right click on your Local Area Connection --> Select Properties --> Click on Internet Protocl (TCP/IP) once and press the Properties button --> Select the option Use the following IP Address: --> Enter in the IP Address [192.168.2.103], Subnet Mask [255.255.255.0] and Default Gateway [192.168.2.1] --> Now select Use the following DNS Servers --> Enter in the DNS Server [192.168.2.1] --> Press OK.

Restart you computer and then see if you still become disconnected. If you do, then you can return your settings to Obtain an IP Address automatically and Obtain DNS Server address automatically, if you so wish.

- Dan
  • 0

#9
inite

inite

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 409 posts
Ok, thx for help. That helped for a few days, but now theres another disconnect. I thought it was the same error, but it isnt.

Happened 3 times in 8 hours :

The Computer Browser service terminated with the following error:
This operation returned because the timeout period expired.

For more information, see Help and Support Center at http://go.microsoft....link/events.asp.


  • 0

#10
Dan

Dan

    Trusted Tech

  • Retired Staff
  • 1,771 posts
Hi inite,

Have you recently removed malware from your computer? Try WinsockFix. Once run, reboot and test your connection.

If that fails, please goto Start, Run, type CMD, press 'OK', then type the following commands:
  • netsh winsock reset catalog
  • netsh int ip reset reset.log
Reboot and test.

Do you still become disconnected?
  • 0

Advertisements


#11
inite

inite

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 409 posts
Hi Dan G,

I removed my malware some weeks back now. I tried the socksfix, restarted comp, and im hopeful nothing happens from now. Whatever it is, i'll post back at the end of the day =)

Ty for ur prompt help. Appreciated.
  • 0

#12
inite

inite

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 409 posts
Posted Image

btw, my default option was actually the auto-negativity, i've changed it as shown above, hopefully that is the best option ?

Just out of curiousity, y not choose the 100base half duplex?

EDIT :

Just as i posted the image, i got d/c again. Same error :

The Computer Browser service terminated with the following error:
This operation returned because the timeout period expired.

For more information, see Help and Support Center at http://go.microsoft....link/events.asp.


Edited by inite, 15 March 2006 - 09:23 PM.

  • 0

#13
Dan

Dan

    Trusted Tech

  • Retired Staff
  • 1,771 posts
Hi inite,

I'm going to suggest a general clean-up for your computer. I would recommend that you run CCleaner (Note: this will also delete all of your Temp Files, History and Cookies).
  • Install it.
  • Update it.
  • Check the default settings in the left-hand pane, ensure you uncheck old prefetch data found under the system tab, then click Analyze> Run Cleaner. You may be fairly surprised by how much it finds. Also click Issues then Scan for issues - fix selected issues.
Once run, restart your computer and then see if you still become disconnected.

Also, are you using the Windows Firewall? If so, have you been shutting this down recently / messing with it's configuration, etc?

- Dan
  • 0

#14
inite

inite

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 409 posts
I'll try the ccleaner in a while.

I've turned off my window's firewall. Would this be advisable since i always turn off my zone alarm as well.

btw, my default option was actually the auto-negativity, i've changed it as shown above, hopefully that is the best option ?

Just out of curiousity, y not choose the 100base half duplex?


  • 0

#15
Dan

Dan

    Trusted Tech

  • Retired Staff
  • 1,771 posts

Just out of curiousity, y not choose the 100base half duplex?

Duplexing speed is simply how your two devices communicate with each other (at what speed/format, etc). You could put your duplex speed to 100base Half if both of your devices are able to operate on that speed. However, your best bet is to return the Duplexing back to auto-sensing / auto-negotiating, as this will detect and implement the best solution for your devices.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP