Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

USB Memory Stick isnt Found


  • Please log in to reply

#1
doire

doire

    Member

  • Member
  • PipPipPip
  • 210 posts
Hi,

When i go onto My Computer to open up my memory stick it isnt there.

I have:

Checked in Device Manager and it shows up and says its working properly.

Swiched USB ports with a USB keyboard...the keyboard works ok but the Memory Stick isnt there again.

Disconnected whatever Network Drives i have on the pc in order to free up drive letters...still doesnt help.

If i put the USB stick in.....then reboot....it shows up in My Computer but if i then take it out and put it back in again it doesnt show up.

Im running XP SP2.

Thanks for any help.
  • 0

Advertisements


#2
gerryf

gerryf

    Retired Staff

  • Retired Staff
  • 11,365 posts
does it behave the same way on different PCs?
  • 0

#3
doire

doire

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 210 posts
Hello Gerry,
I have tried two other memory sticks and still the same problem.

The sticks work fine on other pcs.

Wonder why when i have it plug in, then reboot, it shows up ok???? :tazz:
  • 0

#4
doire

doire

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 210 posts
Would changing the Drive letter of the stick help?

Can this be done manually?
  • 0

#5
gerryf

gerryf

    Retired Staff

  • Retired Staff
  • 11,365 posts
yes, but I do not see that it would help

start > run
devmgmt.msc
<enter>

scroll down to USB ROOT HUB, select each, right click, choose PROPERTIES, go to POWER MANAGEMENT, UNCHECK "allow windows to turn off device to conserver power" (or whatever it says)

Reboot. Make a difference?
  • 0

#6
doire

doire

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 210 posts
Will i take the stick out first. With it in it is showing up as USB Mass Storage Device but when i click on its properties it has no "Power Management" option.

When its out i just have four seperate "USB Root Hubs" showing up.
  • 0

#7
vsalzman

vsalzman

    Member

  • Member
  • PipPip
  • 37 posts
I've had this same problem with several memory sticks, assigning it a drive letter does work. Do this through Disk Management.

Right click on My Computer
Choose Manage
Click on Disk Management
Locate the memory stick in the right side of the screen
Right click on it and choose Change Drive Letter
Choose any free drive letter
The next time you plug it in, it will be assigned that letter
  • 0

#8
gerryf

gerryf

    Retired Staff

  • Retired Staff
  • 11,365 posts
Do it with the HUBS

That said, vsalzman says he has had experience here. I have not. So follow his advice.
  • 0

#9
doire

doire

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 210 posts
Hello,

Still not working.

I have tried what you said Gerry.

I have also renamed the stick a new drive letter...first time Drive E and second time Drive Y but it didnt work.

It only shows up if i log out and log back in again.

I can also see it in the "Safely Remove Hardware" procedure and can remove it.

Its very strange that i cant see it in My Computer or Windows Explorer. :tazz:
  • 0

#10
gerryf

gerryf

    Retired Staff

  • Retired Staff
  • 11,365 posts
a few odd motherboards have rare chipsets that require special usb drivers even though windows xp supports usb natively. Go to our download section, grab everest from the hardware section and ATTACH a report
  • 0

#11
doire

doire

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 210 posts
Gerry,
Everest wont let me install it as this is a networked pc....not a home pc.

Its strange that when i put the stick in....log off and log on again....the stick shows up....but if i take it out....put it back in and go to Win Explorer its not there. :tazz:

I have also tired sfc /scannow but it doesnt pick up any missing files.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP