Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

display properties


  • Please log in to reply

#1
Confused a lot

Confused a lot

    Member

  • Member
  • PipPip
  • 10 posts
A picture is a thousand words!
Posted Image
Where are the tabs gone?
I have tried sfc /scannow but that did not work, so I don't think it is file corruption.
I know I am not infected, and never have been badly infected.
Anyone know what it might be? Registry?

Many thanks to any person kind enough to help me.
  • 0

Advertisements


#2
makai

makai

    Portlock - Oahu

  • Member
  • PipPipPipPipPip
  • 2,793 posts
Hello, Welcome to GTG!

Lets hope this is an easy fix!

Go HERE and scroll down the page to #285

In the right pane, you will see Restore All Dispay Tabs... right click on it and choose Save as from the menu. Save the file to your Desktop and give it a name... something easy to remember, like "tabs", for instance.

Close all windows, and double click on the downloaded file. Confirm "yes" to any prompts.

Go ahead and check to see if your Display tabs returned. If not, you may have to restart your computer so the changes can take effect.

Note... A lot of times, this particular problem can indicate Malware. I advise you to go HERE and follow all the directions/recommendations. If you find you do have Malware present on your computer and you cannot get rid of all of it, or you're not sure you did, please create a post in the MALWARE FORUM and explain any problems you have. Please be as specific as possible.
  • 0

#3
Confused a lot

Confused a lot

    Member

  • Topic Starter
  • Member
  • PipPip
  • 10 posts
Thank very much for you great help, only the help did not work :)

I downloaded and ran the .reg file but it did not fix it. Tried it several times, and then tried downloading it again. I know...
Stupidity: doing the same thing over and over when the same result is expected. :tazz:

I am not infected I am sure. I ran AVG anti virus, Spybot, and Adware SE nothing more than a tracking cookie. Ran CCleaner last night. I have Kerio Firewall and FireFox. And got This as well. Ran Hijack This, I know how to read logs to some extent, nothing that I did not recognize.

I can access one of the other tabs by typing "control color" in the run box. But the is only one tab, and I want all of them at once.

Many thanks for all you help, time and patience.
Confused a lot
  • 0

#4
makai

makai

    Portlock - Oahu

  • Member
  • PipPipPipPipPip
  • 2,793 posts
Hello,

Sorry that didn't work. Normally Kelly's stuff works wonders!

Are you able to see all the tabs if you access the Display Properties via Control Panel?

What you could try is...
Go to Start/run... type in chkdsk /f
You may get a prompt asking if you want to run it at next startup... just confirm "y" (yes).
Restart your machine.

Ran CCleaner last night

While CCleaner is a good app, I find it very dangerous... this was through experienc,btw. CCleaner is capable of deleting valid registry entries it "thinks" are remnants, when in fact they are not. I don't recommend this program to anyone. Use with caution!

The link you posted led me to a microsoft site with no specific information... I did note a redirect in the address bar, but every attempt to visit the link led me to the microsoft page.
Stupidity: doing the same thing over and over when the same result is expected. :tazz: (quote/unquote)

Would you do me a favor and "attach" a HijactThis log to your next reply. Please use the Add This Attachment function below the posting window, and DO NOT copy/paste the log into your reply. HijackThis logs tend to make reading posts really difficult. Thanks.
  • 0

#5
Fenor

Fenor

    Trusted Tech

  • Retired Staff
  • 5,236 posts
* REMOVED by ME :tazz: *

Fenor

Edited by Fenor, 17 March 2006 - 08:43 AM.

  • 0

#6
Confused a lot

Confused a lot

    Member

  • Topic Starter
  • Member
  • PipPip
  • 10 posts
I have noticed before when bad links are posted I get redirected to www.microsoft.com. Here is the link again http://www.mvps.org/...p2002/hosts.htm

Kelly's stuff is normaly great, from personal experance but no luck this time.

I can't see any of the tabs execpt the one shown in the picture when accessing the Display Properties via Control Panel.

I ran check disk(chkdsk), no luck.

I don't use the registry feature in CCleaner. From personal tests it is a bad idea to use any registry cleaner (I have not install any since two formats ago) they do an amazing amout of damage. I only use the temp file deleteing feature of CCleaner.

I attached a log. If I may make a guess (I used to know the rules here well) you don't wan't logs in this form because then people useing Google or yahoo etc. find them here and post them here instead of the malware forum. Blair(admin) once said that I remember.

Hi Fenor, nice to see your still here. :tazz: I have not been active for so long I have forgoten my password to my former GeeksToGo accout. Also not useing computers much over that time has caused me to forget how to fix problems like this one. :) Easy come (learnt alot in 9 months) easy go (forgot a lot in 5 months)

Attached Files


  • 0

#7
wannabe1

wannabe1

    Tech Staff

  • Technician
  • 16,645 posts
Hi

Let's take a look at a couple of registry keys...

Navigate to HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System

What values are listed in the Data column for the following:

"NoDispAppearancePage"
"NoColorChoice"=dword"
"NoSizeChoice"=dword"
"NoDispBackgroundPage"
"NoDispScrSavPage"
"NoDispCPL"
"NoVisualStyleChoice"
"NoDispSettingsPage"
"NoDispScrSavPage"
"NoVisualStyleChoice"
"NoSizeChoice"

wannabe1
  • 0

#8
Confused a lot

Confused a lot

    Member

  • Topic Starter
  • Member
  • PipPip
  • 10 posts
Same as for the .reg file makai asked me to run. 0 for all of them

Here is a copy of a reg file made from my registry so you can see for your self.

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System]
"NoDispAppearancePage"=dword:00000000
"NoColorChoice"=dword:00000000
"NoSizeChoice"=dword:00000000
"NoDispBackgroundPage"=dword:00000000
"NoDispScrSavPage"=dword:00000000
"NoDispCPL"=dword:00000000
"NoVisualStyleChoice"=dword:00000000
"NoDispSettingsPage"=dword:00000000

I tested if in a new user accout it would work. It did not :tazz:

Thanks for all you help!

I am going to go back to Google (I did plenty of Googleing before I come here but maybe I might find something I have not already seen yet.) Hope I find something.
  • 0

#9
wannabe1

wannabe1

    Tech Staff

  • Technician
  • 16,645 posts
Hi Confused a lot...

I'm glad you posted the whole key...you are missing the "Default" string. Return to that key, right click in the right pane, point to "New" (only choice), and choose "New String Value". Type (Default) as the name of the string and click in the right pane to set the change. (It should look like this when you finish: (Default)...REG_SZ...(value not set)

Reboot...do you now have tabs?

wannabe1
  • 0

#10
Confused a lot

Confused a lot

    Member

  • Topic Starter
  • Member
  • PipPip
  • 10 posts
The "Default" string was there. I used export function to get the extract shown above. I have noticed that when you export a registry key the default value is not exported unless it has a value assinged to it. You learn something knew every day :tazz:

Sorry that caused confusion.
Confused a lot
  • 0

#11
wannabe1

wannabe1

    Tech Staff

  • Technician
  • 16,645 posts
You're right! You DO learn something new everyday... :tazz:

Take a look at the following keys...

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System]

[HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\System]

We're looking for the string value: "NoDispAppearancePage" in either or both of those keys...if found, set the value to 0

Edited by wannabe1, 18 March 2006 - 06:34 PM.

  • 0

#12
Confused a lot

Confused a lot

    Member

  • Topic Starter
  • Member
  • PipPip
  • 10 posts
I am starting to feel not so stupid that I could not fix this my self.
Thanks for all your help so far.

I found the value "NoDispAppearancePage" in [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System] with a value of 0
It was not in [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\System]

If this never gets fixed it dose not mater to much I could always access each tab (execpt the web tab) with run commands like
rundll32.exe shell32.dll,Control_RunDLL desk.cpl,,0
rundll32.exe shell32.dll,Control_RunDLL desk.cpl,,1
rundll32.exe shell32.dll,Control_RunDLL desk.cpl,,2
rundll32.exe shell32.dll,Control_RunDLL desk.cpl,,3
rundll32.exe shell32.dll,Control_RunDLL desk.cpl,,5
Leaving out 4 was not a mistake, it just gives the same as 3.

Confused a lot

Edited by Confused a lot, 18 March 2006 - 10:25 PM.

  • 0

#13
Confused a lot

Confused a lot

    Member

  • Topic Starter
  • Member
  • PipPip
  • 10 posts
Ok Problem solved!

Thanks for all your help wannabe1, makai, and even fenor. Your help has been great and very professional. Thanks for all the time you must spend helping others in need. Your awesome.

But the answer is weirder than the problem. I found it after 5 hours Googleing. Here is the link http://groups.google...54c12f9738f937f

The solution was to find two copies of comctl32.dll. I found the in
C:\WINDOWS\system32\comctl32.dll (545 KB)
C:\WINDOWS\WinSxS\x86_Microsoft.Windows.Common-Controls_6595b64144ccf1df_6.0.0.0_x-ww_1382d70a\comctl32.dll (900 KB)
Putting the bigger over the smaller fixed it. (that is after getting rid of the smaller which was hard, luckly I have unlocker which made it easyer). And then rebooting.

Now why that worked, or how the smaller copy was in C:\WINDOWS\system32\ if it causes this problem is beond me.

Again thanks for all your help every one
Confused a lot
  • 0

#14
wannabe1

wannabe1

    Tech Staff

  • Technician
  • 16,645 posts
Thanks for posting your resolution. I found that "fix" last night on Google Groups, but was trying to verify that it worked before I posted...Ain't Google great!!?? :tazz:

wannabe1

Edited by wannabe1, 19 March 2006 - 06:09 AM.

  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP