Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Big Problem with internet connection...need URGENT HELP!


  • Please log in to reply

#1
domyue

domyue

    Member

  • Member
  • PipPipPip
  • 129 posts
Hi, I've developed a big problem. I've got exams coming up and I reallllly need an internet connection at home. I recently updated my zonealarm and then my pc now doesn't connect to the internet.

- Before upgrade it was fine, afterwards I get "limited or no connectivity". I have a netgear router and my LAN ip is normally 192.168.0.x
- Now, the LAN IP is something drastically different (e.g. 169.254.xx.xx) PLUS my Subnet Mask is 255.255.0.0 as opposed to 255.255.255.0
- Cannot connect to the internet (can't acquire the WAN IP when I use IP2 either)

- I've not uninstalled zonealarm and it still can't acquire a proper IP address (when i click repair, it can't renew ip)
- I've tried resetting the router and doesn't work

PLEASE, PLEASE, PLEASEEEE HELP!!
THANKS,
Dom

Edited by domyue, 27 March 2006 - 09:21 PM.

  • 0

Advertisements


#2
Retired Tech

Retired Tech

    Retired Staff

  • Retired Staff
  • 20,563 posts
Can you use another PC to download and save this to disc / floppy to run on your PC

http://www.geekstogo...n=download&id=7

This Utility Restores (WinSock and TCP/IP) Registry Keys, that may become Corrupt after Removing the Host Program that Modified them
  • 0

#3
domyue

domyue

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 129 posts
AHHH it works now!!!
THanks a lot guys

But...i installed zonealarm again and now it doesn't save settings for "allow/deny" programs when I reboot.........
  • 0

#4
Retired Tech

Retired Tech

    Retired Staff

  • Retired Staff
  • 20,563 posts
Did you download from ZoneLabs, they just updated it today
  • 0

#5
domyue

domyue

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 129 posts
initially i didnt get it from the main site, but then I updated the program when it told me to...so the version right now should be from the website officially (since the dld was 23mb...)
Still it can't remember my settings....still asks me for antivirus and firefox, etc.... settings even after I click "remember this setting".

Thanks
  • 0

#6
Retired Tech

Retired Tech

    Retired Staff

  • Retired Staff
  • 20,563 posts
If you downloaded the file, click it to start set up then choose clean install instead of upgrade, then click yes for the security check
  • 0

#7
domyue

domyue

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 129 posts
Yeah I did a clean install. I can't think why it won't save the configurations. Any ideas would be greatly appreciated
  • 0

#8
domyue

domyue

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 129 posts
I think i might have found the reason....

I had the WaitToKillApp registry setting changed......so it might have killed zonealarm at shutdown and not saved the settings (as it is quite a slow program as I understand...) - this would essentially mean that it was "improperly" shutdown and hence it will follow its old backup copy of settings (which would be no settings at all since its a new install).

I'm going to try increasing it. Do you think its WaitToKillApp?? Cos I also changed HungAppTimeout and the WaitToKillServiceTimeout - which of the three do you think will shut down zonealarm prematurely???

Thanks a lot!
  • 0

#9
Retired Tech

Retired Tech

    Retired Staff

  • Retired Staff
  • 20,563 posts
Set them to their defaults and see which is responsible, if any, ZA should remember from when you tick the box and click apply
  • 0

#10
domyue

domyue

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 129 posts
I'll test it out, it seems that when I shutdown ZA (just ZA) and restart ZA, it remembers the settings.
So it must be the shutting down of PC process.

I'll see how it goes,
Thanks again
  • 0

#11
Retired Tech

Retired Tech

    Retired Staff

  • Retired Staff
  • 20,563 posts
Next time you get the box, tick it click apply and reboot, rather than shutdown the PC, see if ZA remembers the setting
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP